aboutsummaryrefslogtreecommitdiff
path: root/devel/z80ex
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-04 00:40:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-04 00:40:05 +0000
commit2a8a40981c2bc7ba306df3348c95e2b4eacb7b05 (patch)
tree6c14f330164c7249304e0a78b864857dcaed72fc /devel/z80ex
parentc4ab2a49a2cb556a44b88b117d7006aae21b9778 (diff)
Notes
Diffstat (limited to 'devel/z80ex')
-rw-r--r--devel/z80ex/Makefile19
-rw-r--r--devel/z80ex/distinfo3
-rw-r--r--devel/z80ex/files/patch-Makefile19
-rw-r--r--devel/z80ex/pkg-descr3
-rw-r--r--devel/z80ex/pkg-plist12
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/z80ex/Makefile b/devel/z80ex/Makefile
new file mode 100644
index 000000000000..8ca973ec9375
--- /dev/null
+++ b/devel/z80ex/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: z80ex
+# Date created: 22 December 2009
+# Whom: Hardy Schumacher <hardy.schumacher@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= z80ex
+PORTVERSION= 1.1.18
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= hardy.schumacher@gmx.de
+COMMENT= ZiLOG Z80 CPU emulator library
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/z80ex/distinfo b/devel/z80ex/distinfo
new file mode 100644
index 000000000000..56281ab950ab
--- /dev/null
+++ b/devel/z80ex/distinfo
@@ -0,0 +1,3 @@
+MD5 (z80ex-1.1.18.tar.gz) = f46283f976c1b4b59965a00a4d822317
+SHA256 (z80ex-1.1.18.tar.gz) = 85eb8b883498f9890e8cb6edccb77e42c82f939f8b81972780744b587db4bc6c
+SIZE (z80ex-1.1.18.tar.gz) = 63563
diff --git a/devel/z80ex/files/patch-Makefile b/devel/z80ex/files/patch-Makefile
new file mode 100644
index 000000000000..b2f52487de48
--- /dev/null
+++ b/devel/z80ex/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- ./Makefile.orig 2010-02-03 19:56:53.000000000 +0100
++++ ./Makefile 2010-02-03 19:57:20.000000000 +0100
+@@ -5,8 +5,7 @@
+ #################################################################
+ # You may tune these values to feet your setup:
+ #################################################################
+-INSTALL_PREFIX := /usr/local
+-CC := gcc
++INSTALL_PREFIX := ${PREFIX}
+ ALL_CFLAGS := -fPIC -fno-common -ansi -pedantic -Wall -pipe -O2 -I. -I./include
+ LINKER := gcc
+
+@@ -93,4 +92,4 @@
+ tar --exclude z80ex.geany --exclude obsolete --exclude ${PROJ}-${VERSION_STR}${RELEASE_TYPE}/${PROJ}-${VERSION_STR}${RELEASE_TYPE} --exclude ${PROJ}-${VERSION_STR}${RELEASE_TYPE}/${PROJ}-${VERSION_STR}${RELEASE_TYPE}.tar.gz -hcf - ./${PROJ}-${VERSION_STR}${RELEASE_TYPE}/ | gzip -f9 > ${PROJ}-${VERSION_STR}${RELEASE_TYPE}.tar.gz
+ rm -rf ./${PROJ}-${VERSION_STR}${RELEASE_TYPE}
+
+-#EOF
+\ No newline at end of file
++#EOF
diff --git a/devel/z80ex/pkg-descr b/devel/z80ex/pkg-descr
new file mode 100644
index 000000000000..47d237130081
--- /dev/null
+++ b/devel/z80ex/pkg-descr
@@ -0,0 +1,3 @@
+Portable ZiLOG Z80 CPU emulator library.
+
+WWW: http://z80ex.sourceforge.net
diff --git a/devel/z80ex/pkg-plist b/devel/z80ex/pkg-plist
new file mode 100644
index 000000000000..7c8105284288
--- /dev/null
+++ b/devel/z80ex/pkg-plist
@@ -0,0 +1,12 @@
+include/z80ex/z80ex.h
+include/z80ex/z80ex_common.h
+include/z80ex/z80ex_dasm.h
+lib/libz80ex.a
+lib/libz80ex.so.1
+lib/libz80ex_dasm.a
+lib/libz80ex_dasm.so.1
+lib/libz80ex.so
+lib/libz80ex.so.1.1.18
+lib/libz80ex_dasm.so
+lib/libz80ex_dasm.so.1.1.18
+@dirrm include/z80ex