aboutsummaryrefslogtreecommitdiff
path: root/devel/zmq
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2008-07-29 06:09:53 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2008-07-29 06:09:53 +0000
commitb9e37d59dfa43e9c70b9ce04efcccdaf2286816d (patch)
treeb6e0d299474a889866599538bc1a2f90f8d67274 /devel/zmq
parentced8cf93c6edf322df4579197912d89f0d50403a (diff)
downloadports-b9e37d59dfa43e9c70b9ce04efcccdaf2286816d.tar.gz
ports-b9e37d59dfa43e9c70b9ce04efcccdaf2286816d.zip
Notes
Diffstat (limited to 'devel/zmq')
-rw-r--r--devel/zmq/Makefile19
-rw-r--r--devel/zmq/distinfo3
-rw-r--r--devel/zmq/pkg-descr3
-rw-r--r--devel/zmq/pkg-plist40
4 files changed, 65 insertions, 0 deletions
diff --git a/devel/zmq/Makefile b/devel/zmq/Makefile
new file mode 100644
index 000000000000..ce9ecf41de2f
--- /dev/null
+++ b/devel/zmq/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: zmq
+# Date created: 2008-07-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zmq
+PORTVERSION= 0.2
+CATEGORIES= devel net
+MASTER_SITES= http://www.zeromq.org/local--files/area:download/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Open source message queue optimised for performance
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/zmq/distinfo b/devel/zmq/distinfo
new file mode 100644
index 000000000000..b67206b65f57
--- /dev/null
+++ b/devel/zmq/distinfo
@@ -0,0 +1,3 @@
+MD5 (zmq-0.2.tar.gz) = e3f9876311b843de96176f8e392a1d19
+SHA256 (zmq-0.2.tar.gz) = d32f36b5e196a965999372e5cf51a53b84ff49e4e487aa82179594e6d0eb93c5
+SIZE (zmq-0.2.tar.gz) = 384601
diff --git a/devel/zmq/pkg-descr b/devel/zmq/pkg-descr
new file mode 100644
index 000000000000..f0ae7b25a473
--- /dev/null
+++ b/devel/zmq/pkg-descr
@@ -0,0 +1,3 @@
+An open source message queue optimised for performance.
+
+WWW: http://www.zeromq.org/
diff --git a/devel/zmq/pkg-plist b/devel/zmq/pkg-plist
new file mode 100644
index 000000000000..267b74d02292
--- /dev/null
+++ b/devel/zmq/pkg-plist
@@ -0,0 +1,40 @@
+@comment $FreeBSD$
+include/zmq/amqp09_client_fsm.hpp
+include/zmq/amqp09_decoder.hpp
+include/zmq/amqp09_encoder.hpp
+include/zmq/amqp09_engine.hpp
+include/zmq/amqp09_marshaller.hpp
+include/zmq/amqp09_server_fsm.hpp
+include/zmq/amqp09_unmarshaller.hpp
+include/zmq/api_engine.hpp
+include/zmq/atomic_ptr.hpp
+include/zmq/atomic_uint32.hpp
+include/zmq/bp_decoder.hpp
+include/zmq/bp_encoder.hpp
+include/zmq/bp_engine.hpp
+include/zmq/cmsg.hpp
+include/zmq/decoder.hpp
+include/zmq/dispatcher.hpp
+include/zmq/dispatcher_proxy.hpp
+include/zmq/encoder.hpp
+include/zmq/err.hpp
+include/zmq/free_fn.hpp
+include/zmq/i_amqp09.hpp
+include/zmq/i_pollable.hpp
+include/zmq/i_signaler.hpp
+include/zmq/platform.hpp
+include/zmq/poll_thread.hpp
+include/zmq/stdint.hpp
+include/zmq/tcp_socket.hpp
+include/zmq/wire.hpp
+include/zmq/ydispatcher.hpp
+include/zmq/ydispatcher_proxy.hpp
+include/zmq/ypipe.hpp
+include/zmq/ypollset.hpp
+include/zmq/ysemaphore.hpp
+include/zmq/ysocketpair.hpp
+lib/libzmq.a
+lib/libzmq.la
+lib/libzmq.so
+lib/libzmq.so.0
+@dirrmtry include/zmq