aboutsummaryrefslogtreecommitdiff
path: root/devel/zthread
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-18 15:40:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-18 15:40:54 +0000
commit8afefff003a314f08a312b4a9c91481338256b19 (patch)
treeab32f30e5588bbd53fe57f696591519df37e2e64 /devel/zthread
parent934eb9e7657113ae9c65f4d8707ad5b7a87387ac (diff)
downloadports-8afefff003a314f08a312b4a9c91481338256b19.tar.gz
ports-8afefff003a314f08a312b4a9c91481338256b19.zip
Notes
Diffstat (limited to 'devel/zthread')
-rw-r--r--devel/zthread/Makefile27
-rw-r--r--devel/zthread/distinfo4
-rw-r--r--devel/zthread/files/patch-configure12
-rw-r--r--devel/zthread/files/patch-ltmain.sh15
-rw-r--r--devel/zthread/pkg-descr2
-rw-r--r--devel/zthread/pkg-plist296
6 files changed, 38 insertions, 318 deletions
diff --git a/devel/zthread/Makefile b/devel/zthread/Makefile
index 184fe5bea926..a3bd0ec67b70 100644
--- a/devel/zthread/Makefile
+++ b/devel/zthread/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= zthread
-PORTVERSION= 1.5.1
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= devel
-MASTER_SITES= http://www.cs.buffalo.edu/~crahen/projects/zthread/ \
- ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ZThread-${PORTVERSION}
@@ -18,11 +16,13 @@ MAINTAINER= wjv@FreeBSD.org
COMMENT= A platform-independent object-oriented C++ threading library
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-ftime
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
.include <bsd.port.pre.mk>
@@ -30,14 +30,23 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
BROKEN= "Does not compile on ${ARCH}; mixes pointers and ints"
.endif
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+.endif
+
+post-extract:
+ @${FIND} ${WRKSRC} -name CVS -type d -delete
+
post-install:
+ @${FIND} ${PREFIX}/include/zthread -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm include/zthread" >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/html ${EXAMPLESDIR}
+ @${MKDIR} ${DOCSDIR}/html
.for docfile in AUTHORS ChangeLog NEWS README TODO
${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/doc/html/ ${DOCSDIR}/html
.endif
.include <bsd.port.post.mk>
diff --git a/devel/zthread/distinfo b/devel/zthread/distinfo
index b24d915be620..61eb32242af7 100644
--- a/devel/zthread/distinfo
+++ b/devel/zthread/distinfo
@@ -1,2 +1,2 @@
-MD5 (ZThread-1.5.1.tar.gz) = 08d3a4fcede8252ce3bd5f28e4bdda77
-SIZE (ZThread-1.5.1.tar.gz) = 443995
+MD5 (ZThread-2.3.1.tar.gz) = 21c3075808b04949bec419010b0d188c
+SIZE (ZThread-2.3.1.tar.gz) = 427364
diff --git a/devel/zthread/files/patch-configure b/devel/zthread/files/patch-configure
deleted file mode 100644
index 461b73379c18..000000000000
--- a/devel/zthread/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig Sun Aug 26 20:27:01 2001
-+++ configure Wed Nov 14 16:02:31 2001
-@@ -4428,7 +4428,8 @@
- # All known linkers require a `.a' archive for static linking (except M$VC,
- # which needs '.lib').
- libext=a
--ltmain="$ac_aux_dir/ltmain.sh"
-+ac_aux_dir_tmp="$ac_aux_dir"
-+ltmain="$ac_aux_dir_tmp/ltmain.sh"
- ofile="$default_ofile"
- with_gnu_ld="$lt_cv_prog_gnu_ld"
- need_locks="$enable_libtool_lock"
diff --git a/devel/zthread/files/patch-ltmain.sh b/devel/zthread/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0e4f1ce2927b
--- /dev/null
+++ b/devel/zthread/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Apr 1 11:53:22 2004
++++ ltmain.sh Thu Apr 1 11:53:33 2004
+@@ -4210,10 +4210,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/zthread/pkg-descr b/devel/zthread/pkg-descr
index 91abdf7c12a3..44509a01ab50 100644
--- a/devel/zthread/pkg-descr
+++ b/devel/zthread/pkg-descr
@@ -13,6 +13,6 @@ Paraphrasing the website:
ZThread implementations are provided for POSIX and Win32 platforms.
Author: Eric Crahen <crahen@cse.buffalo.edu>
-WWW: http://www.cse.buffalo.edu/~crahen/projects/zthread/
+WWW: http://zthread.sourceforge.net/
-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/devel/zthread/pkg-plist b/devel/zthread/pkg-plist
index 66edf4a70fae..a3f6953629c1 100644
--- a/devel/zthread/pkg-plist
+++ b/devel/zthread/pkg-plist
@@ -1,299 +1,7 @@
-%%PORTDOCS%%share/doc/zthread/AUTHORS
-%%PORTDOCS%%share/doc/zthread/ChangeLog
-%%PORTDOCS%%share/doc/zthread/NEWS
-%%PORTDOCS%%share/doc/zthread/README
-%%PORTDOCS%%share/doc/zthread/TODO
-%%PORTDOCS%%share/doc/zthread/html/annotated.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AbstractExecutor-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AbstractExecutor.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AbstractExecutor.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AbstractThreadLocal-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AbstractThreadLocal.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AbstractThreadLocal.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AsyncExecutor-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AsyncExecutor.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AsyncExecutor.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AutoPtr-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1AutoPtr.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Barrier-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Barrier.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Barrier.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BiasedRWLock-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BiasedRWLock.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BiasedRWLock.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BlockingQueue-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BlockingQueue.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BlockingQueue.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BufferedQueue-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BufferedQueue.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1BufferedQueue.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Cancelable-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Cancelable.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Cancelable.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Cancelation__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Cancelation__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Cancelation__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1CheckedMutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1CheckedMutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1CheckedMutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Condition-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Condition.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1CountingSemaphore-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1CountingSemaphore.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1CountingSemaphore.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Deadlock__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Deadlock__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Deadlock__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Executor-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Executor.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Executor.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Factory-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Factory.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FairRWLock-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FairRWLock.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FairRWLock.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastMutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastMutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastMutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastRecursiveMutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastRecursiveMutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastRecursiveMutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastThreadLocal-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastThreadLocal.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1FastThreadLocal.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Guard-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Guard.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1InheritableThreadLocal-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1InheritableThreadLocal.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1InheritableThreadLocal.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Initialization__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Initialization__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Initialization__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Interrupted__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Interrupted__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Interrupted__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1InvalidOp__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1InvalidOp__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1InvalidOp__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Latch-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Latch.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Latch.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Lockable-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Lockable.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Lockable.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1LockedQueue-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1LockedQueue.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1LockedQueue.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1MonitoredQueue-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1MonitoredQueue.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1MonitoredQueue.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Mutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Mutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Mutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1NoSuchElement__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1NoSuchElement__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1NullMutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1NullMutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1NullMutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Observable-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Observable.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Observable.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1PlainMutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1PlainMutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1PlainMutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1PoolExecutor-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1PoolExecutor.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1PoolExecutor.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Queue-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Queue.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Queue.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RLock-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RLock.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RLock.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RWLock-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RWLock.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RWLock.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RecursiveMutex-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RecursiveMutex.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1RecursiveMutex.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Runnable-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Runnable.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Runnable.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Semaphore-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Semaphore.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Semaphore.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SharedInstance-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SharedInstance.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SimpleQueue-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SimpleQueue.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SimpleQueue.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Singleton-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Singleton.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SingletonDestroyer-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SingletonDestroyer.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1StaticSingleton-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1StaticSingleton.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SyncExecutor-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SyncExecutor.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1SyncExecutor.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Synchronization__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Synchronization__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Synchronization__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Thread-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Thread.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Thread.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1ThreadLocal-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1ThreadLocal.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1ThreadLocal.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Timeout__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Timeout__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Timeout__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Timer-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Timer.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Timer.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerEvent-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerEvent.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerListener-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerListener.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerThread-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerThread.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1TimerThread.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Unexpected__Exception-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Unexpected__Exception.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Unexpected__Exception.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1WLock-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1WLock.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1WLock.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Worker-members.html
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Worker.gif
-%%PORTDOCS%%share/doc/zthread/html/classZThread_1_1Worker.html
-%%PORTDOCS%%share/doc/zthread/html/doxygen.css
-%%PORTDOCS%%share/doc/zthread/html/doxygen.gif
-%%PORTDOCS%%share/doc/zthread/html/functions.html
-%%PORTDOCS%%share/doc/zthread/html/hierarchy.html
-%%PORTDOCS%%share/doc/zthread/html/index.html
-%%PORTDOCS%%share/doc/zthread/html/namespace__ZThread.html
-%%PORTDOCS%%share/doc/zthread/html/namespaces.html
-%%PORTDOCS%%share/examples/zthread/BARRIER_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/BarrierExample
-%%PORTDOCS%%share/examples/zthread/BarrierExample.cxx
-%%PORTDOCS%%share/examples/zthread/BarrierExample.o
-%%PORTDOCS%%share/examples/zthread/CONDITION_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/ConditionExample
-%%PORTDOCS%%share/examples/zthread/ConditionExample.cxx
-%%PORTDOCS%%share/examples/zthread/ConditionExample.o
-%%PORTDOCS%%share/examples/zthread/EXECUTOR_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/ExecutorExample
-%%PORTDOCS%%share/examples/zthread/ExecutorExample.cxx
-%%PORTDOCS%%share/examples/zthread/ExecutorExample.o
-%%PORTDOCS%%share/examples/zthread/ExternalExecutor.cxx
-%%PORTDOCS%%share/examples/zthread/ExternalExecutor.h
-%%PORTDOCS%%share/examples/zthread/ExternalExecutor.o
-%%PORTDOCS%%share/examples/zthread/FactoryExample
-%%PORTDOCS%%share/examples/zthread/FactoryExample.cxx
-%%PORTDOCS%%share/examples/zthread/FactoryExample.o
-%%PORTDOCS%%share/examples/zthread/MUTEX_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/Makefile
-%%PORTDOCS%%share/examples/zthread/Makefile.am
-%%PORTDOCS%%share/examples/zthread/Makefile.in
-%%PORTDOCS%%share/examples/zthread/MutexExample
-%%PORTDOCS%%share/examples/zthread/MutexExample.cxx
-%%PORTDOCS%%share/examples/zthread/MutexExample.o
-%%PORTDOCS%%share/examples/zthread/QUEUE_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/QueueExample
-%%PORTDOCS%%share/examples/zthread/QueueExample.cxx
-%%PORTDOCS%%share/examples/zthread/QueueExample.o
-%%PORTDOCS%%share/examples/zthread/SEMAPHORE_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/SERVICE_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/SINGLETON_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/SLEEP_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/SemaphoreExample
-%%PORTDOCS%%share/examples/zthread/SemaphoreExample.cxx
-%%PORTDOCS%%share/examples/zthread/SemaphoreExample.o
-%%PORTDOCS%%share/examples/zthread/ServiceExample
-%%PORTDOCS%%share/examples/zthread/ServiceExample.cxx
-%%PORTDOCS%%share/examples/zthread/ServiceExample.o
-%%PORTDOCS%%share/examples/zthread/SingletonExample
-%%PORTDOCS%%share/examples/zthread/SingletonExample.cxx
-%%PORTDOCS%%share/examples/zthread/SingletonExample.o
-%%PORTDOCS%%share/examples/zthread/SleepExample
-%%PORTDOCS%%share/examples/zthread/SleepExample.cxx
-%%PORTDOCS%%share/examples/zthread/SleepExample.o
-%%PORTDOCS%%share/examples/zthread/StdAfx.cpp
-%%PORTDOCS%%share/examples/zthread/StdAfx.h
-%%PORTDOCS%%share/examples/zthread/THREADLOCAL_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/THREAD_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/TIMEOUT_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/TIMER_EXAMPLE.dsp
-%%PORTDOCS%%share/examples/zthread/ThreadExample
-%%PORTDOCS%%share/examples/zthread/ThreadExample.cxx
-%%PORTDOCS%%share/examples/zthread/ThreadExample.o
-%%PORTDOCS%%share/examples/zthread/ThreadLocalExample
-%%PORTDOCS%%share/examples/zthread/ThreadLocalExample.cxx
-%%PORTDOCS%%share/examples/zthread/ThreadLocalExample.o
-%%PORTDOCS%%share/examples/zthread/TimeoutExample
-%%PORTDOCS%%share/examples/zthread/TimeoutExample.cxx
-%%PORTDOCS%%share/examples/zthread/TimeoutExample.o
-%%PORTDOCS%%share/examples/zthread/TimerExample
-%%PORTDOCS%%share/examples/zthread/TimerExample.cxx
-%%PORTDOCS%%share/examples/zthread/TimerExample.o
bin/zthread-config
-include/zthread/AbstractExecutor.h
-include/zthread/AbstractThreadLocal.h
-include/zthread/AsyncExecutor.h
-include/zthread/AutoPtr.h
-include/zthread/Barrier.h
-include/zthread/BiasedRWLock.h
-include/zthread/BlockingQueue.h
-include/zthread/BufferedQueue.h
-include/zthread/Cancelable.h
-include/zthread/CheckedMutex.h
-include/zthread/Condition.h
-include/zthread/CountingSemaphore.h
-include/zthread/Executor.h
-include/zthread/Factory.h
-include/zthread/FairRWLock.h
-include/zthread/FastMutex.h
-include/zthread/FastRecursiveMutex.h
-include/zthread/FastThreadLocal.h
-include/zthread/Guard.h
-include/zthread/InheritableThreadLocal.h
-include/zthread/Latch.h
-include/zthread/Lockable.h
-include/zthread/LockedQueue.h
-include/zthread/MonitoredQueue.h
-include/zthread/Mutex.h
-include/zthread/NullMutex.h
-include/zthread/Observable.h
-include/zthread/POSIX_FastMutex.h
-include/zthread/POSIX_FastRecursiveMutex.h
-include/zthread/PlainMutex.h
-include/zthread/PoolExecutor.h
-include/zthread/Queue.h
-include/zthread/RWLock.h
-include/zthread/RecursiveMutex.h
-include/zthread/Semaphore.h
-include/zthread/SharedInstance.h
-include/zthread/SimpleQueue.h
-include/zthread/Singleton.h
-include/zthread/SyncExecutor.h
-include/zthread/SynchronizationExceptions.h
-include/zthread/Thread.h
-include/zthread/ThreadLocal.h
-include/zthread/Timer.h
-include/zthread/TimerThread.h
-include/zthread/WIN32_FastMutex.h
-include/zthread/WIN32_FastRecursiveMutex.h
-include/zthread/Worker.h
-include/zthread/ZThread.h
-lib/libZThread-1.5.so
-lib/libZThread-1.5.so.1
+lib/libZThread-2.3.so
+lib/libZThread-2.3.so.1
lib/libZThread.a
-lib/libZThread.la
lib/libZThread.so
share/aclocal/pthread.m4
share/aclocal/zthread.m4
-@dirrm include/zthread
-%%PORTDOCS%%@dirrm share/examples/zthread
-%%PORTDOCS%%@dirrm share/doc/zthread/html
-%%PORTDOCS%%@dirrm share/doc/zthread