aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-06-21 10:58:30 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-06-21 10:58:30 +0000
commit05b327da1c50b95631b0765b07c2c64a907289e8 (patch)
tree26260a96d82659b42bae3b186738022c0e946b3a /devel
parentb21ca3628bda4dc8765eef504affc9572deedf9b (diff)
downloadports-05b327da1c50b95631b0765b07c2c64a907289e8.tar.gz
ports-05b327da1c50b95631b0765b07c2c64a907289e8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Directory-Queue/Makefile23
-rw-r--r--devel/p5-Directory-Queue/distinfo3
-rw-r--r--devel/p5-Directory-Queue/pkg-descr6
-rw-r--r--devel/p5-Directory-Queue/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2601b04682c2..4ea3061faaf3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1519,6 +1519,7 @@
SUBDIR += p5-Digest-TransformPath
SUBDIR += p5-Dir-Project
SUBDIR += p5-Dir-Watch
+ SUBDIR += p5-Directory-Queue
SUBDIR += p5-Directory-Scratch
SUBDIR += p5-Directory-Scratch-Structured
SUBDIR += p5-EV
diff --git a/devel/p5-Directory-Queue/Makefile b/devel/p5-Directory-Queue/Makefile
new file mode 100644
index 000000000000..15f572507b4d
--- /dev/null
+++ b/devel/p5-Directory-Queue/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: devel/p5-Directory-Queue
+# Date created: 21 June 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Directory-Queue
+PORTVERSION= 0.5
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Directory
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Object oriented interface to a directory based queue in Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Directory::Queue.3 \
+ Directory::Queue::Set.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Directory-Queue/distinfo b/devel/p5-Directory-Queue/distinfo
new file mode 100644
index 000000000000..2aea32dcddd0
--- /dev/null
+++ b/devel/p5-Directory-Queue/distinfo
@@ -0,0 +1,3 @@
+MD5 (Directory-Queue-0.5.tar.gz) = a5787a944c76d5f484f88c12d686c1ec
+SHA256 (Directory-Queue-0.5.tar.gz) = ecb9eb4419354514984c5dfcbf739351293d9cfee5a277cbaf5e3bd96a9c59d8
+SIZE (Directory-Queue-0.5.tar.gz) = 12681
diff --git a/devel/p5-Directory-Queue/pkg-descr b/devel/p5-Directory-Queue/pkg-descr
new file mode 100644
index 000000000000..c32cbd4dfaeb
--- /dev/null
+++ b/devel/p5-Directory-Queue/pkg-descr
@@ -0,0 +1,6 @@
+The goal of this module is to offer a simple queue system using the
+underlying filesystem for storage, security and to prevent race
+conditions via atomic operations. It focuses on simplicity, robustness
+and scalability.
+
+WWW: http://search.cpan.org/dist/Directory-Queue/
diff --git a/devel/p5-Directory-Queue/pkg-plist b/devel/p5-Directory-Queue/pkg-plist
new file mode 100644
index 000000000000..d8e25672936f
--- /dev/null
+++ b/devel/p5-Directory-Queue/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Directory/Queue.pm
+%%SITE_PERL%%/Directory/Queue/Set.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Directory/Queue/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Directory/Queue
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Directory
+@dirrmtry %%SITE_PERL%%/Directory/Queue
+@dirrmtry %%SITE_PERL%%/Directory