aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-11-30 05:55:17 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-11-30 05:55:17 +0000
commit14295721d421096cb5551d3e1766855a52311df7 (patch)
tree091112aa72274375ca573520ce5e99f32b2c8aff /devel
parent31eb9a640d033841216e7abfae5f66a9078495f6 (diff)
downloadports-14295721d421096cb5551d3e1766855a52311df7.tar.gz
ports-14295721d421096cb5551d3e1766855a52311df7.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/concurrencykit/Makefile3
-rw-r--r--devel/gcc-arm-embedded/Makefile2
-rw-r--r--devel/gecode/Makefile2
-rw-r--r--devel/radare2/Makefile2
-rw-r--r--devel/smake/Makefile2
5 files changed, 6 insertions, 5 deletions
diff --git a/devel/concurrencykit/Makefile b/devel/concurrencykit/Makefile
index e169816551a0..697ea9223144 100644
--- a/devel/concurrencykit/Makefile
+++ b/devel/concurrencykit/Makefile
@@ -14,9 +14,10 @@ COMMENT= Lock-free data structures for high performance concurrent systems
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 armv6 i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 sparc64
BROKEN_aarch64= Fails to configure: Detecting machine architecture...failed [unsupported]
BROKEN_armv6= Fails to configure: Finding suitable compiler........failed [not found]
+BROKEN_armv7= Fails to configure: Finding suitable compiler........failed [not found]
OPTIONS_DEFINE= RTM VMAPACK
OPTIONS_DEFAULT= VMAPACK
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index 16955c3cc1ed..fe52ccda3530 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -27,7 +27,7 @@ PYGDB_USES= python:2
OPTIONS_SUB= yes
-NOT_FOR_ARCHS= aarch64 arm armeb armv6 \
+NOT_FOR_ARCHS= aarch64 arm armeb armv6 armv7 \
mips mips64 mips64el mipsel mipsn32
NOT_FOR_ARCHS_REASON= Very slow to build on emulator
diff --git a/devel/gecode/Makefile b/devel/gecode/Makefile
index 9ebc010fa119..5c746bb6d11b 100644
--- a/devel/gecode/Makefile
+++ b/devel/gecode/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libmpfr.so:math/mpfr \
libgmp.so:math/gmp
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
NOT_FOR_ARCHS_REASON= needs code written to specify rounding control mechanism in Boost.Numeric.Interval
USES= bison gmake perl5
diff --git a/devel/radare2/Makefile b/devel/radare2/Makefile
index 6123428e0562..15e0a5927ec3 100644
--- a/devel/radare2/Makefile
+++ b/devel/radare2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS+= pkg-config:devel/pkgconf
LIB_DEPENDS+= libcapstone.so:devel/capstone4
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= does not build: Unsupported BSD architecture
CONFIGURE_ARGS+= --with-syscapstone
diff --git a/devel/smake/Makefile b/devel/smake/Makefile
index 894e25f3e45f..19b2be990892 100644
--- a/devel/smake/Makefile
+++ b/devel/smake/Makefile
@@ -14,7 +14,7 @@ LICENSE_COMB= multi
LICENSE_FILE_CDDL= ${WRKSRC}/CDDL.Schily.txt
BROKEN_i386= fails to compile
-NOT_FOR_ARCHS= aarch64 armv6
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= unknown rule to build: ./RULES/arm-freebsd-/nxb-bin/usr/bin/cc.rul
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.a.*//g}