aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-08 03:52:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-08 03:52:00 +0000
commit294cd4ace54d1aa220bcdf00f2c448577e312132 (patch)
treea11344971c13a3f768cecc9ab36d52a17250dcb5 /devel
parent05d3cf5f44eb25b029f26687432070f530f232e3 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Inline-CPP/Makefile19
-rw-r--r--devel/p5-Inline-CPP/distinfo4
-rw-r--r--devel/p5-Inline-CPP/pkg-plist1
3 files changed, 18 insertions, 6 deletions
diff --git a/devel/p5-Inline-CPP/Makefile b/devel/p5-Inline-CPP/Makefile
index 5cb840cf3d09..ea11fc84f920 100644
--- a/devel/p5-Inline-CPP/Makefile
+++ b/devel/p5-Inline-CPP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Inline-CPP
-PORTVERSION= 0.38
+PORTVERSION= 0.39
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,13 +14,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Write Perl subroutines and classes in C++
+LICENSE= ART10
+
BUILD_DEPENDS= p5-Inline>=0.50:${PORTSDIR}/devel/p5-Inline \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Kwalitee>=0:${PORTSDIR}/devel/p5-Test-Kwalitee
PERL_CONFIGURE= yes
-MAN3= Inline::CPP.3
+MAN3= Inline::CPP.3 \
+ Inline::CPP::Config.3 \
+ Inline::CPP::grammar.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Inline-CPP/distinfo b/devel/p5-Inline-CPP/distinfo
index 69a0cad88536..63a403bb41ea 100644
--- a/devel/p5-Inline-CPP/distinfo
+++ b/devel/p5-Inline-CPP/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Inline-CPP-0.38.tar.gz) = 05c9544e0941e4cee649a1ff2ba3e9b271128735f630b03c6919c8ac44808cb7
-SIZE (Inline-CPP-0.38.tar.gz) = 34108
+SHA256 (Inline-CPP-0.39.tar.gz) = 601c765aac9a0e33e478dec7da983949187c9f570598297f535c67aff4d64a69
+SIZE (Inline-CPP-0.39.tar.gz) = 44089
diff --git a/devel/p5-Inline-CPP/pkg-plist b/devel/p5-Inline-CPP/pkg-plist
index 4792d5cf2faa..2452c46360f9 100644
--- a/devel/p5-Inline-CPP/pkg-plist
+++ b/devel/p5-Inline-CPP/pkg-plist
@@ -1,5 +1,6 @@
%%SITE_PERL%%/Inline/CPP.pm
%%SITE_PERL%%/Inline/CPP.pod
+%%SITE_PERL%%/Inline/CPP/Config.pm
%%SITE_PERL%%/Inline/CPP/grammar.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Inline/CPP/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Inline/CPP