aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-10-30 11:44:29 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-10-30 11:44:29 +0000
commit32079e1bf4dbdc91f11518fbe98f5976fbe87b4d (patch)
treec521ba60c8243b6a13247f63debb7ac6efb8aed0 /devel
parent06b560c9a1aa55d911a3598b8ae31d4a35d9cdc8 (diff)
downloadports-32079e1bf4dbdc91f11518fbe98f5976fbe87b4d.tar.gz
ports-32079e1bf4dbdc91f11518fbe98f5976fbe87b4d.zip
Fix build on poweprc64.
PR: 231741 Submitted by: Piotr Kubaj
Notes
Notes: svn path=/head/; revision=483471
Diffstat (limited to 'devel')
-rw-r--r--devel/jna/Makefile3
-rw-r--r--devel/jna/files/patch-native_Makefile13
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index 47d4691e2548..50e0d3e0fbcc 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.AL
BROKEN_armv6= fails to compile: build.xml: compilation failed
BROKEN_armv7= fails to compile: build.xml: compilation failed
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-unknown-warning-option"
USES= autoreconf:build gmake libtool
USE_ANT= yes
@@ -36,7 +35,7 @@ TEST_TARGET= test
OPTIONS_DEFINE= DOCS
-ANT_ARCH= ${ARCH:S/amd64/x86-64/:S/i386/x86/}
+ANT_ARCH= ${ARCH:S/amd64/x86-64/:S/i386/x86/:S/powerpc64/ppc64/}
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/devel/jna/files/patch-native_Makefile b/devel/jna/files/patch-native_Makefile
index 217567a319c6..6aee7441cd19 100644
--- a/devel/jna/files/patch-native_Makefile
+++ b/devel/jna/files/patch-native_Makefile
@@ -18,3 +18,16 @@
LDFLAGS=-o $@ -shared
CDEFINES+=-DHAVE_PROTECTION -DFFI_MMAP_EXEC_WRIT -DUSE_DEAFULT_LIBNAME_ENCODING
endif
+@@ -338,10 +338,10 @@ endif
+ ifeq ($(CC),gcc)
+ GCC_MAJOR_VERSION = $(shell gcc -dumpversion | cut -f 1 -d '.')
+ ifneq ($(GCC_MAJOR_VERSION),4)
+- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
++ LOC_CC_OPTS=-Werror -Wno-unused-variable
+ endif
+ else
+- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
++ LOC_CC_OPTS=-Werror -Wno-unused-variable
+ endif
+
+ # Enable 64-bit builds if the arch demands it