aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-08-05 20:51:47 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-08-05 20:51:47 +0000
commit3ac35b3503e2744a252fadb4d749b4292488084c (patch)
tree23eeb254bcd157be14a95c63a6745ee5054bc852 /devel
parent6662c6791c6dd1957de00e402045b82a0aad76d5 (diff)
downloadports-3ac35b3503e2744a252fadb4d749b4292488084c.tar.gz
ports-3ac35b3503e2744a252fadb4d749b4292488084c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lockfree-malloc/Makefile48
-rw-r--r--devel/lockfree-malloc/distinfo2
-rw-r--r--devel/lockfree-malloc/pkg-descr15
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b66b49efda2f..54a9c9107b94 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1042,6 +1042,7 @@
SUBDIR += llvm29
SUBDIR += lmdbg
SUBDIR += lndir
+ SUBDIR += lockfree-malloc
SUBDIR += log4c
SUBDIR += log4cplus
SUBDIR += log4cpp
diff --git a/devel/lockfree-malloc/Makefile b/devel/lockfree-malloc/Makefile
new file mode 100644
index 000000000000..0f2b98120ebf
--- /dev/null
+++ b/devel/lockfree-malloc/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: lockfree-malloc
+# Date created: 2012-08-01
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lockfree-malloc
+PORTVERSION= 0.0.${DATE}
+CATEGORIES= devel
+MASTER_SITES= http://fbsd.zlonet.ru/distfiles/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Scalable drop-in replacement for malloc/free
+
+LICENSE= LGPL3
+
+DATE= 20120802
+ONLY_FOR_ARCHS= amd64
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
+DOCS_DESC= Install README
+
+PLIST_FILES= lib/liblite-malloc-shared.so \
+ lib/liblite-malloc-static.a
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_FILES+= share/doc/${PORTNAME}/README
+PLIST_DIRS+= share/doc/${PORTNAME}
+.endif
+
+do-install:
+.for i in shared.so static.a
+ ${INSTALL_LIB} ${WRKSRC}/liblite-malloc-${i} ${PREFIX}/lib/liblite-malloc-${i}
+.endfor
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/lockfree-malloc/distinfo b/devel/lockfree-malloc/distinfo
new file mode 100644
index 000000000000..987ab209ecce
--- /dev/null
+++ b/devel/lockfree-malloc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lockfree-malloc-0.0.20120802.tar.bz2) = 5b4ba8683fd0d02f1415d785d7fa04a41b1e3def8a1b690f434877d3931b16ea
+SIZE (lockfree-malloc-0.0.20120802.tar.bz2) = 41121
diff --git a/devel/lockfree-malloc/pkg-descr b/devel/lockfree-malloc/pkg-descr
new file mode 100644
index 000000000000..74cf578333eb
--- /dev/null
+++ b/devel/lockfree-malloc/pkg-descr
@@ -0,0 +1,15 @@
+lockfree-malloc is a scalable drop-in replacement for malloc/free.
+
+* It's thread-friendly. It supports a practically-unlimited number of
+ concurrent threads, without locking or performance degradation.
+* It's efficient, especially in a multi-threaded environment. Compared to
+ a stock libc allocator, we see a significant performance boost.
+* It does NOT fragment or leak memory, unlike a stock libc allocator.
+* It wastes less memory. For small objects (less than 8kb in size), the
+ overhead is around 0 bytes. (!)
+* It is designed from the ground-up for 64-bit architectures.
+* It is elegant. The whole codebase is only around 800 lines of fairly
+ clean C++. (!)
+* It fully stand-alone; it does not rely on pthreads or libc at runtime.
+
+WWW: https://github.com/Begun/lockfree-malloc