aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-14 23:49:12 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-14 23:49:12 +0000
commit5100a069341dbc576886313f4553ef443bd11b01 (patch)
tree2b5f49cd67d77f04ef455fbfb836975c236228a7 /devel
parentb0a6e12de7cb399c0313719f0f8cb7292e1b18ee (diff)
downloadports-5100a069341dbc576886313f4553ef443bd11b01.tar.gz
ports-5100a069341dbc576886313f4553ef443bd11b01.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-build/Makefile53
-rw-r--r--devel/ruby-build/distinfo2
-rw-r--r--devel/ruby-build/pkg-descr6
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 78ea37d7acc5..cdb4a3a48984 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3833,6 +3833,7 @@
SUBDIR += ruby-aspectr
SUBDIR += ruby-avl
SUBDIR += ruby-bsearch
+ SUBDIR += ruby-build
SUBDIR += ruby-byaccr
SUBDIR += ruby-cache
SUBDIR += ruby-calendar
diff --git a/devel/ruby-build/Makefile b/devel/ruby-build/Makefile
new file mode 100644
index 000000000000..3f708a7ec2e8
--- /dev/null
+++ b/devel/ruby-build/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= ruby-build
+PORTVERSION= 20130104
+CATEGORIES= devel ruby
+MASTER_SITES= GH
+
+MAINTAINER= fmb@onibox.net
+COMMENT= Compile and install different ruby versions
+
+LICENSE= RUBY-BUILD
+LICENSE_NAME= Sam Stephenson
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS=${_LICENSE_PERMS_DEFAULT}
+
+RUN_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ curl:${PORTSDIR}/ftp/curl \
+ gmake:${PORTSDIR}/devel/gmake
+
+OPTIONS_DEFINE= RBENV
+RBENV_DESC= Install rbenv for installation support
+OPTIONS_DEFAULT= RBENV
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MRBENV}
+RUN_DEPENDS+= rbenv:${PORTSDIR}/devel/rbenv
+.endif
+
+USE_GITHUB= yes
+GH_ACCOUNT= sstephenson
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 9ef0e06
+GH_TAGNAME= v${PORTVERSION}
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/ruby-build \
+ libexec/rbenv-install \
+ libexec/rbenv-uninstall
+PORTDATA= *
+
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|make\s|gmake|' \
+ ${WRKSRC}/bin/ruby-build
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/ruby-build ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/rbenv-install ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/rbenv-uninstall ${PREFIX}/libexec
+ @${MKDIR} ${DATADIR}
+ ( cd ${WRKSRC}/share/ruby-build && ${COPYTREE_BIN} \* ${DATADIR} )
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-build/distinfo b/devel/ruby-build/distinfo
new file mode 100644
index 000000000000..683c63c77cde
--- /dev/null
+++ b/devel/ruby-build/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ruby-build-20130104.tar.gz) = ae54c9eb8e61d6ccbb33a9702d4e391f105769007a818c8be3dafad38c5d9240
+SIZE (ruby-build-20130104.tar.gz) = 17478
diff --git a/devel/ruby-build/pkg-descr b/devel/ruby-build/pkg-descr
new file mode 100644
index 000000000000..d7c8ebb00d05
--- /dev/null
+++ b/devel/ruby-build/pkg-descr
@@ -0,0 +1,6 @@
+ruby-build is a rbenv plugin that provides a rbenv install command to compile
+and install different versions of Ruby on UNIX-like systems. You can also use
+ruby-build without rbenv in environments where you need precise control over
+Ruby version installation.
+
+WWW: https://github.com/sstephenson/ruby-build