aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2008-12-21 11:23:18 +0000
committerGabor Pali <pgj@FreeBSD.org>2008-12-21 11:23:18 +0000
commit6699c8483c696794842d1e10b82d39ce4fe6b9b9 (patch)
tree895831fb4c689840de2e22b9ca4cbf1db0db1e88 /devel
parentacd0a613bca6d97f12e72616c4f34fbc258ccb9c (diff)
downloadports-6699c8483c696794842d1e10b82d39ce4fe6b9b9.tar.gz
ports-6699c8483c696794842d1e10b82d39ce4fe6b9b9.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-binary-ghc/Makefile51
-rw-r--r--devel/hs-binary-ghc/distinfo3
-rw-r--r--devel/hs-binary-ghc/pkg-descr7
-rw-r--r--devel/hs-binary-ghc/pkg-plist28
-rw-r--r--devel/hs-binary/Makefile51
-rw-r--r--devel/hs-binary/distinfo3
-rw-r--r--devel/hs-binary/pkg-descr7
-rw-r--r--devel/hs-binary/pkg-plist28
9 files changed, 179 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bc2e8b5e5faa..bcc06184c343 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -490,6 +490,7 @@
SUBDIR += hptools
SUBDIR += hs-Stream
SUBDIR += hs-alex
+ SUBDIR += hs-binary-ghc
SUBDIR += hs-c2hs
SUBDIR += hs-cpphs
SUBDIR += hs-dlist
diff --git a/devel/hs-binary-ghc/Makefile b/devel/hs-binary-ghc/Makefile
new file mode 100644
index 000000000000..22b9d9d6c1e1
--- /dev/null
+++ b/devel/hs-binary-ghc/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: binary
+# Date created: December 15, 2008
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= binary
+PORTVERSION= 0.4.4
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Efficient binary serialisation for Haskell
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.ifndef (NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.ifndef (NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>
diff --git a/devel/hs-binary-ghc/distinfo b/devel/hs-binary-ghc/distinfo
new file mode 100644
index 000000000000..309cdbfc3d3c
--- /dev/null
+++ b/devel/hs-binary-ghc/distinfo
@@ -0,0 +1,3 @@
+MD5 (binary-0.4.4.tar.gz) = 48fc6454e82e0aec7f648be107bfc0b8
+SHA256 (binary-0.4.4.tar.gz) = 23dac14ce7eb7542e19b1ae6f8bec78e95c65ef8364416df43aa2b1751949536
+SIZE (binary-0.4.4.tar.gz) = 41466
diff --git a/devel/hs-binary-ghc/pkg-descr b/devel/hs-binary-ghc/pkg-descr
new file mode 100644
index 000000000000..4af4cbcbf16b
--- /dev/null
+++ b/devel/hs-binary-ghc/pkg-descr
@@ -0,0 +1,7 @@
+Efficient, pure binary serialisation using lazy ByteStrings. Haskell
+values may be encoded to and from binary formats, written to disk as
+binary, or sent over the network. Serialisation speeds of over 1 G/sec
+have been observed, so this library should be suitable for high
+performance scenarios.
+
+WWW: http://code.haskell.org/binary/
diff --git a/devel/hs-binary-ghc/pkg-plist b/devel/hs-binary-ghc/pkg-plist
new file mode 100644
index 000000000000..b0b29313a345
--- /dev/null
+++ b/devel/hs-binary-ghc/pkg-plist
@@ -0,0 +1,28 @@
+%%SUBDIR%%/Data/Binary.hi
+%%SUBDIR%%/Data/Binary/Builder.hi
+%%SUBDIR%%/Data/Binary/Get.hi
+%%SUBDIR%%/Data/Binary/Put.hi
+%%SUBDIR%%/HSbinary-%%PORTVERSION%%.o
+%%SUBDIR%%/libHSbinary-%%PORTVERSION%%.a
+%%SUBDIR%%/%%PORTNAME%%-register.sh
+%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/html/%%PORTNAME%%.haddock
+%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
+%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Builder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Get.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Put.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/Data/Binary
+@dirrmtry %%SUBDIR%%/Data
+@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec ghc-pkg unregister %%PORTNAME%%
+@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
diff --git a/devel/hs-binary/Makefile b/devel/hs-binary/Makefile
new file mode 100644
index 000000000000..22b9d9d6c1e1
--- /dev/null
+++ b/devel/hs-binary/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: binary
+# Date created: December 15, 2008
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= binary
+PORTVERSION= 0.4.4
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Efficient binary serialisation for Haskell
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.ifndef (NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.ifndef (NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>
diff --git a/devel/hs-binary/distinfo b/devel/hs-binary/distinfo
new file mode 100644
index 000000000000..309cdbfc3d3c
--- /dev/null
+++ b/devel/hs-binary/distinfo
@@ -0,0 +1,3 @@
+MD5 (binary-0.4.4.tar.gz) = 48fc6454e82e0aec7f648be107bfc0b8
+SHA256 (binary-0.4.4.tar.gz) = 23dac14ce7eb7542e19b1ae6f8bec78e95c65ef8364416df43aa2b1751949536
+SIZE (binary-0.4.4.tar.gz) = 41466
diff --git a/devel/hs-binary/pkg-descr b/devel/hs-binary/pkg-descr
new file mode 100644
index 000000000000..4af4cbcbf16b
--- /dev/null
+++ b/devel/hs-binary/pkg-descr
@@ -0,0 +1,7 @@
+Efficient, pure binary serialisation using lazy ByteStrings. Haskell
+values may be encoded to and from binary formats, written to disk as
+binary, or sent over the network. Serialisation speeds of over 1 G/sec
+have been observed, so this library should be suitable for high
+performance scenarios.
+
+WWW: http://code.haskell.org/binary/
diff --git a/devel/hs-binary/pkg-plist b/devel/hs-binary/pkg-plist
new file mode 100644
index 000000000000..b0b29313a345
--- /dev/null
+++ b/devel/hs-binary/pkg-plist
@@ -0,0 +1,28 @@
+%%SUBDIR%%/Data/Binary.hi
+%%SUBDIR%%/Data/Binary/Builder.hi
+%%SUBDIR%%/Data/Binary/Get.hi
+%%SUBDIR%%/Data/Binary/Put.hi
+%%SUBDIR%%/HSbinary-%%PORTVERSION%%.o
+%%SUBDIR%%/libHSbinary-%%PORTVERSION%%.a
+%%SUBDIR%%/%%PORTNAME%%-register.sh
+%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/html/%%PORTNAME%%.haddock
+%%PORTDOCS%%%%DOCSDIR%%/html/doc-index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock-util.js
+%%PORTDOCS%%%%DOCSDIR%%/html/haddock.css
+%%PORTDOCS%%%%DOCSDIR%%/html/haskell_icon.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/minus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/plus.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Builder.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Get.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary-Put.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data-Binary.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/Data/Binary
+@dirrmtry %%SUBDIR%%/Data
+@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec ghc-pkg unregister %%PORTNAME%%
+@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old