aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 11:31:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 11:31:58 +0000
commitb2c53279530d6e72b9203daef0bb2b85881eec88 (patch)
tree0d1b9cbe72b0874a1d7a61a7cfedbbbc82326467 /devel
parentbfddb9b21bad8e56ad469193496c511f0120dbd6 (diff)
downloadports-b2c53279530d6e72b9203daef0bb2b85881eec88.tar.gz
ports-b2c53279530d6e72b9203daef0bb2b85881eec88.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/trio/Makefile9
-rw-r--r--devel/trio/files/patch-Makefile.in18
2 files changed, 22 insertions, 5 deletions
diff --git a/devel/trio/Makefile b/devel/trio/Makefile
index 0c89f86dbed4..034864b300b2 100644
--- a/devel/trio/Makefile
+++ b/devel/trio/Makefile
@@ -11,12 +11,11 @@ COMMENT= A fully matured and stable set of printf and string functions
GNU_CONFIGURE= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${FIND} doc | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
-.endif
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/trio/files/patch-Makefile.in b/devel/trio/files/patch-Makefile.in
new file mode 100644
index 000000000000..a3d7b38d537f
--- /dev/null
+++ b/devel/trio/files/patch-Makefile.in
@@ -0,0 +1,18 @@
+--- ./Makefile.in.orig 2014-02-19 12:30:54.040272078 +0100
++++ ./Makefile.in 2014-02-19 12:31:21.743269418 +0100
+@@ -43,11 +43,11 @@
+ ./regression
+
+ install: $(TARGETLIB)
+- $(MKDIR) $(libdir)
+- $(MKDIR) $(includedir)
+- $(INSTALL_DATA) $(TARGETLIB) $(libdir)/$(TARGETLIB)
++ $(MKDIR) $(DESTDIR)$(libdir)
++ $(MKDIR) $(DESTDIR)$(includedir)
++ $(INSTALL_DATA) $(TARGETLIB) $(DESTDIR)$(libdir)/$(TARGETLIB)
+ for i in $(TARGETINCS);do \
+- (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(includedir)); \
++ (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir)); \
+ done
+
+ regression: regression.o $(TARGETLIB)