aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
commitd500c1cc50f23b0489994e29a3a20f32a3cb441d (patch)
tree7c1e12df7a7d8fba86936f85270c40cc1e388312 /devel
parent23e6a2b3da60fd03fb9e392af59450056c09f9a5 (diff)
downloadports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.tar.gz
ports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/arm-elf-gcc295/Makefile8
-rw-r--r--devel/libzvbi/Makefile4
-rw-r--r--devel/p5-Devel-Peek/Makefile8
-rw-r--r--devel/p5-File-Lock/Makefile8
4 files changed, 25 insertions, 3 deletions
diff --git a/devel/arm-elf-gcc295/Makefile b/devel/arm-elf-gcc295/Makefile
index 620436690891..8cbd63bbd777 100644
--- a/devel/arm-elf-gcc295/Makefile
+++ b/devel/arm-elf-gcc295/Makefile
@@ -24,6 +24,12 @@ BUILD_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
RUN_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
${PKGNAMEPREFIX}ld:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GCC_REV= ${DISTNAME:S/gcc-//g}
PLIST_SUB+= GCC_REV=${GCC_REV}
USE_PERL5= yes
@@ -63,4 +69,4 @@ post-install:
${PREFIX}/${PKGNAMEPREFIX:S/-$//}/bin/g++
@${RM} ${PREFIX}/lib/libiberty.a
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libzvbi/Makefile b/devel/libzvbi/Makefile
index 10c815a0fced..138277cd59da 100644
--- a/devel/libzvbi/Makefile
+++ b/devel/libzvbi/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ENV= CC="$(CC) -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -L/usr
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/devel/p5-Devel-Peek/Makefile b/devel/p5-Devel-Peek/Makefile
index 2236265e07d7..e319bb6c0a2b 100644
--- a/devel/p5-Devel-Peek/Makefile
+++ b/devel/p5-Devel-Peek/Makefile
@@ -15,9 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl5 data debugging tool for the XS programmer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Devel::Peek.3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Lock/Makefile b/devel/p5-File-Lock/Makefile
index d5aa456e9011..b92ffdb882c5 100644
--- a/devel/p5-File-Lock/Makefile
+++ b/devel/p5-File-Lock/Makefile
@@ -15,6 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl5 module for file locking (flock,fcntl)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>