aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-21 00:11:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-21 00:11:11 +0000
commitd6d69f8e073dfde3a58fc1de229c9af01a05fee7 (patch)
tree0f6f8589e151e98c7fd5a27702408a6add13ab16 /devel
parentbd908cb2f2de769688966e08f4ed162bdaff017b (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/lemon/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/lemon/Makefile b/devel/lemon/Makefile
index 67f2476fc373..e21df3d873fa 100644
--- a/devel/lemon/Makefile
+++ b/devel/lemon/Makefile
@@ -8,20 +8,19 @@ MASTER_SITES= http://tx97.net/pub/distfiles/ \
http://mirror.amdmi3.ru/distfiles/
MAINTAINER= vmagerya@gmail.com
-COMMENT= An LALR(1) parser generator. Similar in function to yacc and bison
+COMMENT= LALR(1) parser generator. Similar in function to yacc and bison
USE_BZIP2= yes
MAKEFILE= /dev/null
ALL_TARGET= ${PORTNAME}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's| = pathsearch(.*| = "${DATADIR}/lempar.c";|' \
${WRKSRC}/lemon.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lemon ${PREFIX}/bin/
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/lempar.c ${DATADIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/lemon ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/lempar.c ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>