aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-09-20 20:50:02 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-09-20 20:50:02 +0000
commitdb380d33a0df51a7644daf6b59ae03647b3d81da (patch)
tree16121b97501b133c51553fcb9abd37c070925bd1 /devel
parent59024b75d038c30b2b7f32f71af553c80639453b (diff)
downloadports-db380d33a0df51a7644daf6b59ae03647b3d81da.tar.gz
ports-db380d33a0df51a7644daf6b59ae03647b3d81da.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ucpp/Makefile20
-rw-r--r--devel/ucpp/distinfo6
-rw-r--r--devel/ucpp/files/patch-Makefile24
-rw-r--r--devel/ucpp/files/patch-cpp.c8
-rw-r--r--devel/ucpp/pkg-descr2
-rw-r--r--devel/ucpp/pkg-plist14
6 files changed, 44 insertions, 30 deletions
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
index 713a0e6fb811..771406283f6c 100644
--- a/devel/ucpp/Makefile
+++ b/devel/ucpp/Makefile
@@ -2,22 +2,26 @@
# $FreeBSD$
PORTNAME= ucpp
-PORTVERSION= 1.3.4
+PORTVERSION= 1.3.2
+PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= # GITHUB
+MASTER_SITES= GH
MAINTAINER= crees@FreeBSD.org
COMMENT= C preprocessor and lexer
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+GH_ACCOUNT= lpsantil
+GH_TAGNAME= 31b719e
USE_GITHUB= yes
-GH_ACCOUNT= scarabeusiv
-USES= autoreconf libtool pathfix
-PATHFIX_MAKEFILEIN= Makefile.am
-GNU_CONFIGURE= yes
-post-patch:
- ${REINPLACE_CMD} '/^CFLAGS/s/-ansi//' ${WRKSRC}/configure.ac
+PLIST_FILES= bin/ucpp man/man1/ucpp.1.gz
+USES= gmake
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1/
.include <bsd.port.mk>
diff --git a/devel/ucpp/distinfo b/devel/ucpp/distinfo
index cf2c577b6532..722e545d4abd 100644
--- a/devel/ucpp/distinfo
+++ b/devel/ucpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474029495
-SHA256 (scarabeusiv-ucpp-1.3.4_GH0.tar.gz) = 35958c5f3bb3851c03d3f442cc072cf27b21dc8478e1eecfce289b1c5aba951a
-SIZE (scarabeusiv-ucpp-1.3.4_GH0.tar.gz) = 92999
+TIMESTAMP = 1474394679
+SHA256 (lpsantil-ucpp-1.3.2-31b719e_GH0.tar.gz) = 475f1c2eb64998387cbab315c1c1bcd381644a14e6885aa434056fbf706b5e8f
+SIZE (lpsantil-ucpp-1.3.2-31b719e_GH0.tar.gz) = 97594
diff --git a/devel/ucpp/files/patch-Makefile b/devel/ucpp/files/patch-Makefile
new file mode 100644
index 000000000000..79ee9abfd35c
--- /dev/null
+++ b/devel/ucpp/files/patch-Makefile
@@ -0,0 +1,24 @@
+Fixes clang build
+
+--- Makefile.orig 2015-03-21 06:43:07 UTC
++++ Makefile
+@@ -56,8 +56,8 @@
+ #FLAGS = -O -m -DMEM_CHECK
+
+ # for gcc
+-CC = gcc
+-FLAGS = -O3 -W -Wall -ansi
++CC ?= cc
++FLAGS = -ansi -DAUDIT -DMEM_DEBUG
+ #FLAGS = -g -W -Wall -ansi -DAUDIT -DMEM_DEBUG
+ #FLAGS = -O3 -mcpu=pentiumpro -fomit-frame-pointer -W -Wall -ansi -DMEM_CHECK
+ #FLAGS = -O -pg -W -Wall -ansi -DMEM_CHECK
+@@ -88,7 +88,7 @@ endif
+ # ----- nothing should be changed below this line -----
+
+ COBJ = mem.o nhash.o cpp.o lexer.o assert.o macro.o eval.o
+-CFLAGS = $(FLAGS)
++CFLAGS += $(FLAGS)
+
+ all: ucpp
+ @ar cq libucpp.a *.o
diff --git a/devel/ucpp/files/patch-cpp.c b/devel/ucpp/files/patch-cpp.c
index 6abcf8dd8133..461aff11b618 100644
--- a/devel/ucpp/files/patch-cpp.c
+++ b/devel/ucpp/files/patch-cpp.c
@@ -1,6 +1,6 @@
---- cpp.c.orig 2008-10-01 21:15:41.000000000 +0400
-+++ src/cpp.c 2011-03-17 21:08:15.000000000 +0300
-@@ -65,8 +65,8 @@
+--- cpp.c.orig 2015-03-21 06:43:07 UTC
++++ cpp.c
+@@ -65,8 +65,8 @@ int emit_dependencies = 0, emit_defines
FILE *emit_output;
#ifdef STAND_ALONE
@@ -11,7 +11,7 @@
#endif
char *current_filename = 0, *current_long_filename = 0;
-@@ -2364,7 +2364,7 @@
+@@ -2371,7 +2371,7 @@ static int parse_opt(int argc, char *arg
char *filename = 0;
int with_std_incpath = 1;
int print_version = 0, print_defs = 0, print_asserts = 0;
diff --git a/devel/ucpp/pkg-descr b/devel/ucpp/pkg-descr
index 9574f2362798..229cf87183ca 100644
--- a/devel/ucpp/pkg-descr
+++ b/devel/ucpp/pkg-descr
@@ -6,4 +6,4 @@ ucpp is a C preprocessor and lexer. It has the following goals:
- Possibility to use the code as a lexer (that outputs tokens
directly)
-WWW: https://github.com/scarabeusiv/ucpp
+WWW: http://code.google.com/p/ucpp/
diff --git a/devel/ucpp/pkg-plist b/devel/ucpp/pkg-plist
deleted file mode 100644
index 9e787ec9e775..000000000000
--- a/devel/ucpp/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/ucpp
-include/libucpp/cpp.h
-include/libucpp/hash.h
-include/libucpp/mem.h
-include/libucpp/nhash.h
-include/libucpp/tune.h
-include/libucpp/ucpp-config.h
-include/libucpp/ucppi.h
-lib/libucpp.a
-lib/libucpp.so
-lib/libucpp.so.13
-lib/libucpp.so.13.0.4
-libdata/pkgconfig/libucpp.pc
-man/man1/ucpp.1.gz