aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-15 08:35:58 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-15 08:35:58 +0000
commite0d879d0fe47bcd20c1c1daea52d1c9941559c5e (patch)
tree1487d1489b4b16eeacc3fbe445061b0e6aa264a4 /devel
parentdbdcdbd8823d86b05171f4c12bab72ed1ea30100 (diff)
downloadports-e0d879d0fe47bcd20c1c1daea52d1c9941559c5e.tar.gz
ports-e0d879d0fe47bcd20c1c1daea52d1c9941559c5e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-wsgiutils/Makefile24
-rw-r--r--devel/py-wsgiutils/distinfo3
-rw-r--r--devel/py-wsgiutils/pkg-descr13
-rw-r--r--devel/py-wsgiutils/pkg-plist16
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4953e72dfdd6..d58edf58e605 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1627,6 +1627,7 @@
SUBDIR += py-urwid
SUBDIR += py-utils
SUBDIR += py-vmaps
+ SUBDIR += py-wsgiutils
SUBDIR += py-xdg
SUBDIR += py-xoltar-toolkit
SUBDIR += py-yaml
diff --git a/devel/py-wsgiutils/Makefile b/devel/py-wsgiutils/Makefile
new file mode 100644
index 000000000000..435f0198eee9
--- /dev/null
+++ b/devel/py-wsgiutils/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-wsgiutils
+# Date created: 25 June 2006
+# Whom: Jordi Haarman
+#
+# $FreeBSD$
+#
+
+PORTNAME= wsgiutils
+PORTVERSION= 0.7
+CATEGORIES= devel textproc www python
+MASTER_SITES= http://www.owlfish.com/software/wsgiutils/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= WSGIUtils-${PORTVERSION}
+
+MAINTAINER= j.haarman@synantics.com
+COMMENT= Utility libraries for development of simple WSGI programs
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ PYTHON_VERSION_NR=${_PYTHON_PORTBRANCH}
+
+.include <bsd.port.mk>
diff --git a/devel/py-wsgiutils/distinfo b/devel/py-wsgiutils/distinfo
new file mode 100644
index 000000000000..5f1abd856b9c
--- /dev/null
+++ b/devel/py-wsgiutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (WSGIUtils-0.7.tar.gz) = bcb0bc3cc3a4d2be2d237ab532b1d5b8
+SHA256 (WSGIUtils-0.7.tar.gz) = 5f0fb822e8c100416edc1f75f2fd4a28dcfd2b3a046aeb39ac1c761101f0a9d1
+SIZE (WSGIUtils-0.7.tar.gz) = 17996
diff --git a/devel/py-wsgiutils/pkg-descr b/devel/py-wsgiutils/pkg-descr
new file mode 100644
index 000000000000..7dbb408c397f
--- /dev/null
+++ b/devel/py-wsgiutils/pkg-descr
@@ -0,0 +1,13 @@
+WSGIUtils is a package of standalone utility libraries that ease the development
+of simple WSGI programs.
+
+The package is divided into two main components which can be used individualy or
+in combination.
+
+wsgiServer is a multi-threaded WSGI web server based on SimpleHTTPServer.
+
+wsgiAdaptor is a simple WSGI application that provides basic authentication,
+signed cookies and persistent sessions.
+
+
+WWW: http://www.owlfish.com/software/wsgiutils/
diff --git a/devel/py-wsgiutils/pkg-plist b/devel/py-wsgiutils/pkg-plist
new file mode 100644
index 000000000000..f71c7da80d8e
--- /dev/null
+++ b/devel/py-wsgiutils/pkg-plist
@@ -0,0 +1,16 @@
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionClient.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionClient.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionClient.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionServer.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionServer.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/SessionServer.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/__init__.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/__init__.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/__init__.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiAdaptor.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiAdaptor.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiAdaptor.pyo
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiServer.py
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiServer.pyc
+%%PYTHON_SITELIBDIR%%/wsgiutils/wsgiServer.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/wsgiutils/