aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-01-28 17:22:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-01-28 17:22:44 +0000
commitfc5c59a1caa9019b56a239dbe58510f0146e04c2 (patch)
tree20b9a981b5f781b367e46e69d559e551d6822e78 /devel
parent2cbcc5d099e30ec1422d47153e34b7b6862ddf73 (diff)
downloadports-fc5c59a1caa9019b56a239dbe58510f0146e04c2.tar.gz
ports-fc5c59a1caa9019b56a239dbe58510f0146e04c2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Async-Interrupt/Makefile21
-rw-r--r--devel/p5-Async-Interrupt/distinfo2
-rw-r--r--devel/p5-Async-Interrupt/pkg-descr5
-rw-r--r--devel/p5-Async-Interrupt/pkg-plist8
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fd8c739c29d0..c3b18fa031ab 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1181,6 +1181,7 @@
SUBDIR += p5-Array-Iterator
SUBDIR += p5-Array-Unique
SUBDIR += p5-Array-Window
+ SUBDIR += p5-Async-Interrupt
SUBDIR += p5-Async-MergePoint
SUBDIR += p5-AtExit
SUBDIR += p5-Attribute-Handlers
diff --git a/devel/p5-Async-Interrupt/Makefile b/devel/p5-Async-Interrupt/Makefile
new file mode 100644
index 000000000000..c7e5189c77f4
--- /dev/null
+++ b/devel/p5-Async-Interrupt/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Async-Interrupt
+# Date created: 2010-12-29
+# Whom: Mikhail T. <michael@fun-box.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Async-Interrupt
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= michael@fun-box.ru
+COMMENT= Allow C/XS libraries to interrupt perl asynchronously
+
+PERL_CONFIGURE= yes
+
+MAN3= Async::Interrupt.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Async-Interrupt/distinfo b/devel/p5-Async-Interrupt/distinfo
new file mode 100644
index 000000000000..06ae2b37d62c
--- /dev/null
+++ b/devel/p5-Async-Interrupt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Async-Interrupt-1.05.tar.gz) = 2177e125175cd80857bff7e70d928ab794391c244a7e598c6f4f82b85b66c7f1
+SIZE (Async-Interrupt-1.05.tar.gz) = 24706
diff --git a/devel/p5-Async-Interrupt/pkg-descr b/devel/p5-Async-Interrupt/pkg-descr
new file mode 100644
index 000000000000..8e4c59dcb93a
--- /dev/null
+++ b/devel/p5-Async-Interrupt/pkg-descr
@@ -0,0 +1,5 @@
+This module implements asynchronous notifications that enable you
+to signal running perl code from another thread, asynchronously,
+and sometimes even without using a single syscall.
+
+WWW: http://search.cpan.org/dist/Async-Interrupt/
diff --git a/devel/p5-Async-Interrupt/pkg-plist b/devel/p5-Async-Interrupt/pkg-plist
new file mode 100644
index 000000000000..6ba5c3310c1a
--- /dev/null
+++ b/devel/p5-Async-Interrupt/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Async/Interrupt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt/Interrupt.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt/Interrupt.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Async/Interrupt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%