aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1998-12-16 00:01:28 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1998-12-16 00:01:28 +0000
commit07a20012a4f53e5feaeed6671abdbb27b784917c (patch)
treeb502fd0a2ab164431a0110de2109219bd010dfa8 /devel
parentd74538e38a82c6ef9b73b304d9b3e4c60d81639a (diff)
downloadports-07a20012a4f53e5feaeed6671abdbb27b784917c.tar.gz
ports-07a20012a4f53e5feaeed6671abdbb27b784917c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cs/Makefile21
-rw-r--r--devel/cs/distinfo2
-rw-r--r--devel/cs/files/patch-aa18
-rw-r--r--devel/cs/pkg-plist3
4 files changed, 27 insertions, 17 deletions
diff --git a/devel/cs/Makefile b/devel/cs/Makefile
index 8af9528ede7f..cd215da4c913 100644
--- a/devel/cs/Makefile
+++ b/devel/cs/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: cs
-# Version required: 0.3
-# Date created: 22 May 1997
-# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+# Version required: 0.5
+# Date created: 22 May 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.1.1.1 1997/05/23 07:58:58 tg Exp $
+# $Id: Makefile,v 1.2 1997/06/05 07:36:51 tg Exp $
#
-DISTNAME= cs-0.3
+DISTNAME= cs-0.5
CATEGORIES= devel
MASTER_SITES= ftp://cantor.informatik.rwth-aachen.de/pub/unix/
@@ -17,7 +17,14 @@ ALL_TARGET= cs
MAN1= cs.1
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cs ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/cs.1 ${PREFIX}/man/man1
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/cs ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/cs.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/cs
+ @ ${INSTALL_DATA} ${WRKSRC}/ANNOUNCE ${PREFIX}/share/doc/cs
+ @ ${INSTALL_DATA} ${WRKSRC}/cs.html ${PREFIX}/share/doc/cs
+.endif
.include <bsd.port.mk>
diff --git a/devel/cs/distinfo b/devel/cs/distinfo
index 3923fe94eb07..8a200bb0b0bd 100644
--- a/devel/cs/distinfo
+++ b/devel/cs/distinfo
@@ -1 +1 @@
-MD5 (cs-0.3.tar.gz) = 414fc15906fcc25a794762a1dec92d63
+MD5 (cs-0.5.tar.gz) = 61f8ea27a169e86e3e5e6eda4585e688
diff --git a/devel/cs/files/patch-aa b/devel/cs/files/patch-aa
index c33936902957..6a5378d51e10 100644
--- a/devel/cs/files/patch-aa
+++ b/devel/cs/files/patch-aa
@@ -1,13 +1,13 @@
---- Makefile.orig Wed May 7 09:32:24 1997
-+++ Makefile Thu May 22 19:18:35 1997
+--- Makefile Sat Sep 19 19:10:58 1998
++++ /home/andy/tmp/wrk/Makefile Tue Dec 15 20:44:22 1998
@@ -2,7 +2,7 @@
- DB= BINARY_DB
+ #DB= BINARY_DB
#{{{script}}}#{{{ Linux, moria machines
--CFLAGS= -p -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
-+#CFLAGS= -p -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
+-CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
++#CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
CPPFLAGS= -D$(DB)
- LDFLAGS= -p -g
+ LDFLAGS= -g
LIBS= -lcurses
@@ -32,11 +32,11 @@
#}}}
@@ -18,11 +18,11 @@
-#LIBS= -lncurses -lmytinfo
-#LDFLAGS=
-#MAKEDEPEND= gcc -MM
-+CFLAGS+= -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common $(CPPFLAGS)
++CFLAGS+= -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common $(CPPFLAGS)
+CPPFLAGS= -I.curses.h -DNO_POSIX_SOURCE -D$(DB)
+LIBS= -lncurses -lmytinfo
-+LDFLAGS= -s
++LDFLAGS=
+MAKEDEPEND= gcc -MM
#}}}
- #{{{ SunOS 4, gcc
+ #{{{ BSDI
#CC= gcc
diff --git a/devel/cs/pkg-plist b/devel/cs/pkg-plist
index 4f886eb900ee..201c6d2dfbc8 100644
--- a/devel/cs/pkg-plist
+++ b/devel/cs/pkg-plist
@@ -1 +1,4 @@
bin/cs
+share/doc/cs/ANNOUNCE
+share/doc/cs/cs.html
+@dirrm share/doc/cs