aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2004-01-16 21:33:20 +0000
committerMichael Haro <mharo@FreeBSD.org>2004-01-16 21:33:20 +0000
commit34b082b6490476a2afdbbdc9434a98411334be4b (patch)
treeaf5f4829bc13ce31a705f1157edc05f41adaa780 /devel
parent91528b401052573f7f9f3d86ed468b9093f27b5b (diff)
downloadports-34b082b6490476a2afdbbdc9434a98411334be4b.tar.gz
ports-34b082b6490476a2afdbbdc9434a98411334be4b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Date-Set/Makefile26
-rw-r--r--devel/p5-Date-Set/distinfo1
-rw-r--r--devel/p5-Date-Set/pkg-descr8
-rw-r--r--devel/p5-Date-Set/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 53eb5143ae8e..935b69c7bc0d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -611,6 +611,7 @@
SUBDIR += p5-Date-Manip
SUBDIR += p5-Date-Pcalc
SUBDIR += p5-Date-Roman
+ SUBDIR += p5-Date-Set
SUBDIR += p5-Date-Simple
SUBDIR += p5-DateConvert
SUBDIR += p5-DateTime
diff --git a/devel/p5-Date-Set/Makefile b/devel/p5-Date-Set/Makefile
new file mode 100644
index 000000000000..8545ed9b7795
--- /dev/null
+++ b/devel/p5-Date-Set/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Date-Set
+# Date created: Thu Jan 8 13:16:46 PST 2004
+# Whom: mharo@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date-Set
+PORTVERSION= 1.29
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Date
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mharo@FreeBSD.org
+COMMENT= A module for date/time sets
+
+BUILD_DEPENDS= ${SITE_PERL}/Set/Infinite.pm:${PORTSDIR}/devel/p5-Set-Infinite \
+ ${SITE_PERL}/Date/ICal.pm:${PORTSDIR}/devel/p5-Date-ICal
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Set::ICal.3 Date::Set.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Set/distinfo b/devel/p5-Date-Set/distinfo
new file mode 100644
index 000000000000..be6f3e2ea733
--- /dev/null
+++ b/devel/p5-Date-Set/distinfo
@@ -0,0 +1 @@
+MD5 (Date-Set-1.29.tar.gz) = a2a5c95303fac0cb98e80f17a18961fb
diff --git a/devel/p5-Date-Set/pkg-descr b/devel/p5-Date-Set/pkg-descr
new file mode 100644
index 000000000000..4f67e0e34b44
--- /dev/null
+++ b/devel/p5-Date-Set/pkg-descr
@@ -0,0 +1,8 @@
+Date::Set is a module for date/time sets. It allows you to generate
+groups of dates, like "every wednesday", and then find all the dates
+matching that pattern.
+
+WWW: http://reefknot.sf.net
+
+- Michael Haro
+mharo@FreeBSD.org
diff --git a/devel/p5-Date-Set/pkg-plist b/devel/p5-Date-Set/pkg-plist
new file mode 100644
index 000000000000..9c99fac0a5a1
--- /dev/null
+++ b/devel/p5-Date-Set/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Date/Set/ICal.pm
+%%SITE_PERL%%/Date/Set.pm
+%%SITE_PERL%%/auto/Date/Set/ICal/autosplit.ix
+%%SITE_PERL%%/auto/Date/Set/autosplit.ix
+@dirrm %%SITE_PERL%%/Date/Set
+@dirrm %%SITE_PERL%%/auto/Date/Set/ICal
+@dirrm %%SITE_PERL%%/auto/Date/Set