aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-15 23:11:12 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-15 23:11:12 +0000
commit44eaadcb751194bcef34890a161d4bf9a873a2a4 (patch)
tree37076f8661cc0a667d6e54eab2728ecc665430a0 /devel
parent156cc72026ce25b8da3d604f4fb691e4d6413b5f (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/anjuta/Makefile2
-rw-r--r--devel/art/Makefile2
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/buildtool-doc/Makefile2
-rw-r--r--devel/c4/Makefile12
-rw-r--r--devel/cdk/Makefile2
-rw-r--r--devel/cppunit/Makefile2
-rw-r--r--devel/csmith/Makefile2
-rw-r--r--devel/cvsweb/Makefile2
-rw-r--r--devel/ddd/Makefile2
-rw-r--r--devel/ditrack/Makefile2
-rw-r--r--devel/fga/Makefile10
-rw-r--r--devel/fga/pkg-plist10
-rw-r--r--devel/flyspray/Makefile2
-rw-r--r--devel/gazpacho/Makefile4
-rw-r--r--devel/gcc-arm-embedded/Makefile2
-rw-r--r--devel/kickassembler/Makefile2
-rw-r--r--devel/libdict/Makefile2
-rw-r--r--devel/libexplain/Makefile2
-rw-r--r--devel/libstatgrab/Makefile2
-rw-r--r--devel/libvc/Makefile2
-rw-r--r--devel/loki/Makefile2
-rw-r--r--devel/mk-configure/Makefile2
-rw-r--r--devel/ocaml-findlib/Makefile2
-rw-r--r--devel/ocaml-magic/Makefile2
-rw-r--r--devel/ocaml-pcre/Makefile2
-rw-r--r--devel/oniguruma4/Makefile2
-rw-r--r--devel/p4api/Makefile2
-rw-r--r--devel/p5-App-Build/Makefile2
-rw-r--r--devel/p5-Class-Contract/pkg-plist4
-rw-r--r--devel/p5-Class-Delegation/pkg-plist14
-rw-r--r--devel/p5-Devel-Diagram/pkg-plist16
-rw-r--r--devel/p5-IO-KQueue/Makefile2
-rw-r--r--devel/p5-IO-KQueue/pkg-plist6
-rw-r--r--devel/py-period/Makefile2
-rw-r--r--devel/py-traits/Makefile2
-rw-r--r--devel/py-xoltar-toolkit/Makefile2
-rw-r--r--devel/pychecker/Makefile2
-rw-r--r--devel/raknet/Makefile2
-rw-r--r--devel/readline/Makefile2
-rw-r--r--devel/ruby-byaccr/Makefile2
-rw-r--r--devel/ruby-cache/Makefile2
-rw-r--r--devel/ruby-calendar/Makefile2
-rw-r--r--devel/ruby-date2/Makefile1
-rw-r--r--devel/ruby-dialogs/Makefile2
-rw-r--r--devel/ruby-fastri/Makefile2
-rw-r--r--devel/ruby-intl/Makefile2
-rw-r--r--devel/ruby-locale2/Makefile2
-rw-r--r--devel/ruby-multi/Makefile2
-rw-r--r--devel/ruby-ncurses/Makefile2
-rw-r--r--devel/ruby-property/Makefile2
-rw-r--r--devel/ruby-rbison/Makefile2
-rw-r--r--devel/ruby-setup.rb/Makefile2
-rw-r--r--devel/ruby-statgrab/Makefile2
-rw-r--r--devel/ruby-wirble/Makefile2
-rw-r--r--devel/srecord/Makefile2
56 files changed, 128 insertions, 43 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 74cf34bafae5..d5c669a65a9d 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -63,7 +63,7 @@ SHEBANG_FILES= scripts/builder2schema.pl \
plugins/gbf-mkfile/gbf-mkfile-parse.in \
plugins/tools/scripts/*.pl
-OPTIONS_DEFINE= SVN DEVHELP
+OPTIONS_DEFINE= SVN DEVHELP DOCS
OPTIONS_DEFAULT=DEVHELP
DEVHELP_DESC= Devhelp support
diff --git a/devel/art/Makefile b/devel/art/Makefile
index f399de119343..3113c8cf8655 100644
--- a/devel/art/Makefile
+++ b/devel/art/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26
USES= gmake pkgconfig
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/artlibgen/src/artlibgen ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/artrepgen/artrepgen ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index b1a18dedd843..b156d98e4c21 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -21,6 +21,8 @@ USES= compiler gmake iconv
WRKSRC= ${WRKDIR}/astyle/build/gcc
+OPTIONS_DEFINE= DOCS
+
pre-patch:
@${REINPLACE_CMD} -e 's,^CFLAGS,#CFLAGS,; s,g++,${CXX},; \
s,\(CFLAGSr.*=.*\),\1 -I${LOCALBASE}/include,' \
diff --git a/devel/buildtool-doc/Makefile b/devel/buildtool-doc/Makefile
index cb9f9c18dd77..5a72b53d0056 100644
--- a/devel/buildtool-doc/Makefile
+++ b/devel/buildtool-doc/Makefile
@@ -25,6 +25,8 @@ DOCBOOK_XSL= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl
DOCS= CHANGES COPYING PEOPLE README README.bt
+OPTIONS_DEFINE= DOCS
+
do-configure:
cd ${WRKSRC} && \
CATALOG_FILE=${LOCALBASE}/share/xml/catalog.ports \
diff --git a/devel/c4/Makefile b/devel/c4/Makefile
index 1f942ec7d4b2..414d227b1129 100644
--- a/devel/c4/Makefile
+++ b/devel/c4/Makefile
@@ -13,12 +13,14 @@ COMMENT= CVS-like Frontend to Perforce
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= c4
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/c4 ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/c4.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/c4 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/c4.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/c4.pdf ${STAGEDIR}${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/c4.ps ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/c4.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/c4.ps ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index f2a9d5c63bad..2ca2eb30a973 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -25,7 +25,7 @@ ALL_TARGET= default examples demos cli cdkshlib
INSTALL_TARGET= install installCDKSHLibrary
USE_LDCONFIG= yes
-OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
diff --git a/devel/cppunit/Makefile b/devel/cppunit/Makefile
index 52a46df0ae0b..a57482e22665 100644
--- a/devel/cppunit/Makefile
+++ b/devel/cppunit/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= C++ port of the JUnit framework for unit testing
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOXYGEN DOCS
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
diff --git a/devel/csmith/Makefile b/devel/csmith/Makefile
index 4d071cf23658..40180201e108 100644
--- a/devel/csmith/Makefile
+++ b/devel/csmith/Makefile
@@ -20,4 +20,6 @@ USES= gmake
ONLY_FOR_ARCHS= i386 amd64
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/devel/cvsweb/Makefile b/devel/cvsweb/Makefile
index c4b862d5a45e..4f1b610eacec 100644
--- a/devel/cvsweb/Makefile
+++ b/devel/cvsweb/Makefile
@@ -19,6 +19,8 @@ CONFLICTS= cvsweb-3.*
NO_BUILD= yes
USES= perl5
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
# Specify where your repository belongs.
diff --git a/devel/ddd/Makefile b/devel/ddd/Makefile
index cf8718b45eeb..3f5afc862044 100644
--- a/devel/ddd/Makefile
+++ b/devel/ddd/Makefile
@@ -28,6 +28,8 @@ DOCS= AUTHORS INSTALL PROBLEMS README TIPS TODO \
doc/ddd-themes.pdf doc/ddd.pdf
INFO= ddd ddd-themes
+OPTIONS_DEFINE= DOCS
+
.if defined(MOTIFLIB)
.if defined(MOTIF_STATIC)
LIBXMDIR!= ${ECHO_CMD} ${MOTIFLIB} | ${SED} -e 's/\/libXm\.a//g' | ${AWK} '{print $$1}'
diff --git a/devel/ditrack/Makefile b/devel/ditrack/Makefile
index 985d9ddef9d4..7efa5e53a856 100644
--- a/devel/ditrack/Makefile
+++ b/devel/ditrack/Makefile
@@ -20,6 +20,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= DITrack
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/upgrade-0.7-db.py ${STAGEDIR}${DATADIR}
diff --git a/devel/fga/Makefile b/devel/fga/Makefile
index 7ba26c655147..aa114a3d99b2 100644
--- a/devel/fga/Makefile
+++ b/devel/fga/Makefile
@@ -16,12 +16,14 @@ USES= gmake
EXAMPLES= graph_gen maxbit tsp tsp_bf
PORTDOCS= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-install:
${INSTALL_DATA} ${WRKSRC}/include/fga.hpp ${STAGEDIR}${PREFIX}/include
${INSTALL_PROGRAM} ${EXAMPLES:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
- ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/,:S,$,.cpp,} ${STAGEDIR}${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/,:S,$,.cpp,} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/fga/pkg-plist b/devel/fga/pkg-plist
index 0efacc75c7e4..26173fca5e63 100644
--- a/devel/fga/pkg-plist
+++ b/devel/fga/pkg-plist
@@ -3,8 +3,8 @@ bin/maxbit
bin/tsp
bin/tsp_bf
include/fga.hpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/graph_gen.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/maxbit.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/tsp.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/tsp_bf.cpp
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph_gen.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/maxbit.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsp.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsp_bf.cpp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/devel/flyspray/Makefile b/devel/flyspray/Makefile
index faaed8c26e4a..97fcfac715ee 100644
--- a/devel/flyspray/Makefile
+++ b/devel/flyspray/Makefile
@@ -21,7 +21,7 @@ NO_WRKSUBDIR= yes
DOS2UNIX_REGEX= .php
-OPTIONS_DEFINE= GRAPHVIZ MYSQL MYSQLI PGSQL
+OPTIONS_DEFINE= GRAPHVIZ MYSQL MYSQLI PGSQL DOCS
OPTIONS_DEFAULT= MYSQLI
MYSQLI_DESC= Use MySQLi Database Interface
diff --git a/devel/gazpacho/Makefile b/devel/gazpacho/Makefile
index 05fab5a63896..256cc64c8b29 100644
--- a/devel/gazpacho/Makefile
+++ b/devel/gazpacho/Makefile
@@ -17,10 +17,12 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/kiwi-i18n:${PORTSDIR}/x11-toolkits/py-kiwi
NO_BUILD= yes
USE_GNOME= pygtk2
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS=yes
USES= gettext
DOCS= AUTHORS ChangeLog CONTRIBUTORS COPYING README NEWS
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|share/doc/gazpacho/examples|${EXAMPLESDIR}|g' ${WRKSRC}/setup.py
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index fdb670936084..e1136376bf9e 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -13,7 +13,7 @@ COMMENT= Complete gcc-based toolcahin for embedded ARM development
LICENSE= GPLv2 LGPL20 LGPL21 GPLv3 LGPL3
LICENSE_COMB= multi
-OPTIONS_DEFINE= PURE EXAMPLES HTML PDF
+OPTIONS_DEFINE= PURE EXAMPLES HTML PDF DOCS
OPTIONS_DEFAULT=EXAMPLES
PURE_DESC= Use all libraries from bundle, do not depend on anything
HTML_DESC= Install HTML documentation
diff --git a/devel/kickassembler/Makefile b/devel/kickassembler/Makefile
index 49e83e7964f7..9e506f4210cd 100644
--- a/devel/kickassembler/Makefile
+++ b/devel/kickassembler/Makefile
@@ -19,6 +19,8 @@ SUB_LIST= PORTNAME=${PORTNAME}
SUB_FILES= kickassembler.sh
WRKSRC= ${WRKDIR}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-extract-script:
@${MV} "${WRKSRC}/Examples/MusicIrq/ode to 64.bin" ${WRKSRC}/Examples/MusicIrq/odeto64.bin
diff --git a/devel/libdict/Makefile b/devel/libdict/Makefile
index e864bf78d3a1..c9ac80a46055 100644
--- a/devel/libdict/Makefile
+++ b/devel/libdict/Makefile
@@ -18,6 +18,8 @@ MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
+OPTIONS_DEFINE= DOCS
+
post-extract:
. for ___f in avl_insert.pdf empty.pdf treap_insert.pdf
@${CP} ${DISTDIR}/${___f} ${WRKSRC}/
diff --git a/devel/libexplain/Makefile b/devel/libexplain/Makefile
index 40e011368b5b..e6e7e450039e 100644
--- a/devel/libexplain/Makefile
+++ b/devel/libexplain/Makefile
@@ -28,6 +28,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PATCHLEVEL= D012
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
's|$$(libdir)/pkgconfig|$$(libdir)/../libdata/pkgconfig|g ; \
diff --git a/devel/libstatgrab/Makefile b/devel/libstatgrab/Makefile
index 9d0626f9aca1..560dec9af6c1 100644
--- a/devel/libstatgrab/Makefile
+++ b/devel/libstatgrab/Makefile
@@ -17,7 +17,7 @@ USES= pathfix pkgconfig libtool
CONFIGURE_ARGS+= --docdir=${DOCSDIR}
-OPTIONS_DEFINE= TOOLS
+OPTIONS_DEFINE= TOOLS DOCS
OPTIONS_DEFAULT= TOOLS
TOOLS_DESC= Build and install statgrab and saidar
diff --git a/devel/libvc/Makefile b/devel/libvc/Makefile
index 5ecd32a56a4f..950349e033b2 100644
--- a/devel/libvc/Makefile
+++ b/devel/libvc/Makefile
@@ -14,6 +14,8 @@ USES= bison libtool tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for DOC in AUTHORS ChangeLog NEWS README THANKS doc/rfc2426.txt
diff --git a/devel/loki/Makefile b/devel/loki/Makefile
index c7b5dfe103a3..54bc806ba68f 100644
--- a/devel/loki/Makefile
+++ b/devel/loki/Makefile
@@ -18,6 +18,8 @@ DOCS= README CHANGES doc/flex/flex_string.html \
doc/yasli/Notes.txt \
doc/yasli/yasli.html
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's/bad_function_call/Loki::bad_function_call/g' \
${WRKSRC}/test/Function/FunctionTest.cpp
diff --git a/devel/mk-configure/Makefile b/devel/mk-configure/Makefile
index 44e255c513d4..e865984317f4 100644
--- a/devel/mk-configure/Makefile
+++ b/devel/mk-configure/Makefile
@@ -20,6 +20,8 @@ INSTALL_TARGET= installdirs install install-doc
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${ECHO_CMD} "MKDEP ?= bmkdep" >> ${WRKSRC}/mk/sys.mk
diff --git a/devel/ocaml-findlib/Makefile b/devel/ocaml-findlib/Makefile
index 62bcd57ce3aa..b007ace560c6 100644
--- a/devel/ocaml-findlib/Makefile
+++ b/devel/ocaml-findlib/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS= -bindir "${PREFIX}/bin" -mandir "${PREFIX}/man" \
USE_OCAML_FINDLIB=yes
OCAMLFIND_DEPEND= # Avoid dependency loop
-OPTIONS_DEFINE= TOOLBOX
+OPTIONS_DEFINE= TOOLBOX DOCS
OPTIONS_DEFAULT=TOOLBOX
OPTIONS_SUB= yes
TOOLBOX_DESC= Include toolbox interface (requires OCaml with TK)
diff --git a/devel/ocaml-magic/Makefile b/devel/ocaml-magic/Makefile
index 77ab78132341..f45f9947b2a7 100644
--- a/devel/ocaml-magic/Makefile
+++ b/devel/ocaml-magic/Makefile
@@ -23,6 +23,8 @@ ALL_TARGET+= doc examples
DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
# This really is overzealous but I work this way
.if !exists(/usr/lib/libmagic.so)
LIB_DEPENDS+= libmagic.so:${PORTSDIR}/sysutils/file
diff --git a/devel/ocaml-pcre/Makefile b/devel/ocaml-pcre/Makefile
index 04e7fe63c3a7..7daabb4303d5 100644
--- a/devel/ocaml-pcre/Makefile
+++ b/devel/ocaml-pcre/Makefile
@@ -20,6 +20,8 @@ USE_OCAML_LDCONFIG= yes
EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/pcre-ocaml
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|$$prefix"/"share|${STAGEDIR}${PREFIX}/share|' \
${WRKSRC}/setup.ml
diff --git a/devel/oniguruma4/Makefile b/devel/oniguruma4/Makefile
index d54b83498077..1b6f51e17571 100644
--- a/devel/oniguruma4/Makefile
+++ b/devel/oniguruma4/Makefile
@@ -19,6 +19,8 @@ DOCS= HISTORY README doc/*
PKGNAMESUFFIX= 4
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
-e 's|freebsd1|freebsd1.|' \
diff --git a/devel/p4api/Makefile b/devel/p4api/Makefile
index 3d638d5f88a0..9927b9736adf 100644
--- a/devel/p4api/Makefile
+++ b/devel/p4api/Makefile
@@ -20,6 +20,8 @@ WRKSRC= ${WRKDIR}/p4api-2008.1.158777
PLATFORM= freebsd60
VERSION= 08.1
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
diff --git a/devel/p5-App-Build/Makefile b/devel/p5-App-Build/Makefile
index b005a05fd3ff..cf8c6639e86d 100644
--- a/devel/p5-App-Build/Makefile
+++ b/devel/p5-App-Build/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= p5-Test-Differences>=0.47:${PORTSDIR}/devel/p5-Test-Differences \
USES= perl5
USE_PERL5= modbuild
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/CHANGES ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/devel/p5-Class-Contract/pkg-plist b/devel/p5-Class-Contract/pkg-plist
index 50474a9cc99f..67d29159472a 100644
--- a/devel/p5-Class-Contract/pkg-plist
+++ b/devel/p5-Class-Contract/pkg-plist
@@ -3,8 +3,8 @@
%%SITE_PERL%%/Class/Contract.pm
%%SITE_PERL%%/Class/Contract/Production.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Contract/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Contract
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
@dirrm %%SITE_PERL%%/Class/Contract
diff --git a/devel/p5-Class-Delegation/pkg-plist b/devel/p5-Class-Delegation/pkg-plist
index dad090a74614..368e2288500c 100644
--- a/devel/p5-Class-Delegation/pkg-plist
+++ b/devel/p5-Class-Delegation/pkg-plist
@@ -1,13 +1,13 @@
%%PERL5_MAN3%%/Class::Delegation.3.gz
%%SITE_PERL%%/Class/Delegation.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Delegation/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo_adapt_interface.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo_change_semantics.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo_facade.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo_handle.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo_inheritance.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo_pseudo.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_adapt_interface.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_change_semantics.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_facade.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_handle.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_inheritance.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_pseudo.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Delegation
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
@dirrmtry %%SITE_PERL%%/Class
diff --git a/devel/p5-Devel-Diagram/pkg-plist b/devel/p5-Devel-Diagram/pkg-plist
index 6bc21558f230..73195c3ddbe2 100644
--- a/devel/p5-Devel-Diagram/pkg-plist
+++ b/devel/p5-Devel-Diagram/pkg-plist
@@ -4,14 +4,14 @@
%%SITE_PERL%%/Devel/Diagram/Render/UXF20.pm
%%SITE_PERL%%/Devel/Diagram/xsl/uxf20toHtml.xsl
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/Diagram/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/ClassDiagram.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/cd-CGI.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/cd-CPAN.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/cd-DBI.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/cd-HTML.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/cd-IO.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/cd-LWP.html
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ClassDiagram.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cd-CGI.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cd-CPAN.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cd-DBI.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cd-HTML.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cd-IO.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cd-LWP.html
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/Diagram
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel
@dirrm %%SITE_PERL%%/Devel/Diagram/xsl
diff --git a/devel/p5-IO-KQueue/Makefile b/devel/p5-IO-KQueue/Makefile
index 68989523285e..3f294cec13ed 100644
--- a/devel/p5-IO-KQueue/Makefile
+++ b/devel/p5-IO-KQueue/Makefile
@@ -12,6 +12,8 @@ COMMENT= Perl interface to the BSD kqueue system call
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/devel/p5-IO-KQueue/pkg-plist b/devel/p5-IO-KQueue/pkg-plist
index 46f02c773c0a..e50032fb6303 100644
--- a/devel/p5-IO-KQueue/pkg-plist
+++ b/devel/p5-IO-KQueue/pkg-plist
@@ -1,9 +1,9 @@
%%SITE_PERL%%/%%PERL_ARCH%%/IO/KQueue.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/KQueue/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/KQueue/KQueue.so
-%%PORTDOCS%%%%EXAMPLESDIR%%/chat.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/tail.pl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chat.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tail.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PERL5_MAN3%%/IO::KQueue.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/KQueue
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO
diff --git a/devel/py-period/Makefile b/devel/py-period/Makefile
index 75f27f247287..3c7b4fc013ed 100644
--- a/devel/py-period/Makefile
+++ b/devel/py-period/Makefile
@@ -13,6 +13,8 @@ COMMENT= Basic time period checking library
USE_PYTHON= yes
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
${INSTALL_SCRIPT} ${WRKSRC}/period.py ${STAGEDIR}${PYTHON_SITELIBDIR}
diff --git a/devel/py-traits/Makefile b/devel/py-traits/Makefile
index 11491e0f444a..bb44a30b4582 100644
--- a/devel/py-traits/Makefile
+++ b/devel/py-traits/Makefile
@@ -22,6 +22,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples \
diff --git a/devel/py-xoltar-toolkit/Makefile b/devel/py-xoltar-toolkit/Makefile
index 9599b69e2229..9c7b20fac05d 100644
--- a/devel/py-xoltar-toolkit/Makefile
+++ b/devel/py-xoltar-toolkit/Makefile
@@ -14,6 +14,8 @@ COMMENT= Functional programming, lazy expressions, and thread pools for Python
USE_PYTHON= 2
NO_WRKSUBDIR= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
diff --git a/devel/pychecker/Makefile b/devel/pychecker/Makefile
index 6e9be28b5a23..fd74a8e43f63 100644
--- a/devel/pychecker/Makefile
+++ b/devel/pychecker/Makefile
@@ -17,6 +17,8 @@ PYDISTUTILS_AUTOPLIST= yes
DOCS= ChangeLog COPYRIGHT KNOWN_BUGS MAINTAINERS README TODO VERSION
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/devel/raknet/Makefile b/devel/raknet/Makefile
index 4ea4009fbaa4..76b118297c50 100644
--- a/devel/raknet/Makefile
+++ b/devel/raknet/Makefile
@@ -43,6 +43,8 @@ DOS2UNIX_REGEX= .*\.(cpp|h|txt)
# have to be provided by the port to have working extensions
CMAKE_ARGS+= -DDISABLEDEPENDENCIES:BOOL=ON
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${FIND} ${WRKSRC} -type f -a '(' -name '*.cpp' -o -name '*.h' ')' -print0 \
| ${XARGS} -0 -x -n10 \
diff --git a/devel/readline/Makefile b/devel/readline/Makefile
index b30cbfa2041f..a2297854eb1f 100644
--- a/devel/readline/Makefile
+++ b/devel/readline/Makefile
@@ -18,7 +18,7 @@ COMMENT= Library for editing command lines as they are typed
LICENSE= GPLv3
-OPTIONS_DEFINE= TERMCAP
+OPTIONS_DEFINE= TERMCAP DOCS
OPTIONS_DEFAULT=TERMCAP
TERMCAP_DESC= Link against libtermcap
diff --git a/devel/ruby-byaccr/Makefile b/devel/ruby-byaccr/Makefile
index 5011a758503e..6990c99c81f1 100644
--- a/devel/ruby-byaccr/Makefile
+++ b/devel/ruby-byaccr/Makefile
@@ -17,6 +17,8 @@ RUBY_NO_RUN_DEPENDS= yes
DOCS= README README.html
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} 's,^#include <malloc\.h>,#include <stdlib.h>,' ${WRKSRC}/*.[ch]
diff --git a/devel/ruby-cache/Makefile b/devel/ruby-cache/Makefile
index 8ad03a7cfdf0..e03246a45c23 100644
--- a/devel/ruby-cache/Makefile
+++ b/devel/ruby-cache/Makefile
@@ -21,6 +21,8 @@ RUBY_SETUP= install.rb
DOCS= MANUAL.rd README.rd
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
diff --git a/devel/ruby-calendar/Makefile b/devel/ruby-calendar/Makefile
index 4fc08f79d4aa..27bc18685b09 100644
--- a/devel/ruby-calendar/Makefile
+++ b/devel/ruby-calendar/Makefile
@@ -20,6 +20,8 @@ DOCS_EN= README.en ext/sdn/README.sdncal20
DOCS_JA= README
EXAMPLES_EN= ext/calendar/cal*.rb
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES_EN}
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
index 5cbb2657b836..64a667370b00 100644
--- a/devel/ruby-date2/Makefile
+++ b/devel/ruby-date2/Makefile
@@ -20,6 +20,7 @@ DOCS_JA= MANUAL MANUAL.rd MANUAL.html README
EXAMPLES_EN= cal.rb daylight.rb goodfriday.rb
EXAMPLES_JA= ncal.rb
+OPTIONS_DEFINE= DOCS
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/ja
diff --git a/devel/ruby-dialogs/Makefile b/devel/ruby-dialogs/Makefile
index acad7c7b6ae7..edff0d1fdb61 100644
--- a/devel/ruby-dialogs/Makefile
+++ b/devel/ruby-dialogs/Makefile
@@ -17,6 +17,8 @@ RUBY_NO_BUILD_DEPENDS= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKDIR}/dialogs.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/devel/ruby-fastri/Makefile b/devel/ruby-fastri/Makefile
index c43a7ad99ecb..fa99bdca2513 100644
--- a/devel/ruby-fastri/Makefile
+++ b/devel/ruby-fastri/Makefile
@@ -17,6 +17,8 @@ CONFIGURE_ARGS= --prefix="${PREFIX}"
DOCS= CHANGES README.en
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${RUBY_MODDOCDIR}/
diff --git a/devel/ruby-intl/Makefile b/devel/ruby-intl/Makefile
index 68ab6e9a4dab..de3f58a227db 100644
--- a/devel/ruby-intl/Makefile
+++ b/devel/ruby-intl/Makefile
@@ -20,6 +20,8 @@ USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALL_TARGET= site-install
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/po/
${INSTALL_DATA} ${WRKSRC}/hello.rb ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
diff --git a/devel/ruby-locale2/Makefile b/devel/ruby-locale2/Makefile
index 0e0792fb8ae5..22a1796342da 100644
--- a/devel/ruby-locale2/Makefile
+++ b/devel/ruby-locale2/Makefile
@@ -18,6 +18,8 @@ CONFLICTS= ${PKGNAMEPREFIX}locale-[0-9]*
USE_RUBY= yes
USE_RUBY_SETUP= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/
${INSTALL_DATA} ${WRKSRC}/README.rdoc ${STAGEDIR}${RUBY_MODDOCDIR}/
diff --git a/devel/ruby-multi/Makefile b/devel/ruby-multi/Makefile
index 8865c38349ef..114c27d10e74 100644
--- a/devel/ruby-multi/Makefile
+++ b/devel/ruby-multi/Makefile
@@ -18,6 +18,8 @@ NO_BUILD= yes
EXAMPLES= multi_example.rb
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/multi.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/devel/ruby-ncurses/Makefile b/devel/ruby-ncurses/Makefile
index aaf42243c5a8..ff96fe67d131 100644
--- a/devel/ruby-ncurses/Makefile
+++ b/devel/ruby-ncurses/Makefile
@@ -22,6 +22,8 @@ INSTALL_TARGET= site-install
DOCS= COPYING Changes README THANKS TODO
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
diff --git a/devel/ruby-property/Makefile b/devel/ruby-property/Makefile
index 8733ab073475..83edd43c97a4 100644
--- a/devel/ruby-property/Makefile
+++ b/devel/ruby-property/Makefile
@@ -16,6 +16,8 @@ USE_RUBY= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-patch:
${RUBY} -i -pe 'gsub /rubyapi\.css/, "../rubyapi.css"' ${WRKSRC}/Properties-ja.html
diff --git a/devel/ruby-rbison/Makefile b/devel/ruby-rbison/Makefile
index 975fd511f871..5a500f2e8108 100644
--- a/devel/ruby-rbison/Makefile
+++ b/devel/ruby-rbison/Makefile
@@ -23,6 +23,8 @@ EXAMPLES= CalcFileLexer.rb CalcStringLexer.rb \
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/rbison ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
diff --git a/devel/ruby-setup.rb/Makefile b/devel/ruby-setup.rb/Makefile
index 7e1ab3b5af32..52739f5bf585 100644
--- a/devel/ruby-setup.rb/Makefile
+++ b/devel/ruby-setup.rb/Makefile
@@ -24,6 +24,8 @@ RUBY_SHEBANG_FILES= ${_SCRIPTS:S:^:${WRKSRC}/ruby-:}
DOCS_EN= doc.en/* NEWS.en Usage_en.txt README.en ChangeLog TODO
DOCS_JA= doc.ja/* NEWS.ja Usage_ja.txt README.ja
+OPTIONS_DEFINE= DOCS
+
post-extract:
.for f in ${_SCRIPTS}
${CP} -p ${WRKSRC}/${f} ${WRKSRC}/ruby-${f}
diff --git a/devel/ruby-statgrab/Makefile b/devel/ruby-statgrab/Makefile
index 4eec3fdb83d5..135ae5e5f607 100644
--- a/devel/ruby-statgrab/Makefile
+++ b/devel/ruby-statgrab/Makefile
@@ -20,6 +20,8 @@ USES= pkgconfig
INSTALL_TARGET= site-install
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README.mkdn ${STAGEDIR}${RUBY_MODDOCDIR}
diff --git a/devel/ruby-wirble/Makefile b/devel/ruby-wirble/Makefile
index c7696e8a6e39..60fa6eba0112 100644
--- a/devel/ruby-wirble/Makefile
+++ b/devel/ruby-wirble/Makefile
@@ -15,6 +15,8 @@ DOCS_EN= README
USE_RUBY= yes
do-build:
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/lib/wirble.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/devel/srecord/Makefile b/devel/srecord/Makefile
index a1971f547f59..7d64f9b205f6 100644
--- a/devel/srecord/Makefile
+++ b/devel/srecord/Makefile
@@ -32,6 +32,8 @@ HEADER_DIRS= input \
output/file \
quit
+OPTIONS_DEFINE= DOCS
+
post-build:
cd ${WRKSRC} && ${MAKE_CMD} libdir/pkgconfig/srecord.pc