aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-14 10:50:53 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-14 10:50:53 +0000
commit57853c4e4643899a11f882a8ae2822c6853f8487 (patch)
treef57e844183210e95046ed3e90a9e7760af10f076 /devel
parent1821746de27af20aedfa4aec4dd41e15278da191 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sort-Key-DateTime/Makefile32
-rw-r--r--devel/p5-Sort-Key-DateTime/distinfo2
-rw-r--r--devel/p5-Sort-Key-DateTime/pkg-descr4
-rw-r--r--devel/p5-Sort-Key-DateTime/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e19667f36b46..93f14bb6d056 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1103,6 +1103,7 @@
SUBDIR += p5-Sort-Array
SUBDIR += p5-Sort-ArrayOfArrays
SUBDIR += p5-Sort-Key
+ SUBDIR += p5-Sort-Key-DateTime
SUBDIR += p5-Sort-Tree
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Spiffy
diff --git a/devel/p5-Sort-Key-DateTime/Makefile b/devel/p5-Sort-Key-DateTime/Makefile
new file mode 100644
index 000000000000..3af6b6b5d51e
--- /dev/null
+++ b/devel/p5-Sort-Key-DateTime/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: devel/p5-Sort-Key-DateTime
+# Date created: 14 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sort-Key-DateTime
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sort
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for sorting objects by some DateTime key
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/${PERL_ARCH}/Sort/Key.pm:${PORTSDIR}/devel/p5-Sort-Key
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sort::Key::DateTime.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sort-Key-DateTime/distinfo b/devel/p5-Sort-Key-DateTime/distinfo
new file mode 100644
index 000000000000..ead1664735d8
--- /dev/null
+++ b/devel/p5-Sort-Key-DateTime/distinfo
@@ -0,0 +1,2 @@
+MD5 (Sort-Key-DateTime-0.05.tar.gz) = 68f6a71cb2a0a389f55ea1fa91b67629
+SIZE (Sort-Key-DateTime-0.05.tar.gz) = 2570
diff --git a/devel/p5-Sort-Key-DateTime/pkg-descr b/devel/p5-Sort-Key-DateTime/pkg-descr
new file mode 100644
index 000000000000..522fe6fda6d9
--- /dev/null
+++ b/devel/p5-Sort-Key-DateTime/pkg-descr
@@ -0,0 +1,4 @@
+Sort::Key::DateTime allows to sort objects by some (calculated) key of
+type DateTime.
+
+WWW: http://search.cpan.org/dist/Sort-Key-DateTime/
diff --git a/devel/p5-Sort-Key-DateTime/pkg-plist b/devel/p5-Sort-Key-DateTime/pkg-plist
new file mode 100644
index 000000000000..500d1e7e1a72
--- /dev/null
+++ b/devel/p5-Sort-Key-DateTime/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Sort/Key/DateTime.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key/DateTime/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Sort/Key 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Sort 2>/dev/null || true