aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2012-05-06 09:43:49 +0000
committerEygene Ryabinkin <rea@FreeBSD.org>2012-05-06 09:43:49 +0000
commit6c395d15c9c0b4f1da2c14735bc1d1958815fef3 (patch)
tree2bce3f701b7dc62aa7a32e4df58abc209b4358d8 /devel
parent3729e9edb30dbe4ad228895c52b0c7d4a9e991e9 (diff)
downloadports-6c395d15c9c0b4f1da2c14735bc1d1958815fef3.tar.gz
ports-6c395d15c9c0b4f1da2c14735bc1d1958815fef3.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/lxr/Makefile2
-rw-r--r--devel/lxr/distinfo4
-rw-r--r--devel/lxr/files/patch-use-strict-syntax23
-rw-r--r--devel/lxr/files/pkg_message.in8
-rw-r--r--devel/lxr/pkg-plist7
5 files changed, 38 insertions, 6 deletions
diff --git a/devel/lxr/Makefile b/devel/lxr/Makefile
index 1f946df5c0d5..31d91a7f7834 100644
--- a/devel/lxr/Makefile
+++ b/devel/lxr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lxr
-PORTVERSION= 0.9.10
+PORTVERSION= 0.10.2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
diff --git a/devel/lxr/distinfo b/devel/lxr/distinfo
index 648be5eb555c..31553234f789 100644
--- a/devel/lxr/distinfo
+++ b/devel/lxr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lxr-0.9.10.tgz) = dbbad73ebde6ea734b5bc299cfe7545a5b371e62cdff0605691e7f0498b6ca18
-SIZE (lxr-0.9.10.tgz) = 115993
+SHA256 (lxr-0.10.2.tgz) = 109b8d21f804cd18b27f9cd304b0bd45af8d492650800b83dcbca6d949d97ee6
+SIZE (lxr-0.10.2.tgz) = 138193
diff --git a/devel/lxr/files/patch-use-strict-syntax b/devel/lxr/files/patch-use-strict-syntax
new file mode 100644
index 000000000000..e5e74e21c31a
--- /dev/null
+++ b/devel/lxr/files/patch-use-strict-syntax
@@ -0,0 +1,23 @@
+--- a/lib/LXR/Common.pm.orig 2012-03-10 22:34:11.000000000 +0400
++++ b/lib/LXR/Common.pm 2012-03-10 22:33:21.000000000 +0400
+@@ -62,9 +62,9 @@
+ our $identifier;
+ our $HTTP;
+
+-$wwwdebug = 0;
++my $wwwdebug = 0;
+
+-$tmpcounter = 23;
++my $tmpcounter = 23;
+
+ sub warning {
+ my $msg = shift;
+@@ -111,7 +111,7 @@
+ sub nonvarargs {
+ my @args;
+
+- foreach my $param (%{keys $HTTP->{'param'}}) {
++ foreach my $param (keys %{$HTTP->{'param'}}) {
+ next unless $param =~ m!^_!;
+ my $val = $HTTP->{'param'}->{$param};
+ if (length($val)) {
diff --git a/devel/lxr/files/pkg_message.in b/devel/lxr/files/pkg_message.in
index 35f9754d4e1d..edf20e8bdf2d 100644
--- a/devel/lxr/files/pkg_message.in
+++ b/devel/lxr/files/pkg_message.in
@@ -23,6 +23,14 @@ You should look at the contents of the directory
and possibly merge new stuff from it to the corresponding files in
%%LXRDIR%%/
+0.9.x -> 0.10.x
+===============
+
+Search templates were changed, be sure to look at the files
+ %%LXRDIR%%/templates/html-ident.html
+ %%LXRDIR%%/templates/html-search-swish.html
+ %%LXRDIR%%/templates/html-search-glimpse.html
+
Happy cross-referencing and code mining!
diff --git a/devel/lxr/pkg-plist b/devel/lxr/pkg-plist
index 674073c7df39..4e7b09488d32 100644
--- a/devel/lxr/pkg-plist
+++ b/devel/lxr/pkg-plist
@@ -8,13 +8,12 @@
%%LXRDIR%%/initdb-mysql
%%LXRDIR%%/upgrade-0.9.10-postgres
%%LXRDIR%%/upgrade-0.9.10-mysql
-%%LXRDIR%%/templates/html-head-btn.html
%%LXRDIR%%/templates/valid-html401.png
-%%LXRDIR%%/templates/diff-head-btn.html
+%%LXRDIR%%/templates/vcss
+%%LXRDIR%%/templates/html-head-btn.html
%%LXRDIR%%/templates/html-fatal.html
%%LXRDIR%%/templates/html-dir.html
%%LXRDIR%%/templates/html-head.html
-%%LXRDIR%%/templates/html-ident-refs.html
%%LXRDIR%%/templates/html-ident.html
%%LXRDIR%%/templates/html-search-glimpse.html
%%LXRDIR%%/templates/html-search-swish.html
@@ -39,8 +38,10 @@
%%SITE_PERL%%/LXR/Files.pm
%%SITE_PERL%%/LXR/Index.pm
%%SITE_PERL%%/LXR/Lang.pm
+%%SITE_PERL%%/LXR/Markup.pm
%%SITE_PERL%%/LXR/SimpleParse.pm
%%SITE_PERL%%/LXR/Tagger.pm
+%%SITE_PERL%%/LXR/Template.pm
%%SITE_PERL%%/LXR/Index/Mysql.pm
%%SITE_PERL%%/LXR/Index/DBI.pm
%%SITE_PERL%%/LXR/Index/Oracle.pm