aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-05 06:31:32 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-05 06:31:32 +0000
commit7b95ee310249bed9eda7bb418725d431cb3f2e74 (patch)
treecebc15636fdb0c62e73a3775b490a5bfa24d9724 /devel
parent81200350b5a94637058a4a318e942b61a1e254e7 (diff)
downloadports-7b95ee310249bed9eda7bb418725d431cb3f2e74.tar.gz
ports-7b95ee310249bed9eda7bb418725d431cb3f2e74.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ccrtp/Makefile12
-rw-r--r--devel/ccrtp/distinfo6
-rw-r--r--devel/ccrtp/pkg-plist5
-rw-r--r--devel/commoncpp/Makefile2
-rw-r--r--devel/commoncpp/distinfo6
-rw-r--r--devel/commoncpp/files/patch-include-cc++_address.h28
-rw-r--r--devel/commoncpp/files/patch-src_thread.cpp11
-rw-r--r--devel/commoncpp/pkg-plist8
8 files changed, 62 insertions, 16 deletions
diff --git a/devel/ccrtp/Makefile b/devel/ccrtp/Makefile
index ba690d8b76fe..ff3fc09b2b05 100644
--- a/devel/ccrtp/Makefile
+++ b/devel/ccrtp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ccrtp
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,15 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
COMMENT= Implementation of the real-time transport protocol
-LIB_DEPENDS= ccgnu2-1.4.0:${PORTSDIR}/devel/commoncpp
+LIB_DEPENDS= ccgnu2-1.5.0:${PORTSDIR}/devel/commoncpp
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_GCC= 3.4+
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
INFO= ccrtp
+post-patch:
+ @cd ${WRKSRC}/src && \
+ ${FIND} * -type f -exec ${REINPLACE_CMD} -i "" -e "s|<malloc.h>|<stdlib.h>|g" "{}" \;
+
.include <bsd.port.mk>
diff --git a/devel/ccrtp/distinfo b/devel/ccrtp/distinfo
index 8a64ab27cdf6..5b24db6ffb20 100644
--- a/devel/ccrtp/distinfo
+++ b/devel/ccrtp/distinfo
@@ -1,3 +1,3 @@
-MD5 (ccrtp-1.4.1.tar.gz) = 632aacddec2998f393d1773a078d881a
-SHA256 (ccrtp-1.4.1.tar.gz) = de0214d0933a59e8c5e99fb411556ef36186aba9ed345a43db20968c6315b1af
-SIZE (ccrtp-1.4.1.tar.gz) = 585909
+MD5 (ccrtp-1.5.0.tar.gz) = 019754d20b46b1b23f3bc368aa58d662
+SHA256 (ccrtp-1.5.0.tar.gz) = e6073cd096e3230e8036ed4dd1eca96bab1527f98eeb2823d646d40c53d8c153
+SIZE (ccrtp-1.5.0.tar.gz) = 615076
diff --git a/devel/ccrtp/pkg-plist b/devel/ccrtp/pkg-plist
index ea5557905fd4..680bff45a97b 100644
--- a/devel/ccrtp/pkg-plist
+++ b/devel/ccrtp/pkg-plist
@@ -1,3 +1,4 @@
+include/ccrtp/CryptoContext.h
include/ccrtp/base.h
include/ccrtp/cqueue.h
include/ccrtp/channel.h
@@ -12,8 +13,8 @@ include/ccrtp/rtcppkt.h
include/ccrtp/rtp.h
include/ccrtp/rtppkt.h
include/ccrtp/sources.h
-lib/libccrtp1-1.4.so.0
-lib/libccrtp1-1.4.so
+lib/libccrtp1-1.5.so.0
+lib/libccrtp1-1.5.so
lib/libccrtp1.so
lib/libccrtp1.a
lib/libccrtp1.la
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 93cbcb46eb3c..1946feb0bfc1 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= commoncpp
-PORTVERSION= 1.4.2
+PORTVERSION= 1.5.0
PORTEPOCH= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/devel/commoncpp/distinfo b/devel/commoncpp/distinfo
index e4671f860cf8..3ff99fb2459b 100644
--- a/devel/commoncpp/distinfo
+++ b/devel/commoncpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (commoncpp2-1.4.2.tar.gz) = 4153ec41bc11c52f05f2f2e35cf66953
-SHA256 (commoncpp2-1.4.2.tar.gz) = 640a2201209d4b2b9795729219036b3f058907675c18f8848addb3a69f8e4202
-SIZE (commoncpp2-1.4.2.tar.gz) = 851571
+MD5 (commoncpp2-1.5.0.tar.gz) = c454fa913f2f1ce53a3ccea27ec4a068
+SHA256 (commoncpp2-1.5.0.tar.gz) = 39999d01a3433aaa9511885d050dd7d829f00779afd21cdcedec1479925d974c
+SIZE (commoncpp2-1.5.0.tar.gz) = 861379
diff --git a/devel/commoncpp/files/patch-include-cc++_address.h b/devel/commoncpp/files/patch-include-cc++_address.h
new file mode 100644
index 000000000000..b5ca34bd302a
--- /dev/null
+++ b/devel/commoncpp/files/patch-include-cc++_address.h
@@ -0,0 +1,28 @@
+--- include/cc++/address.h Sun Oct 1 07:07:12 2006
++++ include/cc++/address.h Wed Oct 4 21:25:44 2006
+@@ -237,10 +237,10 @@
+ };
+
+ inline bool operator==(struct sockaddr *sa, IPV4Cidr &cidr)
+- {return cidr.isMember(sa);};
++ {return cidr.isMember(sa);}
+
+ inline bool operator==(struct in_addr &a, IPV4Cidr &cidr)
+- {return cidr.isMember(a);};
++ {return cidr.isMember(a);}
+
+ #ifdef CCXX_IPV6
+ /**
+@@ -325,10 +325,10 @@
+ };
+
+ inline bool operator==(struct sockaddr *sa, IPV6Cidr &cidr)
+- {return cidr.isMember(sa);};
++ {return cidr.isMember(sa);}
+
+ inline bool operator==(struct in6_addr &a, IPV6Cidr &cidr)
+- {return cidr.isMember(a);};
++ {return cidr.isMember(a);}
+
+ #endif
+
diff --git a/devel/commoncpp/files/patch-src_thread.cpp b/devel/commoncpp/files/patch-src_thread.cpp
new file mode 100644
index 000000000000..fdef47fabf7e
--- /dev/null
+++ b/devel/commoncpp/files/patch-src_thread.cpp
@@ -0,0 +1,11 @@
+--- src/thread.cpp Wed Oct 4 19:16:54 2006
++++ src/thread.cpp Wed Oct 4 19:17:17 2006
+@@ -820,7 +820,7 @@
+ cctid_t Thread::getId(void) const
+ {
+ if(!priv)
+- return -1;
++ return false;
+
+ return priv->_tid;
+ }
diff --git a/devel/commoncpp/pkg-plist b/devel/commoncpp/pkg-plist
index fbd591ad4c6d..26ca58af1225 100644
--- a/devel/commoncpp/pkg-plist
+++ b/devel/commoncpp/pkg-plist
@@ -37,13 +37,13 @@ include/cc++/unix.h
include/cc++/url.h
include/cc++/xml.h
include/cc++/zstream.h
-lib/libccext2-1.4.so
-lib/libccext2-1.4.so.0
+lib/libccext2-1.5.so
+lib/libccext2-1.5.so.0
lib/libccext2.a
lib/libccext2.la
lib/libccext2.so
-lib/libccgnu2-1.4.so
-lib/libccgnu2-1.4.so.0
+lib/libccgnu2-1.5.so
+lib/libccgnu2-1.5.so.0
lib/libccgnu2.a
lib/libccgnu2.la
lib/libccgnu2.so