aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-03 05:56:20 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-03 05:56:20 +0000
commita50c1cb64785b551bfdbff06f3e1ee2731d50271 (patch)
treef0d9050bfa3146dd2ccf52f45dfa6976fdf0d336 /devel
parent4812598a539d066b1edf7c36055b163ca1207256 (diff)
downloadports-a50c1cb64785b551bfdbff06f3e1ee2731d50271.tar.gz
ports-a50c1cb64785b551bfdbff06f3e1ee2731d50271.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Algorithm-IncludeExclude/Makefile2
-rw-r--r--devel/p5-Best/Makefile2
-rw-r--r--devel/p5-Class-Closure/Makefile4
-rw-r--r--devel/p5-Class-ReturnValue/Makefile2
-rw-r--r--devel/p5-Class-Spiffy/Makefile2
-rw-r--r--devel/p5-Class-Tom/Makefile4
-rw-r--r--devel/p5-Data-ACL/Makefile2
-rw-r--r--devel/p5-Data-Compare/Makefile2
-rw-r--r--devel/p5-Date-DayOfWeek/Makefile4
-rw-r--r--devel/p5-File-Attributes-Recursive/Makefile6
-rw-r--r--devel/p5-File-Attributes/Makefile6
-rw-r--r--devel/p5-File-CreationTime/Makefile2
-rw-r--r--devel/p5-Memoize/Makefile2
-rw-r--r--devel/p5-Term-Prompt/Makefile2
14 files changed, 21 insertions, 21 deletions
diff --git a/devel/p5-Algorithm-IncludeExclude/Makefile b/devel/p5-Algorithm-IncludeExclude/Makefile
index 5875c7f51305..224a57fc997e 100644
--- a/devel/p5-Algorithm-IncludeExclude/Makefile
+++ b/devel/p5-Algorithm-IncludeExclude/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Build and evaluate include/exclude lists
-BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Best/Makefile b/devel/p5-Best/Makefile
index e9705b1e5a14..09597924bf3c 100644
--- a/devel/p5-Best/Makefile
+++ b/devel/p5-Best/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Fallbackable module loader
-BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Class-Closure/Makefile b/devel/p5-Class-Closure/Makefile
index c17f96cae61d..c06b2d6baa34 100644
--- a/devel/p5-Class-Closure/Makefile
+++ b/devel/p5-Class-Closure/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Encapsulated, declarative classes in Perl
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PadWalker.pm:${PORTSDIR}/devel/p5-PadWalker \
- ${SITE_PERL}/${PERL_ARCH}/Devel/Caller.pm:${PORTSDIR}/devel/p5-Devel-Caller
+BUILD_DEPENDS= p5-PadWalker>=0:${PORTSDIR}/devel/p5-PadWalker \
+ p5-Devel-Caller>=0:${PORTSDIR}/devel/p5-Devel-Caller
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Class-ReturnValue/Makefile b/devel/p5-Class-ReturnValue/Makefile
index 001b497350fb..0d90b9810a27 100644
--- a/devel/p5-Class-ReturnValue/Makefile
+++ b/devel/p5-Class-ReturnValue/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= A return-value object that can be treated as a boolean,array or object
-BUILD_DEPENDS= ${SITE_PERL}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace
+BUILD_DEPENDS= p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= 5.8.0+
diff --git a/devel/p5-Class-Spiffy/Makefile b/devel/p5-Class-Spiffy/Makefile
index feabb04c09bc..9e97a05fd4e9 100644
--- a/devel/p5-Class-Spiffy/Makefile
+++ b/devel/p5-Class-Spiffy/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Class::Spiffy - Spiffy Perl Interface Framework For You
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Class-Tom/Makefile b/devel/p5-Class-Tom/Makefile
index 6eb4ffc39406..7dbbc482be06 100644
--- a/devel/p5-Class-Tom/Makefile
+++ b/devel/p5-Class-Tom/Makefile
@@ -16,8 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= A perl module to transport objects from one system to another
-BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
-RUN_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+BUILD_DEPENDS= p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump
+RUN_DEPENDS= p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump
PERL_CONFIGURE= yes
diff --git a/devel/p5-Data-ACL/Makefile b/devel/p5-Data-ACL/Makefile
index 8f33af74e45e..5a21a8974f7e 100644
--- a/devel/p5-Data-ACL/Makefile
+++ b/devel/p5-Data-ACL/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Data::ACL - Perl extension for simple ACL lists
-BUILD_DEPENDS= ${SITE_PERL}/Set/NestedGroups.pm:${PORTSDIR}/devel/p5-Set-NestedGroups
+BUILD_DEPENDS= p5-Set-NestedGroups>=0:${PORTSDIR}/devel/p5-Set-NestedGroups
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Data-Compare/Makefile b/devel/p5-Data-Compare/Makefile
index f9f8b7b12478..f071f6bce5e0 100644
--- a/devel/p5-Data-Compare/Makefile
+++ b/devel/p5-Data-Compare/Makefile
@@ -16,7 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/0*$//}
MAINTAINER= tobez@FreeBSD.org
COMMENT= Data::Compare - compare perl data structures
-BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule
+BUILD_DEPENDS= p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Date-DayOfWeek/Makefile b/devel/p5-Date-DayOfWeek/Makefile
index f2b70f38a518..4fbbdc537c01 100644
--- a/devel/p5-Date-DayOfWeek/Makefile
+++ b/devel/p5-Date-DayOfWeek/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Determine the day of the week for any date
-BUILD_DEPENDS= ${SITE_PERL}/Date/Leapyear.pm:${PORTSDIR}/devel/p5-Date-Leapyear \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= p5-Date-Leapyear>=0:${PORTSDIR}/devel/p5-Date-Leapyear \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-File-Attributes-Recursive/Makefile b/devel/p5-File-Attributes-Recursive/Makefile
index 3079d420f134..1d55b52779d7 100644
--- a/devel/p5-File-Attributes-Recursive/Makefile
+++ b/devel/p5-File-Attributes-Recursive/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Inherit file attributes from parent directories
-BUILD_DEPENDS= ${SITE_PERL}/Directory/Scratch.pm:${PORTSDIR}/devel/p5-Directory-Scratch \
- ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
- ${SITE_PERL}/File/Attributes.pm:${PORTSDIR}/devel/p5-File-Attributes
+BUILD_DEPENDS= p5-Directory-Scratch>=0:${PORTSDIR}/devel/p5-Directory-Scratch \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-File-Attributes>=0:${PORTSDIR}/devel/p5-File-Attributes
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-File-Attributes/Makefile b/devel/p5-File-Attributes/Makefile
index 91acb5de019d..d3ccf1aa336b 100644
--- a/devel/p5-File-Attributes/Makefile
+++ b/devel/p5-File-Attributes/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= File::Attributes - Manipulate file metadata
-BUILD_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
- ${SITE_PERL}/Directory/Scratch.pm:${PORTSDIR}/devel/p5-Directory-Scratch \
- ${SITE_PERL}/Best.pm:${PORTSDIR}/devel/p5-Best \
+BUILD_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
+ p5-Directory-Scratch>=0:${PORTSDIR}/devel/p5-Directory-Scratch \
+ p5-Best>=0:${PORTSDIR}/devel/p5-Best \
p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-File-CreationTime/Makefile b/devel/p5-File-CreationTime/Makefile
index 94ba35d94430..de1b53b8a314 100644
--- a/devel/p5-File-CreationTime/Makefile
+++ b/devel/p5-File-CreationTime/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Keeps track of file creation times
-BUILD_DEPENDS= ${SITE_PERL}/File/Attributes.pm:${PORTSDIR}/devel/p5-File-Attributes
+BUILD_DEPENDS= p5-File-Attributes>=0:${PORTSDIR}/devel/p5-File-Attributes
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Memoize/Makefile b/devel/p5-Memoize/Makefile
index 2dc32a841df2..3b878a48eea3 100644
--- a/devel/p5-Memoize/Makefile
+++ b/devel/p5-Memoize/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Transparently speed up perl functions by caching return values
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Term-Prompt/Makefile b/devel/p5-Term-Prompt/Makefile
index 45b9f146c8a0..b8a32392be74 100644
--- a/devel/p5-Term-Prompt/Makefile
+++ b/devel/p5-Term-Prompt/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl extension for prompting a user for information
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes