aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-01-27 14:48:01 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-01-27 14:48:01 +0000
commitc4088621e9e6ec56320fa9511bcb7439ed51f221 (patch)
treeac2ea3d7fe06a09614ca2ec40d72b294970d868d /devel
parent9031bc775387de52f9a489f58832dfcadf6ee9fe (diff)
downloadports-c4088621e9e6ec56320fa9511bcb7439ed51f221.tar.gz
ports-c4088621e9e6ec56320fa9511bcb7439ed51f221.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-Look/Makefile24
-rw-r--r--devel/p5-SVN-Look/distinfo3
-rw-r--r--devel/p5-SVN-Look/pkg-descr13
-rw-r--r--devel/p5-SVN-Look/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c81c8621a12e..e0fb37aff48d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1690,6 +1690,7 @@
SUBDIR += p5-SVN-Dump
SUBDIR += p5-SVN-Hook
SUBDIR += p5-SVN-Log
+ SUBDIR += p5-SVN-Look
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
SUBDIR += p5-SVN-Notify-Config
diff --git a/devel/p5-SVN-Look/Makefile b/devel/p5-SVN-Look/Makefile
new file mode 100644
index 000000000000..eb17a87c34da
--- /dev/null
+++ b/devel/p5-SVN-Look/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: SVN::Look
+# Date created: 2009-01-27
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Look
+PORTVERSION= 0.13.463
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A caching wrapper aroung the svnlook command
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec/Functions.pm:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Look.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Look/distinfo b/devel/p5-SVN-Look/distinfo
new file mode 100644
index 000000000000..f5e445b8944a
--- /dev/null
+++ b/devel/p5-SVN-Look/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Look-0.13.463.tar.gz) = c9b161d4f7a27384713d040491e8c5f5
+SHA256 (SVN-Look-0.13.463.tar.gz) = 8caf41883b512b2238e3762965e1839c97181804cb2aaa725e66c51cad8677f1
+SIZE (SVN-Look-0.13.463.tar.gz) = 6273
diff --git a/devel/p5-SVN-Look/pkg-descr b/devel/p5-SVN-Look/pkg-descr
new file mode 100644
index 000000000000..7d6cfd0796a4
--- /dev/null
+++ b/devel/p5-SVN-Look/pkg-descr
@@ -0,0 +1,13 @@
+SVN-Look is a caching wrapper aroung the svnlook command.
+
+The svnlook command is the workhorse of Subversion hook scripts,
+being used to gather all sorts of information about a repository,
+its revisions, and its transactions.
+
+This script provides a simple object oriented interface to a specific
+svnlook invocation, to make it easier to hook writers to get and
+use the information they need. Moreover, all the information
+gathered buy calling the svnlook command is cached in the object,
+avoiding repetitious calls.
+
+WWW: http://search.cpan.org/dist/SVN-Look/
diff --git a/devel/p5-SVN-Look/pkg-plist b/devel/p5-SVN-Look/pkg-plist
new file mode 100644
index 000000000000..9200ef2aec62
--- /dev/null
+++ b/devel/p5-SVN-Look/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SVN/Look.pm
+@dirrmtry %%SITE_PERL%%/SVN
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Look/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Look
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN