aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-31 11:11:06 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-31 11:11:06 +0000
commit1c61db05db0f36a5b948173177bf3aec77ef2813 (patch)
tree615eb55868dca4486b9cad7e01dc973c2a8442e7 /devel
parent38e16b656013daffd4a20b40bf797933ed097bdb (diff)
downloadports-1c61db05db0f36a5b948173177bf3aec77ef2813.tar.gz
ports-1c61db05db0f36a5b948173177bf3aec77ef2813.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tie-Watch/Makefile21
-rw-r--r--devel/p5-Tie-Watch/distinfo3
-rw-r--r--devel/p5-Tie-Watch/pkg-descr14
-rw-r--r--devel/p5-Tie-Watch/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8067ee42fb7c..28b75c6eaa84 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1434,6 +1434,7 @@
SUBDIR += p5-Tie-Restore
SUBDIR += p5-Tie-ShareLite
SUBDIR += p5-Tie-Simple
+ SUBDIR += p5-Tie-Watch
SUBDIR += p5-Tie-iCal
SUBDIR += p5-Time-Clock
SUBDIR += p5-Time-Duration
diff --git a/devel/p5-Tie-Watch/Makefile b/devel/p5-Tie-Watch/Makefile
new file mode 100644
index 000000000000..2b1782d19551
--- /dev/null
+++ b/devel/p5-Tie-Watch/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Tie-Watch
+# Date created: 31 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-Watch
+DISTVERSION= 1.2
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Place watchpoints on variables
+
+PERL_CONFIGURE= yes
+
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Tie-Watch/distinfo b/devel/p5-Tie-Watch/distinfo
new file mode 100644
index 000000000000..da5aad3468e5
--- /dev/null
+++ b/devel/p5-Tie-Watch/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tie-Watch-1.2.tar.gz) = 9bbdff61b7fc82980d5c213f4b5763bc
+SHA256 (Tie-Watch-1.2.tar.gz) = d41b7c390f385ff3253e7b38a4be7701b5107b47e5d84db66d83a28bc72a86c9
+SIZE (Tie-Watch-1.2.tar.gz) = 9037
diff --git a/devel/p5-Tie-Watch/pkg-descr b/devel/p5-Tie-Watch/pkg-descr
new file mode 100644
index 000000000000..de70e5448288
--- /dev/null
+++ b/devel/p5-Tie-Watch/pkg-descr
@@ -0,0 +1,14 @@
+This class module binds one or more subroutines of your devising to a Perl
+variable. All variables can have FETCH, STORE and DESTROY callbacks.
+Additionally, arrays can define CLEAR, DELETE, EXISTS, EXTEND, FETCHSIZE,
+POP, PUSH, SHIFT, SPLICE, STORESIZE and UNSHIFT callbacks, and hashes can
+define CLEAR, DELETE, EXISTS, FIRSTKEY and NEXTKEY callbacks.
+
+With Tie::Watch you can:
+* alter a variable's value
+* prevent a variable's value from being changed
+* invoke a Perl/Tk callback when a variable changes
+* trace references to a variable
+
+WWW: http://search.cpan.org/dist/Tie-Watch/
+Author: Steve Lidie <sol0@Lehigh.EDU>
diff --git a/devel/p5-Tie-Watch/pkg-plist b/devel/p5-Tie-Watch/pkg-plist
new file mode 100644
index 000000000000..daa91c14051b
--- /dev/null
+++ b/devel/p5-Tie-Watch/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Watch/.packlist
+%%SITE_PERL%%/Tie/Watch.pm
+@dirrmtry %%SITE_PERL%%/Tie
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Watch
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie