aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2005-12-20 02:30:51 +0000
committerMark Linimon <linimon@FreeBSD.org>2005-12-20 02:30:51 +0000
commit6525ced36bf91895132563e4e79138f40ebdca71 (patch)
treed65b6e6650dc824e26ca68e6534c4b02a36b200b /devel
parent87e85560e486289737d35a63b632c48ebde55e1b (diff)
downloadports-6525ced36bf91895132563e4e79138f40ebdca71.tar.gz
ports-6525ced36bf91895132563e4e79138f40ebdca71.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/portmk/Mk/bsd.apache.mk2
-rw-r--r--devel/portmk/Mk/bsd.autotools.mk10
-rw-r--r--devel/portmk/Mk/bsd.database.mk10
-rw-r--r--devel/portmk/Mk/bsd.gcc.mk6
-rw-r--r--devel/portmk/Mk/bsd.gnome.mk4
-rw-r--r--devel/portmk/Mk/bsd.gstreamer.mk4
-rw-r--r--devel/portmk/Mk/bsd.kde.mk6
-rw-r--r--devel/portmk/Mk/bsd.local.mk2
-rw-r--r--devel/portmk/Mk/bsd.mail.mk4
-rw-r--r--devel/portmk/Mk/bsd.php.mk4
-rw-r--r--devel/portmk/Mk/bsd.port.mk2
-rw-r--r--devel/portmk/Mk/bsd.ruby.mk8
-rw-r--r--devel/portmk/Mk/bsd.sdl.mk4
-rw-r--r--devel/portmk/Mk/bsd.tcl.mk6
14 files changed, 37 insertions, 35 deletions
diff --git a/devel/portmk/Mk/bsd.apache.mk b/devel/portmk/Mk/bsd.apache.mk
index 4e112790781f..f01c98726358 100644
--- a/devel/portmk/Mk/bsd.apache.mk
+++ b/devel/portmk/Mk/bsd.apache.mk
@@ -52,7 +52,7 @@ IGNORE= ${_ERROR_MSG} Illegal use of USE_APACHE
.if defined(AP_PORT_IS_SERVER)
# For slave ports:
.if defined(SLAVE_DESIGNED_FOR) && ${PORTVERSION} != ${SLAVE_DESIGNED_FOR}
-IGNORE= "Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync"
+IGNORE= Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync
.endif
.if defined(SLAVE_PORT_MODULES)
diff --git a/devel/portmk/Mk/bsd.autotools.mk b/devel/portmk/Mk/bsd.autotools.mk
index 8c347d19714b..92674991da58 100644
--- a/devel/portmk/Mk/bsd.autotools.mk
+++ b/devel/portmk/Mk/bsd.autotools.mk
@@ -76,7 +76,7 @@ USE_AUTOTOOLS_COMPAT+= libtool:${WANT_LIBTOOL_VER}:env
#
.if ${USE_AUTOTOOLS_COMPAT}!=""
. if defined(USE_AUTOTOOLS)
-BROKEN+= "Mix and match of old and new autotools system prohibited"
+BROKEN+= Mix and match of old and new autotools system prohibited
. else
USE_AUTOTOOLS= ${USE_AUTOTOOLS_COMPAT}
_AUTOTOOLS_PN= ${.CURDIR:C/${PORTSDIR}\///}
@@ -166,7 +166,7 @@ AUTOMAKE_VERSION= ${AUTOTOOL_automake_env}
# Make sure we specified a legal version of automake
#
. if !exists(${PORTSDIR}/devel/automake${AUTOMAKE_VERSION}/Makefile)
-BROKEN+= "Unknown AUTOMAKE version: ${AUTOMAKE_VERSION}"
+BROKEN+= Unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
. endif
# Set up the automake environment
@@ -212,7 +212,7 @@ AUTOCONF_VERSION= ${AUTOTOOL_autoconf_env}
# Make sure we specified a legal version of autoconf
#
. if !exists(${PORTSDIR}/devel/autoconf${AUTOCONF_VERSION}/Makefile)
-BROKEN+= "Unknown AUTOCONF version: ${AUTOCONF_VERSION}"
+BROKEN+= Unknown AUTOCONF version: ${AUTOCONF_VERSION}
. endif
# Set up the autoconf/autoheader environment
@@ -260,7 +260,7 @@ LIBTOOL_VERSION= ${AUTOTOOL_libtool_env}
# Make sure we specified a legal version of libtool
#
. if !exists(${PORTSDIR}/devel/libtool${LIBTOOL_VERSION}/Makefile)
-BROKEN+= "Unknown LIBTOOL version: ${LIBTOOL_VERSION}"
+BROKEN+= Unknown LIBTOOL version: ${LIBTOOL_VERSION}
. endif
# Set up the libtool environment
@@ -338,7 +338,7 @@ ${item:U}_ENV+= ${AUTOTOOLS_VARS}
# the order of autotools running.
.if !target(run-autotools)
-run-autotools:: run-autotools-aclocal run-autotools-automake \
+run-autotools:: run-autotools-aclocal patch-autotools run-autotools-automake \
run-autotools-autoconf run-autotools-autoheader
.endif
diff --git a/devel/portmk/Mk/bsd.database.mk b/devel/portmk/Mk/bsd.database.mk
index f210ada9f5bb..ca31dc5ecd40 100644
--- a/devel/portmk/Mk/bsd.database.mk
+++ b/devel/portmk/Mk/bsd.database.mk
@@ -102,7 +102,7 @@ IGNORE= Doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL $
.endif # BROKEN_WITH_MYSQL
LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
.else
-IGNORE= "Unknown MySQL version: ${MYSQL_VER}"
+IGNORE= Unknown MySQL version: ${MYSQL_VER}
.endif # Check for correct libs
.endif # USE_MYSQL
@@ -135,13 +135,13 @@ PGSQL_VER= ${DEFAULT_PGSQL_VER}
.if defined(BROKEN_WITH_PGSQL)
. for VER in ${BROKEN_WITH_PGSQL}
. if (${PGSQL_VER} == "${VER}")
-IGNORE= "Does not work with postgresql${PGSQL_VER}-client PostgresSQL \(${BROKEN_WITH_PGSQL} not supported\)"
+IGNORE= Does not work with postgresql${PGSQL_VER}-client PostgresSQL (${BROKEN_WITH_PGSQL} not supported)
. endif
. endfor
.endif # BROKEN_WITH_PGSQL
LIB_DEPENDS+= pq.${PGSQL${PGSQL_VER}_LIBVER}:${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
.else
-IGNORE= "Unknown PostgreSQL version: ${PGSQL_VER}"
+IGNORE= Unknown PostgreSQL version: ${PGSQL_VER}
.endif # Check for correct version
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -206,7 +206,7 @@ _FOUND= yes
# USE_BDB is specified incorrectly, so mark this as IGNORE
.if ${_FOUND} == "no"
-IGNORE= "Unknown bdb version: ${USE_BDB}"
+IGNORE= Unknown bdb version: ${USE_BDB}
.endif
.endif # USE_BDB
@@ -226,7 +226,7 @@ LIB_DEPENDS+= sqlite${_SQLITE_VER}:${PORTSDIR}/databases/sqlite${_SQLITE_VER}
.elif ${_SQLITE_VER} == "2"
LIB_DEPENDS+= sqlite.${_SQLITE_VER}:${PORTSDIR}/databases/sqlite${_SQLITE_VER}
.else
-IGNORE= "Unknown sqlite version: ${_SQLITE_VER}"
+IGNORE= Unknown sqlite version: ${_SQLITE_VER}
.endif
.endif # defined(USE_SQLITE)
diff --git a/devel/portmk/Mk/bsd.gcc.mk b/devel/portmk/Mk/bsd.gcc.mk
index 01ce26d32dea..76f5f68c2c73 100644
--- a/devel/portmk/Mk/bsd.gcc.mk
+++ b/devel/portmk/Mk/bsd.gcc.mk
@@ -18,7 +18,7 @@
# If you are wondering what your port exactly does, use "make test-gcc"
# to see some debugging.
#
-# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.gcc.mk,v 1.1 2005-12-19 06:08:26 linimon Exp $
+# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.gcc.mk,v 1.2 2005-12-20 02:30:51 linimon Exp $
#
GCC_Include_MAINTAINER= portmgr@FreeBSD.org
@@ -77,7 +77,7 @@ _GCCVERSION_OKAY= true;
.endfor
.if !defined(_GCCVERSION_OKAY)
-BROKEN= "Unknown version of GCC specified (USE_GCC=${USE_GCC})"
+BROKEN= Unknown version of GCC specified (USE_GCC=${USE_GCC})
.endif
#
@@ -93,7 +93,7 @@ _GCC_FOUND${v}:= base
. endif
.endfor
.if !defined(_GCCVERSION)
-BROKEN= "Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})"
+BROKEN= Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})
.endif
#
diff --git a/devel/portmk/Mk/bsd.gnome.mk b/devel/portmk/Mk/bsd.gnome.mk
index 5dd7ccdc153c..9ce224b85ad4 100644
--- a/devel/portmk/Mk/bsd.gnome.mk
+++ b/devel/portmk/Mk/bsd.gnome.mk
@@ -602,7 +602,7 @@ BROKEN+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
. endif
. endif
. if ${_USE_GNOME_ALL:M${component}}==""
-BROKEN= "Unknown component ${component}"
+BROKEN= Unknown component ${component}
. endif
_USE_GNOME+= ${${component}_USE_GNOME_IMPL} ${component}
. endfor
@@ -628,7 +628,7 @@ ltverhack_PRE_PATCH= ${CP} -pf ${LTMAIN} ${WRKDIR}/gnome-ltmain.sh && \
done;
.else
.if ${USE_GNOME:Mltverhack}!=""
-BROKEN= "${PORTNAME} uses the ltverhack GNOME component but does not use libtool"
+BROKEN= ${PORTNAME} uses the ltverhack GNOME component but does not use libtool
.endif
.endif
diff --git a/devel/portmk/Mk/bsd.gstreamer.mk b/devel/portmk/Mk/bsd.gstreamer.mk
index 36e350001f9a..67eecb89abf3 100644
--- a/devel/portmk/Mk/bsd.gstreamer.mk
+++ b/devel/portmk/Mk/bsd.gstreamer.mk
@@ -6,7 +6,7 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# Date: 4 Oct 2004
#
-# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.gstreamer.mk,v 1.1 2005-12-19 06:08:26 linimon Exp $
+# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.gstreamer.mk,v 1.2 2005-12-20 02:30:51 linimon Exp $
#
.if !defined(_POSTMKINCLUDED) && !defined(Gstreamer_Pre_Include)
@@ -237,7 +237,7 @@ BUILD_DEPENDS+= ${_GST_LIB_BASE}/libgst${ext}.so:${PORTSDIR}/${${ext}_DEPENDS}
RUN_DEPENDS+= ${_GST_LIB_BASE}/libgst${ext}.so:${PORTSDIR}/${${ext}_DEPENDS}
. endif
. else
-BROKEN= "Unknown gstreamer-plugin -- ${ext}"
+BROKEN= Unknown gstreamer-plugin -- ${ext}
. endif
.endfor
diff --git a/devel/portmk/Mk/bsd.kde.mk b/devel/portmk/Mk/bsd.kde.mk
index 02560c106077..972955970b6b 100644
--- a/devel/portmk/Mk/bsd.kde.mk
+++ b/devel/portmk/Mk/bsd.kde.mk
@@ -1,7 +1,7 @@
#-*- mode: Makefile; tab-width: 4; -*-
# ex:ts=4
#
-# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.kde.mk,v 1.1 2005-12-19 06:08:26 linimon Exp $
+# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.kde.mk,v 1.2 2005-12-20 02:30:51 linimon Exp $
#
# Please view me with 4 column tabs!
@@ -68,7 +68,7 @@ LIB_DEPENDS+= kimproxy:${PORTSDIR}/x11/kdelibs3
USE_QT_VER= 3
PREFIX= ${KDE_PREFIX}
.else
-BROKEN= "Unknown value in USE_KDELIBS_VER"
+BROKEN= Unknown value in USE_KDELIBS_VER
.endif # ${USE_KDELIBS_VER} == 3
.endif # defined(USE_KDELIBS_VER)
@@ -122,7 +122,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.else
-BROKEN="Unsupported value of USE_QT_VER"
+BROKEN=Unsupported value of USE_QT_VER
.endif # defined(USE_QT_VER)
# End of USE_QT_VER section
diff --git a/devel/portmk/Mk/bsd.local.mk b/devel/portmk/Mk/bsd.local.mk
index 69d913934515..07ff97ca883e 100644
--- a/devel/portmk/Mk/bsd.local.mk
+++ b/devel/portmk/Mk/bsd.local.mk
@@ -28,4 +28,6 @@ Local_Post_Include= bsd.local.mk
# time should live.
#
+.include "${DEVELPORTSDIR}/Mk/bsd.portsmon.mk"
+
.endif # defined(_POSTMKINCLUDED) && !defined(Local_Post_Include)
diff --git a/devel/portmk/Mk/bsd.mail.mk b/devel/portmk/Mk/bsd.mail.mk
index df7bc292e0b0..5820a425507a 100644
--- a/devel/portmk/Mk/bsd.mail.mk
+++ b/devel/portmk/Mk/bsd.mail.mk
@@ -22,7 +22,7 @@ Mail_Pre_Include= bsd.mail.mk
#
# QMAIL_SLAVEPORT - Define it if you install a slaveport of qmail, to
# prevent stale dependencies. Valid slaveports are:
-# ldap, mysql, smtp_auth+tls, spamcontrol and tls.
+# ldap, mysql, spamcontrol and tls.
#
# USE_QMAIL_BUILD - Add qmail or qmail slaveport to BUILD_DEPENDS.
#
@@ -34,7 +34,7 @@ Mail_Pre_Include= bsd.mail.mk
QMAIL_PREFIX?= /var/qmail
-_QMAIL_VALID_SLAVEPORTS= ldap mysql smtp_auth+tls spamcontrol tls
+_QMAIL_VALID_SLAVEPORTS= ldap mysql spamcontrol tls
.if defined(USE_QMAIL) || defined(USE_QMAIL_RUN) || defined (USE_QMAIL_BUILD)
diff --git a/devel/portmk/Mk/bsd.php.mk b/devel/portmk/Mk/bsd.php.mk
index a2358dacfafc..9ac58483aa9b 100644
--- a/devel/portmk/Mk/bsd.php.mk
+++ b/devel/portmk/Mk/bsd.php.mk
@@ -7,7 +7,7 @@
# Please send all suggested changes to the maintainer instead of committing
# them to CVS yourself.
#
-# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.php.mk,v 1.2 2005-12-20 01:56:26 linimon Exp $
+# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.php.mk,v 1.3 2005-12-20 02:30:51 linimon Exp $
#
# Adding 'USE_PHP=yes' to a port includes this Makefile after bsd.ports.pre.mk.
# If the port requires a predefined set of PHP extensions, they can be
@@ -74,7 +74,7 @@ PHP_EXT_INC?= ""
.if defined(BROKEN_WITH_PHP)
. for VER in ${BROKEN_WITH_PHP}
. if ${PHP_VER} == "${VER}"
-BROKEN= "Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})"
+BROKEN= Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})
. endif
. endfor
.endif
diff --git a/devel/portmk/Mk/bsd.port.mk b/devel/portmk/Mk/bsd.port.mk
index ffaa396837b9..570cb2eca5ab 100644
--- a/devel/portmk/Mk/bsd.port.mk
+++ b/devel/portmk/Mk/bsd.port.mk
@@ -2691,7 +2691,7 @@ VALID_CATEGORIES+= accessibility afterstep arabic archivers astro audio \
ipv6 irc japanese java kde korean lang linux lisp \
mail math mbone misc multimedia net net-im net-mgmt news \
palm parallel pear perl5 picobsd plan9 polish portuguese print \
- python ruby rubygem russian \
+ python ruby rubygems russian \
scheme science security shells spanish sysutils \
tcl80 tcl81 tcl82 tcl83 tcl84 textproc \
tk80 tk82 tk83 tk84 tkstep80 \
diff --git a/devel/portmk/Mk/bsd.ruby.mk b/devel/portmk/Mk/bsd.ruby.mk
index 3921e6dcda0d..3192521e1751 100644
--- a/devel/portmk/Mk/bsd.ruby.mk
+++ b/devel/portmk/Mk/bsd.ruby.mk
@@ -3,7 +3,7 @@
#
# Created by: Akinori MUSHA <knu@FreeBSD.org>
#
-# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.ruby.mk,v 1.1 2005-12-19 06:08:26 linimon Exp $
+# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.ruby.mk,v 1.2 2005-12-20 02:30:51 linimon Exp $
#
.if !defined(Ruby_Include)
@@ -114,12 +114,12 @@ RUBY_VER?= ${RUBY_DEFAULT_VER}
.if defined(RUBY)
.if !exists(${RUBY})
-BROKEN= "You set the variable RUBY to \"${RUBY}\", but it does not seem to exist. Please specify an already installed ruby executable."
+BROKEN= You set the variable RUBY to "${RUBY}", but it does not seem to exist. Please specify an already installed ruby executable.
.endif
_RUBY_TEST!= ${RUBY} -e 'begin; require "rbconfig"; rescue LoadError; puts "error"; end'
.if !empty(_RUBY_TEST)
-BROKEN= "You set the variable RUBY to \"${RUBY}\", but it failed to include rbconfig. Please specify a properly installed ruby executable."
+BROKEN= You set the variable RUBY to "${RUBY}", but it failed to include rbconfig. Please specify a properly installed ruby executable.
.endif
_RUBY_CONFIG= ${RUBY} -r rbconfig -e 'C = Config::CONFIG' -e
@@ -147,7 +147,7 @@ RUBY_PATCHFILES?= ${RUBY_VERSION}-patch1.gz
RUBY_WRKSRC= ${WRKDIR}/ruby-${RUBY_VERSION}
#MASTER_SITE_SUBDIR_RUBY= snapshots
.elif defined(RUBY_VER) && ${RUBY_VER} == 1.7
-BROKEN= "Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead."
+BROKEN= Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead.
.else
RUBY_VERSION?= 1.6.8
RUBY_DISTVERSION?= ${RUBY_VERSION}-2004.07.28
diff --git a/devel/portmk/Mk/bsd.sdl.mk b/devel/portmk/Mk/bsd.sdl.mk
index bbfdaf08c4e6..c24f4848ef02 100644
--- a/devel/portmk/Mk/bsd.sdl.mk
+++ b/devel/portmk/Mk/bsd.sdl.mk
@@ -29,7 +29,7 @@
#
#
-# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.sdl.mk,v 1.1 2005-12-19 06:08:26 linimon Exp $
+# $FreeBSD: /tmp/pcvs/ports/devel/portmk/Mk/Attic/bsd.sdl.mk,v 1.2 2005-12-20 02:30:51 linimon Exp $
#
SDL_Include_MAINTAINER= edwin@FreeBSD.org
@@ -145,7 +145,7 @@ USE_SDL= sdl
_USE_SDL=
.for component in ${USE_SDL}
. if ${_USE_SDL_ALL:M${component}}==""
-BROKEN= "Unknown SDL component ${component}"
+BROKEN= Unknown SDL component ${component}
. endif
_USE_SDL+= ${_REQUIRES_${component}} ${component}
.endfor
diff --git a/devel/portmk/Mk/bsd.tcl.mk b/devel/portmk/Mk/bsd.tcl.mk
index c0bfed148156..9bb3c7761fa0 100644
--- a/devel/portmk/Mk/bsd.tcl.mk
+++ b/devel/portmk/Mk/bsd.tcl.mk
@@ -79,7 +79,7 @@ TCLSH= ${LOCALBASE}/bin/tclsh${TCL_VER}
.endfor
.if ${_FOUND} == "no"
-IGNORE= "Unknown TCL version specified: ${USE_TCL}"
+IGNORE= Unknown TCL version specified: ${USE_TCL}
.endif
.endif # defined(USE_TCL)
@@ -94,7 +94,7 @@ USE_TK= 84
TK_VER:= ${USE_TK:S/8/8./}
.if defined(USE_TCL) && ${TCL_VER} != ${TK_VER}
-IGNORE= "TCL and TK versions must be equal (${TCL_VER} vs ${TK_VER})"
+IGNORE= TCL and TK versions must be equal (${TCL_VER} vs ${TK_VER})
.endif
_FOUND= no
@@ -112,7 +112,7 @@ WISH= ${LOCALBASE}/bin/wish${TK_VER}
.endfor
.if ${_FOUND} == "no"
-IGNORE= "Unknown TK version specified: ${USE_TK}"
+IGNORE= Unknown TK version specified: ${USE_TK}
.endif
.endif # defined(USE_TK)