aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-05-11 03:11:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-05-11 03:11:40 +0000
commit885da254bdca14268559dc43f752c6812addaf40 (patch)
tree8916fba475eff2f0290e7a7dc15244c1a177c827 /devel
parent4eb7870f08800ea6f61bd4c76c103c296748f905 (diff)
downloadports-885da254bdca14268559dc43f752c6812addaf40.tar.gz
ports-885da254bdca14268559dc43f752c6812addaf40.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/py-tables/Makefile16
-rw-r--r--devel/py-tables/distinfo4
-rw-r--r--devel/py-tables/files/patch-setup.py13
-rw-r--r--devel/py-tables/pkg-descr2
-rw-r--r--devel/py-tables/pkg-plist43
5 files changed, 30 insertions, 48 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index d1280e32c654..3f39b9092a03 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= tables
-PORTVERSION= 0.7.2
+PORTVERSION= 1.0
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pytables
@@ -23,13 +23,25 @@ LIB_DEPENDS= hdf5.0:${PORTSDIR}/science/hdf5 \
ucl.1:${PORTSDIR}/archivers/ucl
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
+USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-.if !defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/setup.py
+
post-install:
+ @${FIND} ${PYTHON_SITELIBDIR}/tables ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/tables -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
index 429a5429936d..a4d11f3ffe23 100644
--- a/devel/py-tables/distinfo
+++ b/devel/py-tables/distinfo
@@ -1,2 +1,2 @@
-MD5 (pytables-0.7.2.tar.gz) = b6b14895bbdb01020e66d7f18fe0373f
-SIZE (pytables-0.7.2.tar.gz) = 228821
+MD5 (pytables-1.0.tar.gz) = 776b3ef35b59a12c1617be919cd072d8
+SIZE (pytables-1.0.tar.gz) = 2388959
diff --git a/devel/py-tables/files/patch-setup.py b/devel/py-tables/files/patch-setup.py
new file mode 100644
index 000000000000..d53d1b3aec63
--- /dev/null
+++ b/devel/py-tables/files/patch-setup.py
@@ -0,0 +1,13 @@
+--- setup.py.orig Wed May 11 11:04:04 2005
++++ setup.py Wed May 11 11:04:38 2005
+@@ -30,8 +30,8 @@
+
+ # Global variables
+ lflags_arg = []
+-lib_dirs = []
+-inc_dirs = []
++lib_dirs = ['%%LOCALBASE%%/lib']
++inc_dirs = ['%%LOCALBASE%%/include']
+
+ # Some useful functions
+ def check_lib_unix(where, libname, headername, compulsory):
diff --git a/devel/py-tables/pkg-descr b/devel/py-tables/pkg-descr
index 0d208e3bb804..5fedcb338849 100644
--- a/devel/py-tables/pkg-descr
+++ b/devel/py-tables/pkg-descr
@@ -2,4 +2,4 @@ The goal of PyTables is to enable the end user to manipulate easily scientific
data tables and Numerical Python objects in a persistent, disk-based
hierarchical structure.
-WWW: http://pytables.sourceforge.net/
+WWW: http://www.pytables.org/
diff --git a/devel/py-tables/pkg-plist b/devel/py-tables/pkg-plist
deleted file mode 100644
index ff8cec7dfabc..000000000000
--- a/devel/py-tables/pkg-plist
+++ /dev/null
@@ -1,43 +0,0 @@
-%%PYTHON_SITELIBDIR%%/tables/Array.py
-%%PYTHON_SITELIBDIR%%/tables/Array.pyc
-%%PYTHON_SITELIBDIR%%/tables/Array.pyo
-%%PYTHON_SITELIBDIR%%/tables/AttributeSet.py
-%%PYTHON_SITELIBDIR%%/tables/AttributeSet.pyc
-%%PYTHON_SITELIBDIR%%/tables/AttributeSet.pyo
-%%PYTHON_SITELIBDIR%%/tables/File.py
-%%PYTHON_SITELIBDIR%%/tables/File.pyc
-%%PYTHON_SITELIBDIR%%/tables/File.pyo
-%%PYTHON_SITELIBDIR%%/tables/Group.py
-%%PYTHON_SITELIBDIR%%/tables/Group.pyc
-%%PYTHON_SITELIBDIR%%/tables/Group.pyo
-%%PYTHON_SITELIBDIR%%/tables/IsDescription.py
-%%PYTHON_SITELIBDIR%%/tables/IsDescription.pyc
-%%PYTHON_SITELIBDIR%%/tables/IsDescription.pyo
-%%PYTHON_SITELIBDIR%%/tables/Leaf.py
-%%PYTHON_SITELIBDIR%%/tables/Leaf.pyc
-%%PYTHON_SITELIBDIR%%/tables/Leaf.pyo
-%%PYTHON_SITELIBDIR%%/tables/Table.py
-%%PYTHON_SITELIBDIR%%/tables/Table.pyc
-%%PYTHON_SITELIBDIR%%/tables/Table.pyo
-%%PYTHON_SITELIBDIR%%/tables/__init__.py
-%%PYTHON_SITELIBDIR%%/tables/__init__.pyc
-%%PYTHON_SITELIBDIR%%/tables/__init__.pyo
-%%PYTHON_SITELIBDIR%%/tables/hdf5Extension.so
-%%PYTHON_SITELIBDIR%%/tables/utils.py
-%%PYTHON_SITELIBDIR%%/tables/utils.pyc
-%%PYTHON_SITELIBDIR%%/tables/utils.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/tables
-%%PORTDOCS%%%%EXAMPLESDIR%%/array1.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/array2.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/array3.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/array4.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/attributes1.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/dumpFile.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/gl-test.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/objecttree.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/table-tree.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/table1.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial1-1.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial1-2.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial2.py
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%