aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-27 18:12:39 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-27 18:12:39 +0000
commit8ea8ccd4074d002c6984dace11935451be8a1bca (patch)
tree156a21ab28cdc973750769e15bb7a8c20eea04fd /devel
parent3c54f14d96c12042ae1cfd02dd727ab5e8ca2021 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/scons/Makefile4
-rw-r--r--devel/scons/files/patch-engine_SCons_Tool_m4.py11
2 files changed, 15 insertions, 0 deletions
diff --git a/devel/scons/Makefile b/devel/scons/Makefile
index 58c2639d0658..d032d993ca01 100644
--- a/devel/scons/Makefile
+++ b/devel/scons/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scons
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -11,6 +12,8 @@ COMMENT= Build tool alternative to make
LICENSE= MIT
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
@@ -22,5 +25,6 @@ post-patch:
-e 's,distutils\.command\.install$$,setuptools\.command\.install,' \
-e 's,distutils\.command\.install\.,setuptools\.command\.install\.,' \
${WRKSRC}/setup.py
+ @${FIND} ${WRKSRC} -name \*.orig -delete
.include <bsd.port.mk>
diff --git a/devel/scons/files/patch-engine_SCons_Tool_m4.py b/devel/scons/files/patch-engine_SCons_Tool_m4.py
new file mode 100644
index 000000000000..a17224f6cffd
--- /dev/null
+++ b/devel/scons/files/patch-engine_SCons_Tool_m4.py
@@ -0,0 +1,11 @@
+--- engine/SCons/Tool/m4.py.orig 2013-03-03 14:48:40.000000000 +0000
++++ engine/SCons/Tool/m4.py
+@@ -49,7 +49,7 @@ def generate(env):
+ # file and run from there.
+ # The src_suffix setup is like so: file.c.m4 -> file.c,
+ # file.cpp.m4 -> file.cpp etc.
+- env['M4'] = 'm4'
++ env['M4'] = 'gm4'
+ env['M4FLAGS'] = SCons.Util.CLVar('-E')
+ env['M4COM'] = 'cd ${SOURCE.rsrcdir} && $M4 $M4FLAGS < ${SOURCE.file} > ${TARGET.abspath}'
+