aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2004-01-25 15:27:24 +0000
committerMax Khon <fjoe@FreeBSD.org>2004-01-25 15:27:24 +0000
commit6f344f7598eca9bc94d3f69579a7eba823c3a1e4 (patch)
tree6b0f0ac1c72a0eff473144b05539cef81c91d081 /devel
parentaa4efabd791f05ccdabf59086afbe34ee4fcfce7 (diff)
downloadports-6f344f7598eca9bc94d3f69579a7eba823c3a1e4.tar.gz
ports-6f344f7598eca9bc94d3f69579a7eba823c3a1e4.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cvsnt/Makefile27
-rw-r--r--devel/cvsnt/distinfo1
-rw-r--r--devel/cvsnt/files/patch-configure29
-rw-r--r--devel/cvsnt/files/patch-configure.in11
-rw-r--r--devel/cvsnt/files/patch-lib-getopt.h11
-rw-r--r--devel/cvsnt/files/patch-lib-regex.h13
-rw-r--r--devel/cvsnt/files/patch-lockservice-LockParse.cpp10
-rw-r--r--devel/cvsnt/files/patch-lockservice-server.cpp13
-rw-r--r--devel/cvsnt/files/patch-rcs-common.cpp8
-rw-r--r--devel/cvsnt/files/patch-src-cvs.h21
-rw-r--r--devel/cvsnt/files/patch-src-server.h17
-rw-r--r--devel/cvsnt/files/patch-src-subr.c10
-rw-r--r--devel/cvsnt/pkg-descr14
-rw-r--r--devel/cvsnt/pkg-plist42
15 files changed, 228 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e979d32d7ccd..9728534bd9db 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -157,6 +157,7 @@
SUBDIR += cvslines
SUBDIR += cvsmapfs
SUBDIR += cvsmonitor
+ SUBDIR += cvsnt
SUBDIR += cvspadm
SUBDIR += cvsplot
SUBDIR += cvsps
diff --git a/devel/cvsnt/Makefile b/devel/cvsnt/Makefile
new file mode 100644
index 000000000000..3b266cda1516
--- /dev/null
+++ b/devel/cvsnt/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cvsnt
+# Date created: 21 Jan 2004
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsnt
+PORTVERSION= 2.0.14
+CATEGORIES= devel
+MASTER_SITES= http://www.cvsnt.org/archive/ \
+ http://homepages.nildram.co.uk/~tmhoyle/
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= CVS clone
+
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --enable-fork
+USE_GETOPT_LONG=yes
+
+.if exists(/usr/include/gssapi.h)
+PLIST_SUB= GSERVER=""
+.else
+PLIST_SUB= GSERVER="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cvsnt/distinfo b/devel/cvsnt/distinfo
new file mode 100644
index 000000000000..0a557dd31b9b
--- /dev/null
+++ b/devel/cvsnt/distinfo
@@ -0,0 +1 @@
+MD5 (cvsnt-2.0.14.tar.gz) = 1ed977577ae688ddca498edccf51923a
diff --git a/devel/cvsnt/files/patch-configure b/devel/cvsnt/files/patch-configure
new file mode 100644
index 000000000000..260f0e37f018
--- /dev/null
+++ b/devel/cvsnt/files/patch-configure
@@ -0,0 +1,29 @@
+--- configure.orig Wed Dec 10 23:43:42 2003
++++ configure Sun Jan 25 20:31:22 2004
+@@ -19208,7 +19208,7 @@
+
+
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool13/ltmain.sh"
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -25221,7 +25221,7 @@
+ rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ if test "$ac_cv_search_SSL_CTX_new" = no; then
+- for ac_lib in ssl ssleay32; do
++ for ac_lib in "ssl -lcrypto" ssleay32; do
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -27699,7 +27699,7 @@
+ #define LOCKSERVER_SUPPORT
+ _ACEOF
+
+- enable_server="yes"
++ enable_lockserver="yes"
+ fi
+ fi;
+ echo "$as_me:$LINENO: result: $enable_lockserver" >&5
diff --git a/devel/cvsnt/files/patch-configure.in b/devel/cvsnt/files/patch-configure.in
new file mode 100644
index 000000000000..8c6bab63899d
--- /dev/null
+++ b/devel/cvsnt/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Sun Jan 25 20:32:56 2004
++++ configure.in Sun Jan 25 20:32:22 2004
+@@ -305,7 +305,7 @@
+ fi],
+ [if test "$ac_cv_search_connect" != no; then
+ AC_DEFINE(LOCKSERVER_SUPPORT,[],[Support CVS lock server])
+- enable_server="yes"
++ enable_lockserver="yes"
+ fi])
+ AC_MSG_RESULT($enable_lockserver)
+ AM_CONDITIONAL(WITH_LOCKSERVER, test "$enable_lockserver" = "yes")
diff --git a/devel/cvsnt/files/patch-lib-getopt.h b/devel/cvsnt/files/patch-lib-getopt.h
new file mode 100644
index 000000000000..5ecae90d9cd3
--- /dev/null
+++ b/devel/cvsnt/files/patch-lib-getopt.h
@@ -0,0 +1,11 @@
+--- lib/getopt.h.orig Sun Jan 25 20:07:35 2004
++++ lib/getopt.h Sun Jan 25 20:08:37 2004
+@@ -97,7 +97,7 @@
+ exactly why), and there is no particular need to prototype it.
+ We really shouldn't be trampling on the system's namespace at all by
+ declaring getopt() but that is a bigger issue. */
+-extern int getopt ();
++extern int getopt (int argc, char *const argv[], const char *shortopts);
+
+ extern int getopt_long (int argc, char *const *argv, const char *shortopts,
+ const struct option *longopts, int *longind);
diff --git a/devel/cvsnt/files/patch-lib-regex.h b/devel/cvsnt/files/patch-lib-regex.h
new file mode 100644
index 000000000000..da6c79803268
--- /dev/null
+++ b/devel/cvsnt/files/patch-lib-regex.h
@@ -0,0 +1,13 @@
+--- lib/regex.h.orig Sun Jan 25 20:56:51 2004
++++ lib/regex.h Sun Jan 25 20:59:22 2004
+@@ -485,8 +485,8 @@
+ #ifdef _REGEX_RE_COMP
+ /* 4.2 bsd compatibility. */
+ /* CVS: don't use prototypes: they may conflict with system headers. */
+-extern char *re_comp _RE_ARGS (());
+-extern int re_exec _RE_ARGS (());
++extern char *re_comp _RE_ARGS ((const char *));
++extern int re_exec _RE_ARGS ((const char *));
+ #endif
+
+ /* POSIX compatibility. */
diff --git a/devel/cvsnt/files/patch-lockservice-LockParse.cpp b/devel/cvsnt/files/patch-lockservice-LockParse.cpp
new file mode 100644
index 000000000000..28fb1cff2099
--- /dev/null
+++ b/devel/cvsnt/files/patch-lockservice-LockParse.cpp
@@ -0,0 +1,10 @@
+--- lockservice/LockParse.cpp.orig Sun Jan 25 20:42:06 2004
++++ lockservice/LockParse.cpp Sun Jan 25 20:42:39 2004
+@@ -5,6 +5,7 @@
+ #include <winsock2.h>
+ #include <ws2tcpip.h>
+ #else
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netdb.h>
+ #include <errno.h>
diff --git a/devel/cvsnt/files/patch-lockservice-server.cpp b/devel/cvsnt/files/patch-lockservice-server.cpp
new file mode 100644
index 000000000000..f7299452161d
--- /dev/null
+++ b/devel/cvsnt/files/patch-lockservice-server.cpp
@@ -0,0 +1,13 @@
+--- lockservice/server.cpp.orig Sun Jan 25 20:42:11 2004
++++ lockservice/server.cpp Sun Jan 25 20:42:29 2004
+@@ -8,7 +8,10 @@
+ #include <ws2tcpip.h>
+ #define SOCKET_ERRNO WSAGetLastError()
+ #else
++#include <sys/types.h>
++#include <sys/time.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <netdb.h>
+ #include <errno.h>
+ #include <unistd.h>
diff --git a/devel/cvsnt/files/patch-rcs-common.cpp b/devel/cvsnt/files/patch-rcs-common.cpp
new file mode 100644
index 000000000000..4067639d8089
--- /dev/null
+++ b/devel/cvsnt/files/patch-rcs-common.cpp
@@ -0,0 +1,8 @@
+--- rcs/common.cpp.orig Sun Jan 25 21:05:34 2004
++++ rcs/common.cpp Sun Jan 25 21:05:42 2004
+@@ -1,5 +1,4 @@
+ #include <stdio.h>
+-#include <malloc.h>
+ #include <string>
+ #ifdef _WIN32
+ #define WIN32_LEAN_AND_MEAN
diff --git a/devel/cvsnt/files/patch-src-cvs.h b/devel/cvsnt/files/patch-src-cvs.h
new file mode 100644
index 000000000000..3371c1fa1eb9
--- /dev/null
+++ b/devel/cvsnt/files/patch-src-cvs.h
@@ -0,0 +1,21 @@
+--- src/cvs.h.orig Fri Jan 23 18:47:11 2004
++++ src/cvs.h Fri Jan 23 18:48:21 2004
+@@ -931,6 +931,9 @@
+ /* stdio redirection, the easy way... */
+ #include <stdio.h>
+ #define printf cvs_printf
++#if defined(putchar)
++#undef putchar
++#endif
+ #define putchar cvs_putchar
+ #define puts cvs_puts
+ #define fputs cvs_fputs
+@@ -982,7 +985,7 @@
+
+ #ifndef __USER_HANDLE_T_DEFINED
+ /* User handle pointer */
+-typedef struct { void *__unused; } *user_handle_t;
++typedef struct { void *_unused; } *user_handle_t;
+ #define __USER_HANDLE_T_DEFINED
+ #endif
+
diff --git a/devel/cvsnt/files/patch-src-server.h b/devel/cvsnt/files/patch-src-server.h
new file mode 100644
index 000000000000..078f51022286
--- /dev/null
+++ b/devel/cvsnt/files/patch-src-server.h
@@ -0,0 +1,17 @@
+--- src/server.h.orig Fri Jan 23 18:51:00 2004
++++ src/server.h Fri Jan 23 18:54:13 2004
+@@ -91,7 +91,13 @@
+ struct buffer;
+ #endif
+
+-extern void server_updated();
++extern void server_updated(
++ struct file_info *finfo,
++ Vers_TS *vers,
++ enum server_updated_arg4 updated,
++ mode_t mode,
++ unsigned char *checksum,
++ struct buffer *filebuf);
+
+ /* Whether we should send RCS format patches. */
+ extern int server_use_rcs_diff();
diff --git a/devel/cvsnt/files/patch-src-subr.c b/devel/cvsnt/files/patch-src-subr.c
new file mode 100644
index 000000000000..a642468461be
--- /dev/null
+++ b/devel/cvsnt/files/patch-src-subr.c
@@ -0,0 +1,10 @@
+--- src/subr.c.orig Fri Jan 23 18:54:50 2004
++++ src/subr.c Fri Jan 23 18:55:17 2004
+@@ -20,6 +20,7 @@
+ #include <winsock2.h>
+ #include <ws2tcpip.h>
+ #else
++#include <sys/socket.h>
+ #include <netdb.h>
+ #endif
+ #include <errno.h>
diff --git a/devel/cvsnt/pkg-descr b/devel/cvsnt/pkg-descr
new file mode 100644
index 000000000000..73770edf162c
--- /dev/null
+++ b/devel/cvsnt/pkg-descr
@@ -0,0 +1,14 @@
+CVSNT is a CVS clone. CVSNT features are:
+
+* Merge tracking via MergePoint attribute.
+* Support for :sspi: and :sserver: authentication.
+* Branch ACLs can be used to restrict access.
+* Directory browsing via cvs ls command.
+* LockServer on a second port replaces filesystem-based locks &
+ provides file level locking.
+* More sophisticated / extra triggers available e.g. postcommit.
+* Supports Unicode files with additional keyword expansion switches.
+* Atomic Checkout behaviour ensures you get the right version of every file.
+* Efficient storage of binary files using binary deltas.
+
+WWW: http://www.cvsnt.org/
diff --git a/devel/cvsnt/pkg-plist b/devel/cvsnt/pkg-plist
new file mode 100644
index 000000000000..796026229044
--- /dev/null
+++ b/devel/cvsnt/pkg-plist
@@ -0,0 +1,42 @@
+bin/co
+bin/cvs
+bin/cvslockd
+bin/rcs2log
+bin/rcsdiff
+bin/rlog
+etc/cvsnt/PServer.example
+lib/cvsnt/ca.pem
+lib/cvsnt/ext_protocol.la
+lib/cvsnt/ext_protocol.so
+lib/cvsnt/fork_protocol.la
+lib/cvsnt/fork_protocol.so
+%%GSERVER%%lib/cvsnt/gserver_protocol.la
+%%GSERVER%%lib/cvsnt/gserver_protocol.so
+lib/cvsnt/pserver_protocol.la
+lib/cvsnt/pserver_protocol.so
+lib/cvsnt/server_protocol.la
+lib/cvsnt/server_protocol.so
+lib/cvsnt/sserver_protocol.la
+lib/cvsnt/sserver_protocol.so
+lib/cvsnt/sspi_protocol.la
+lib/cvsnt/sspi_protocol.so
+share/cvsnt/contrib/README
+share/cvsnt/contrib/clmerge
+share/cvsnt/contrib/cln_hist
+share/cvsnt/contrib/commit_prep
+share/cvsnt/contrib/cvs2vendor
+share/cvsnt/contrib/cvs_acls
+share/cvsnt/contrib/cvscheck
+share/cvsnt/contrib/debug_check_log
+share/cvsnt/contrib/intro.doc
+share/cvsnt/contrib/log
+share/cvsnt/contrib/log_accum
+share/cvsnt/contrib/mfpipe
+share/cvsnt/contrib/rcs-to-cvs
+share/cvsnt/contrib/rcs2log
+share/cvsnt/contrib/rcslock
+share/cvsnt/contrib/sccs2rcs
+@dirrm share/cvsnt/contrib
+@dirrm share/cvsnt
+@dirrm lib/cvsnt
+@dirrm etc/cvsnt