aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-05-28 19:56:43 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-05-28 19:56:43 +0000
commitfd45926764c6c86329194eb1a720404ea2507de5 (patch)
tree8c1ae2601b5ba6f215bb8a3e061cda0175737ae7 /devel
parentd9dd45d404959c588d55e413b758d5a9e8c42feb (diff)
downloadports-fd45926764c6c86329194eb1a720404ea2507de5.tar.gz
ports-fd45926764c6c86329194eb1a720404ea2507de5.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/libusb/Makefile22
-rw-r--r--devel/libusb/pkg-plist48
2 files changed, 69 insertions, 1 deletions
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
index 4ab0a7068069..bc69a5f34867 100644
--- a/devel/libusb/Makefile
+++ b/devel/libusb/Makefile
@@ -14,7 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= r.c.ladan@gmail.com
COMMENT= Library giving userland programs access to USB devices
+OPTIONS= SGML "Install developer guide from SGML" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SGML)
+BUILD_DEPENDS+= ${LOCALBASE}/share/sgml/jade/catalog:${PORTSDIR}/textproc/jade \
+ ${LOCALBASE}/share/sgml/docbook/dsssl/modular/catalog:${PORTSDIR}/textproc/dsssl-docbook-modular \
+ ${LOCALBASE}/share/sgml/docbook/catalog:${PORTSDIR}/textproc/docbook
+MAKE_ENV+= SGML_CATALOG_FILES=${LOCALBASE}/share/sgml/jade/catalog:${LOCALBASE}/share/sgml/docbook/dsssl/modular/catalog:${LOCALBASE}/share/sgml/docbook/catalog:${LOCALBASE}/share/sgml/docbook/4.2/catalog
+PLIST_SUB= SGML=""
+.else
CONFIGURE_ARGS= --disable-build-docs
+PLIST_SUB= SGML="@comment "
+.endif
+
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -22,4 +36,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' ${WRKSRC}/descriptors.c
-.include <bsd.port.mk>
+post-install:
+.if defined(WITH_SGML)
+ @${MKDIR} ${DOCSDIR}/html
+ @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libusb/pkg-plist b/devel/libusb/pkg-plist
index ce06d28fc8d9..502081e323ad 100644
--- a/devel/libusb/pkg-plist
+++ b/devel/libusb/pkg-plist
@@ -12,3 +12,51 @@ lib/libusbpp.a
lib/libusbpp.la
lib/libusbpp.so
libdata/pkgconfig/libusb.pc
+%%SGML%%%%DOCSDIR%%/html/api-device-interfaces.html
+%%SGML%%%%DOCSDIR%%/html/api-return-values.html
+%%SGML%%%%DOCSDIR%%/html/api-synchronous.html
+%%SGML%%%%DOCSDIR%%/html/api-timeouts.html
+%%SGML%%%%DOCSDIR%%/html/api-types.html
+%%SGML%%%%DOCSDIR%%/html/api.html
+%%SGML%%%%DOCSDIR%%/html/examples-code.html
+%%SGML%%%%DOCSDIR%%/html/examples-other.html
+%%SGML%%%%DOCSDIR%%/html/examples-tests.html
+%%SGML%%%%DOCSDIR%%/html/examples.html
+%%SGML%%%%DOCSDIR%%/html/function.usbbulkread.html
+%%SGML%%%%DOCSDIR%%/html/function.usbbulkwrite.html
+%%SGML%%%%DOCSDIR%%/html/function.usbclaiminterface.html
+%%SGML%%%%DOCSDIR%%/html/function.usbclearhalt.html
+%%SGML%%%%DOCSDIR%%/html/function.usbclose.html
+%%SGML%%%%DOCSDIR%%/html/function.usbcontrolmsg.html
+%%SGML%%%%DOCSDIR%%/html/function.usbdetachkerneldrivernp.html
+%%SGML%%%%DOCSDIR%%/html/function.usbfindbusses.html
+%%SGML%%%%DOCSDIR%%/html/function.usbfinddevices.html
+%%SGML%%%%DOCSDIR%%/html/function.usbgetbusses.html
+%%SGML%%%%DOCSDIR%%/html/function.usbgetdescriptor.html
+%%SGML%%%%DOCSDIR%%/html/function.usbgetdescriptorbyendpoint.html
+%%SGML%%%%DOCSDIR%%/html/function.usbgetdrivernp.html
+%%SGML%%%%DOCSDIR%%/html/function.usbgetstring.html
+%%SGML%%%%DOCSDIR%%/html/function.usbgetstringsimple.html
+%%SGML%%%%DOCSDIR%%/html/function.usbinit.html
+%%SGML%%%%DOCSDIR%%/html/function.usbinterruptread.html
+%%SGML%%%%DOCSDIR%%/html/function.usbinterruptwrite.html
+%%SGML%%%%DOCSDIR%%/html/function.usbopen.html
+%%SGML%%%%DOCSDIR%%/html/function.usbreleaseinterface.html
+%%SGML%%%%DOCSDIR%%/html/function.usbreset.html
+%%SGML%%%%DOCSDIR%%/html/function.usbresetep.html
+%%SGML%%%%DOCSDIR%%/html/function.usbsetaltinterface.html
+%%SGML%%%%DOCSDIR%%/html/function.usbsetconfiguration.html
+%%SGML%%%%DOCSDIR%%/html/functions.html
+%%SGML%%%%DOCSDIR%%/html/index.html
+%%SGML%%%%DOCSDIR%%/html/intro-overview.html
+%%SGML%%%%DOCSDIR%%/html/intro-support.html
+%%SGML%%%%DOCSDIR%%/html/intro.html
+%%SGML%%%%DOCSDIR%%/html/preface.html
+%%SGML%%%%DOCSDIR%%/html/ref.bulk.html
+%%SGML%%%%DOCSDIR%%/html/ref.control.html
+%%SGML%%%%DOCSDIR%%/html/ref.core.html
+%%SGML%%%%DOCSDIR%%/html/ref.deviceops.html
+%%SGML%%%%DOCSDIR%%/html/ref.interrupt.html
+%%SGML%%%%DOCSDIR%%/html/ref.nonportable.html
+%%SGML%%@dirrm %%DOCSDIR%%/html
+%%SGML%%@dirrm %%DOCSDIR%%