aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-22 12:45:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-22 12:45:46 +0000
commit1d5f6e4eb6742516de94de6a029296a994ef2cb1 (patch)
tree051e8d756161e71c770f019c19f60f86343b0255 /devel
parent95f3b20b3e699ecb468b200c9ec6655ec4ced345 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-bioruby/Makefile28
-rw-r--r--devel/rubygem-bioruby/distinfo3
-rw-r--r--devel/rubygem-bioruby/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a428d6ed2bec..fedf1f593648 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2595,6 +2595,7 @@
SUBDIR += rubygem-activesupport
SUBDIR += rubygem-analogger
SUBDIR += rubygem-arrayfields
+ SUBDIR += rubygem-bioruby
SUBDIR += rubygem-builder
SUBDIR += rubygem-chronic
SUBDIR += rubygem-columnize
diff --git a/devel/rubygem-bioruby/Makefile b/devel/rubygem-bioruby/Makefile
new file mode 100644
index 000000000000..c4e2e935cd43
--- /dev/null
+++ b/devel/rubygem-bioruby/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rubygem-bioruby
+# Date created: 20 June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bioruby
+PORTVERSION= 1.3.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+DISTNAME= bio-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Integrated environment for Bioinformatics written in Ruby
+
+PLIST_FILES= bin/bioruby \
+ bin/br_biofetch.rb \
+ bin/br_bioflat.rb \
+ bin/br_biogetseq.rb \
+ bin/br_pmfetch.rb
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+GEM_NAME= ${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-bioruby/distinfo b/devel/rubygem-bioruby/distinfo
new file mode 100644
index 000000000000..c95e69f1d80b
--- /dev/null
+++ b/devel/rubygem-bioruby/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/bio-1.3.0.gem) = 23d28f07311b769265ba4a764716cd13
+SHA256 (rubygem/bio-1.3.0.gem) = e2441f967e1dfbfff6eb57d81e148976290f3ce78b234a71d88a94c7343644cf
+SIZE (rubygem/bio-1.3.0.gem) = 914944
diff --git a/devel/rubygem-bioruby/pkg-descr b/devel/rubygem-bioruby/pkg-descr
new file mode 100644
index 000000000000..d13335b9146f
--- /dev/null
+++ b/devel/rubygem-bioruby/pkg-descr
@@ -0,0 +1,4 @@
+BioRuby project aims to implement integrated environment for
+Bioinformatics by using Ruby.
+
+WWW: http://bioruby.org/