aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 09:55:25 +0000
commit9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0 (patch)
tree043d479b1d60668b1d77568d010f6178e25bd6ba /devel
parentc4823e883be563337dde9dde23949cde6c3fce0f (diff)
downloadports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.tar.gz
ports-9c288e873f84089ba8dcb3c1acff8ce23bd4e5e0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/adacurses/Makefile4
-rw-r--r--devel/amulet/Makefile4
-rw-r--r--devel/clint/Makefile8
-rw-r--r--devel/doc++/Makefile8
-rw-r--r--devel/freescope/Makefile8
-rw-r--r--devel/ixlib/Makefile8
-rw-r--r--devel/mico/Makefile8
-rw-r--r--devel/titano/Makefile8
-rw-r--r--devel/yacl/Makefile8
9 files changed, 57 insertions, 7 deletions
diff --git a/devel/adacurses/Makefile b/devel/adacurses/Makefile
index f1ad8c284b18..e95875ff544b 100644
--- a/devel/adacurses/Makefile
+++ b/devel/adacurses/Makefile
@@ -19,6 +19,10 @@ BUILD_DEPENDS= gnat:${PORTSDIR}/lang/gnat
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_LIBTOOL= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
diff --git a/devel/amulet/Makefile b/devel/amulet/Makefile
index 7d9751dcd6d4..b1ae53fa4061 100644
--- a/devel/amulet/Makefile
+++ b/devel/amulet/Makefile
@@ -22,6 +22,10 @@ MAKE_ENV= AMULET_DIR=$(WRKSRC) AMULET_VARS_FILE=Makefile.vars.gcc.FreeBSD
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.if $(PORTOBJFORMAT) == "elf"
SO_VERSION= 3
.else
diff --git a/devel/clint/Makefile b/devel/clint/Makefile
index 10138f654afc..a7306ff0e1a7 100644
--- a/devel/clint/Makefile
+++ b/devel/clint/Makefile
@@ -16,6 +16,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A static source code checker for C++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_PYTHON= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -28,4 +34,4 @@ post-patch:
post-install:
@install-info ${PREFIX}/info/clint.info ${PREFIX}/info/dir
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/doc++/Makefile b/devel/doc++/Makefile
index 478994e79b20..8d1dc53dac55 100644
--- a/devel/doc++/Makefile
+++ b/devel/doc++/Makefile
@@ -18,6 +18,12 @@ RUN_DEPENDS= tex:${PORTSDIR}/print/teTeX \
gs:${PORTSDIR}/print/ghostscript-gnu \
anytopnm:${PORTSDIR}/graphics/netpbm
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -63,4 +69,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/freescope/Makefile b/devel/freescope/Makefile
index dd9c37fadd1a..633c86a271a7 100644
--- a/devel/freescope/Makefile
+++ b/devel/freescope/Makefile
@@ -16,6 +16,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Source code browsing on UNIX-like operating systems
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_REINPLACE= yes
@@ -28,4 +34,4 @@ pre-patch:
s|CXXFLAGS=.*$$|CXXFLAGS="\$$CXXFLAGS"|g ; \
s|bindir="/usr/local/bin"||g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/ixlib/Makefile b/devel/ixlib/Makefile
index c4a7f70e9e53..0eca1515f596 100644
--- a/devel/ixlib/Makefile
+++ b/devel/ixlib/Makefile
@@ -18,10 +18,16 @@ COMMENT= A small C++ tools library based on STL
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index e4e857779222..98325b09208e 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.mico.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= A CORBA 2.0 implementation which goal is freely available
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/mico
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -61,4 +67,4 @@ post-install:
@${STRIP_CMD} ${PREFIX}/bin/traderd
@${STRIP_CMD} ${PREFIX}/bin/traversald
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/titano/Makefile b/devel/titano/Makefile
index b025f79fd0e2..cc722e18569e 100644
--- a/devel/titano/Makefile
+++ b/devel/titano/Makefile
@@ -17,6 +17,12 @@ COMMENT= An IDE for GNOME desktop
LIB_DEPENDS= gtkeditor.0:${PORTSDIR}/x11-toolkits/libgtkeditor
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${DISTNAME:S/b//}
USE_REINPLACE= yes
@@ -36,4 +42,4 @@ post-install:
${MKDIR} ${PREFIX}/share/gnome/pixmaps/titano
${INSTALL_DATA} ${WRKSRC}/src/xpm/* ${PREFIX}/share/gnome/pixmaps/titano
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/yacl/Makefile b/devel/yacl/Makefile
index 8b352c3993d7..b3aa429f628e 100644
--- a/devel/yacl/Makefile
+++ b/devel/yacl/Makefile
@@ -14,6 +14,12 @@ DISTNAME= yacl-0170-beta
MAINTAINER= ports@freebsd.org
COMMENT= Portable programming library for C++
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
NO_WRKSUBDIR= yes
USE_ZIP= yes
MAKE_ENV= YACLPATH=${WRKDIR}
@@ -51,4 +57,4 @@ post-install:
@strip ${PREFIX}/share/yacl/apps/bmpview
@strip ${PREFIX}/share/yacl/apps/dlged
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>