aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 15:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 15:34:17 +0000
commit9f1de9b900c064307cc328ec436f07477dfaa7f0 (patch)
tree5b19e4fae39149280653cc670bc170d039477f8e /devel
parent296877462b8b100e9f83f9c6aa6ed4bff34c6def (diff)
downloadports-9f1de9b900c064307cc328ec436f07477dfaa7f0.tar.gz
ports-9f1de9b900c064307cc328ec436f07477dfaa7f0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cdk/Makefile2
-rw-r--r--devel/directfb/Makefile3
-rw-r--r--devel/gdb/Makefile4
-rw-r--r--devel/hs-terminfo/Makefile2
-rw-r--r--devel/jtag/Makefile2
-rw-r--r--devel/libepp-nicbr/Makefile2
-rw-r--r--devel/omake/Makefile5
-rw-r--r--devel/piklab/Makefile4
-rw-r--r--devel/stfl/Makefile9
9 files changed, 12 insertions, 21 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 0d42b15baf22..46e06fdea5bb 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -16,8 +16,8 @@ COMMENT= Curses Development Kit for speedy development of full screen programs
LICENSE= BSD
+USES= ncurses
USE_GMAKE= yes
-USE_NCURSES= yes
GNU_CONFIGURE= yes
PORTDOCS= COPYING EXPANDING INSTALL NOTES README TODO
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 8a8d27724fc6..f4ff3c623bd0 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -26,10 +26,9 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix ncurses
USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
-USE_NCURSES= yes
DIRECTFB_SHLIB= 5 # LT_CURRENT
DIRECTFB_BIN= 5 # LT_BINARY
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index cf68b0447b44..7b908c12a1ae 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -65,11 +65,11 @@ CONFIGURE_ARGS+= --with-system-readline
.if ${PORT_OPTIONS:MBASE_READLINE}
CFLAGS+= -D_rl_echoing_p=readline_echoing_p
-USE_READLINE= base
+USES+= readline
.endif
.if ${PORT_OPTIONS:MPORT_READLINE}
-USE_READLINE= port
+USES+= readline:port
.endif
.if ${PORT_OPTIONS:MPYTHON}
diff --git a/devel/hs-terminfo/Makefile b/devel/hs-terminfo/Makefile
index 73e23328f634..1c7744778961 100644
--- a/devel/hs-terminfo/Makefile
+++ b/devel/hs-terminfo/Makefile
@@ -10,7 +10,7 @@ COMMENT= Haskell bindings to the terminfo library
LICENSE= BSD
-USE_NCURSES= yes
+USES= ncurses
CONFIGURE_ARGS+= --configure-option=--with-curses-includes=${NCURSESINC} \
--configure-option=--with-curses-libraries=${NCURSESLIB}
diff --git a/devel/jtag/Makefile b/devel/jtag/Makefile
index fe20a90f7168..7619ad16a5ea 100644
--- a/devel/jtag/Makefile
+++ b/devel/jtag/Makefile
@@ -17,8 +17,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= NLS DOCS
+USES= readline
USE_BZIP2= yes
-USE_READLINE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/libepp-nicbr/Makefile b/devel/libepp-nicbr/Makefile
index e9575817d156..380e8f8ac354 100644
--- a/devel/libepp-nicbr/Makefile
+++ b/devel/libepp-nicbr/Makefile
@@ -36,7 +36,7 @@ PLIST_SUB= VER="${PORTVERSION}"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MREADLINE}
-USE_READLINE= yes
+USES+= readline
PLIST_SUB+= READLINE=""
.else
CONFIGURE_ENV+= ac_cv_lib_readline_readline=no
diff --git a/devel/omake/Makefile b/devel/omake/Makefile
index 038e4a2f6365..b2601e4d59b0 100644
--- a/devel/omake/Makefile
+++ b/devel/omake/Makefile
@@ -7,13 +7,12 @@ CATEGORIES= devel
MASTER_SITES= http://main.metaprl.org/download/omake/
MAINTAINER= bf@FreeBSD.org
-COMMENT= A flexible build system
+COMMENT= Flexible build system
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C|-.*||}
USE_OCAML= yes
NO_OCAML_RUNDEPENDS=yes
-USE_NCURSES= yes
-USE_READLINE= yes
+USES= ncurses readline
MAKE_JOBS_UNSAFE= yes
INFO= omake-doc
diff --git a/devel/piklab/Makefile b/devel/piklab/Makefile
index fb17fbf1d97d..191b5ff48c39 100644
--- a/devel/piklab/Makefile
+++ b/devel/piklab/Makefile
@@ -18,9 +18,7 @@ USE_BZIP2= yes
USE_DOS2UNIX= Piklab.cmake
USE_QT4= corelib gui qt3support qtestlib xml \
moc_build qmake_build rcc_build uic_build
-USE_NCURSES= yes
-USE_READLINE= yes
-USES= cmake gettext
+USES= cmake gettext readline
MAKE_JOBS_SAFE= yes
MAN1= piklab-hex.1 piklab-prog.1
diff --git a/devel/stfl/Makefile b/devel/stfl/Makefile
index dc86dc1aa401..ec4c8d972838 100644
--- a/devel/stfl/Makefile
+++ b/devel/stfl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: stfl
-# Date created: 28 March 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= stfl
PORTVERSION= 0.22
@@ -18,8 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_LDCONFIG= yes
USE_GMAKE= yes
-USES= iconv
-USE_NCURSES= yes
+USES= iconv ncurses
MAKE_JOBS_SAFE= yes
ALL_TARGET= libstfl.so
PLIST_FILES= lib/libstfl.so.1 lib/libstfl.so include/stfl.h \