aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2006-01-06 15:45:21 +0000
committerHiroki Sato <hrs@FreeBSD.org>2006-01-06 15:45:21 +0000
commit394e4298dc91f755d456ee567ddfe422273aa989 (patch)
tree8bea9dcf5df0b7794702985cd8ea3c578c1dd777 /devel
parentb46d4c822059cfa1531f68ef79dd8935c5d242a8 (diff)
downloadports-394e4298dc91f755d456ee567ddfe422273aa989.tar.gz
ports-394e4298dc91f755d456ee567ddfe422273aa989.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/plan9port/Makefile27
-rw-r--r--devel/plan9port/distinfo6
-rw-r--r--devel/plan9port/files/patch-src-cmd-eqn-e.h19
-rw-r--r--devel/plan9port/files/patch-src-lib9-fmt-plan9.h16
4 files changed, 51 insertions, 17 deletions
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 986858c132ea..8d0ead1449db 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= plan9port
-PORTVERSION= 20051231
+PORTVERSION= 20060101
CATEGORIES= devel plan9
MASTER_SITES= http://swtch.com/plan9port/ \
ftp://quenix2.dyndns.org/FreeBSD/ports/distfiles/
@@ -27,9 +27,6 @@ ONLY_FOR_ARCHS= i386
PLAN9= ${PREFIX}/plan9
MANPREFIX= ${PLAN9}
-# Files's name in this directory are utf-8 encoded and not
-# handled by pkg_delete
-UTF8_DIR= plan9/troff/font/devutf/charlib
MAN1= 9term.1 acmeevent.1 ascii.1 acme.1 9p.1 basename.1 cal.1 \
calendar.1 cat.1 cleanname.1 cmp.1 comm.1 date.1 db.1 \
@@ -89,27 +86,29 @@ NOMANCOMPRESS= yes
EMPTY_DIRS= plan9/log \
plan9/bin/lpbin \
plan9/9pm/Windows/386/bin \
- plan9/9pm/Plan9/386/lib
+ plan9/9pm/Plan9/386/lib \
+ plan9/dist/debian \
+ plan9/dist/pkg
-pre-build:
- @${REINPLACE_CMD} -e 's|cc=gcc|cc=${CC}|' ${WRKSRC}/bin/9c
- @${REINPLACE_CMD} -e 's|cc=gcc|cc=${CC}|' ${WRKSRC}/bin/9l
+post-patch:
+ ${FIND} ${WRKSRC}/man -type f -regex ".*\.[0-9?]$\" \
+ | ${XARGS} ${REINPLACE_CMD} -e 's|\\\*9|${PREFIX}|'
do-build:
cd ${WRKSRC} && ./INSTALL
post-build:
+ ${RM} -rf `${FIND} ${WRKSRC}/dist -type f ! -regex ".*\.png"`
${RM} -rf `${FIND} ${WRKSRC} -name CVS -o -name .cvsignore`
- ( ${FIND} ${WRKSRC}/ -type f | ${SORT} \
- | ${GREP} -v ".*plan9/man/man[0-9]/.*\.[0-9?]$\" \
- | ${GREP} -v charlib ; \
+ ( cd ${WRKDIR} && \
+ ${FIND} plan9 -type f \
+ -a ! -path "plan9/man/man[0-9]/*.[0-9]*"; \
for D in ${EMPTY_DIRS}; do \
${ECHO_CMD} "@exec ${MKDIR} ${PREFIX}/$${D}"; \
done; \
- ${FIND} ${WRKSRC}/ -type d | ${SORT} -r \
+ ${FIND} plan9 -type d | ${SORT} -r \
| ${SED} -e 's|^|@dirrm |'; \
- ) | ${SED} -e 's|${WRKDIR}/||' \
- | ${SED} -e 's|@dirrm ${UTF8_DIR}|@unexec ${RM} -rf ${PREFIX}/${UTF8_DIR}|' >${PLIST}
+ ) > ${PLIST}
do-install:
${CP} -rp ${WRKSRC} ${PREFIX}
diff --git a/devel/plan9port/distinfo b/devel/plan9port/distinfo
index 5a39139f2084..97f07dabbb34 100644
--- a/devel/plan9port/distinfo
+++ b/devel/plan9port/distinfo
@@ -1,3 +1,3 @@
-MD5 (plan9port-20051231.tgz) = 712d893f62426800d0894959af81c012
-SHA256 (plan9port-20051231.tgz) = 8ecc59889b450193ee24c20f68e120573b6a60cf64dd3ebb3bc2c081a4fc1206
-SIZE (plan9port-20051231.tgz) = 18376484
+MD5 (plan9port-20060101.tgz) = 1ee06ef9325b30cb3f02ea032cc93b0f
+SHA256 (plan9port-20060101.tgz) = 3895c3b413fa1d2c40b124c961810426757d5dbedf6a7f6971ed7b870c0a5466
+SIZE (plan9port-20060101.tgz) = 18379002
diff --git a/devel/plan9port/files/patch-src-cmd-eqn-e.h b/devel/plan9port/files/patch-src-cmd-eqn-e.h
new file mode 100644
index 000000000000..8aef293f2384
--- /dev/null
+++ b/devel/plan9port/files/patch-src-cmd-eqn-e.h
@@ -0,0 +1,19 @@
+--- src/cmd/eqn/e.h.orig Sat Dec 31 14:00:37 2005
++++ src/cmd/eqn/e.h Sat Jan 7 00:16:57 2006
+@@ -2,7 +2,16 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
++#if defined(__FreeBSD__)
++#if __FreeBSD__ >= 2
++#include <osreldate.h>
++#if __FreeBSD_version < 500000
++#include <inttypes.h>
++#else
+ #include <stdint.h>
++#endif
++#endif
++#endif
+
+ #undef sqrt
+ #define sqrt p9_sqrt
diff --git a/devel/plan9port/files/patch-src-lib9-fmt-plan9.h b/devel/plan9port/files/patch-src-lib9-fmt-plan9.h
new file mode 100644
index 000000000000..c4d58697e2d2
--- /dev/null
+++ b/devel/plan9port/files/patch-src-lib9-fmt-plan9.h
@@ -0,0 +1,16 @@
+--- src/lib9/fmt/plan9.h.orig Fri Dec 30 14:00:49 2005
++++ src/lib9/fmt/plan9.h Sat Jan 7 00:15:40 2006
+@@ -1,4 +1,13 @@
++#if defined(__FreeBSD__)
++#if __FreeBSD__ >= 2
++#include <osreldate.h>
++#if __FreeBSD_version < 500000
++#include <inttypes.h>
++#else
+ #include <stdint.h>
++#endif
++#endif
++#endif
+
+ /*
+ * compiler directive on Plan 9