aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-12 05:47:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-12 05:47:43 +0000
commit8db370234ca1a82dbde45333806a54cbcd85fd5b (patch)
treec29753d825c8241db26793e42cd2f205cb43a9b4 /devel
parentfc271dc2dc5065982238c939f4acbe6ebd0bbffa (diff)
downloadports-8db370234ca1a82dbde45333806a54cbcd85fd5b.tar.gz
ports-8db370234ca1a82dbde45333806a54cbcd85fd5b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/tradcpp/Makefile12
-rw-r--r--devel/tradcpp/distinfo4
-rw-r--r--devel/tradcpp/files/patch-directive.c56
-rw-r--r--devel/tradcpp/files/patch-files.c20
-rw-r--r--devel/tradcpp/files/patch-output.c11
5 files changed, 8 insertions, 95 deletions
diff --git a/devel/tradcpp/Makefile b/devel/tradcpp/Makefile
index db9315d73e85..c2bb98f6875d 100644
--- a/devel/tradcpp/Makefile
+++ b/devel/tradcpp/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= tradcpp
-PORTVERSION= 0.1
+PORTVERSION= 0.2
CATEGORIES= devel
MASTER_SITES= http://ftp.NetBSD.org/pub/NetBSD/misc/dholland/
@@ -10,12 +10,12 @@ COMMENT= Traditional (K&R-style) C preprocessor
LICENSE= BSD
-PLIST_FILES= bin/tradcpp
+MANCOMPRESSED= yes
+MAKE_JOBS_SAFE= yes
+MAKE_ARGS= BINDIR=${PREFIX}/bin MANDIR=${MANPREFIX}/man/man
-post-patch:
- @${REINPLACE_CMD} 's/NOMAN/NO_MAN/' ${WRKSRC}/Makefile
+PLIST_FILES= bin/tradcpp
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+MAN1= tradcpp.1
.include <bsd.port.mk>
diff --git a/devel/tradcpp/distinfo b/devel/tradcpp/distinfo
index f823672233b2..0a3fd39f7245 100644
--- a/devel/tradcpp/distinfo
+++ b/devel/tradcpp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tradcpp-0.1.tar.gz) = b3f92103bbf5df833364cd80746c5c6d14b17581cb2a4fba09739cee01445fae
-SIZE (tradcpp-0.1.tar.gz) = 28288
+SHA256 (tradcpp-0.2.tar.gz) = 1a9661acbc08733e0156ffebc2e78d141748ec5f66242670be0620e99fc2170f
+SIZE (tradcpp-0.2.tar.gz) = 32388
diff --git a/devel/tradcpp/files/patch-directive.c b/devel/tradcpp/files/patch-directive.c
deleted file mode 100644
index 9dcb782ca011..000000000000
--- a/devel/tradcpp/files/patch-directive.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- ./directive.c.orig 2013-06-11 06:14:31.000000000 +0200
-+++ ./directive.c 2013-06-11 14:19:53.281451337 +0200
-@@ -238,7 +238,7 @@
-
- static
- void
--d_else(struct place *p, struct place *p2, char *line)
-+d_else(struct place *p, struct place *p2 __unused, char *line __unused)
- {
- if (ifstate->seenelse) {
- complain(p, "Multiple #else directives in one conditional");
-@@ -252,7 +252,7 @@
-
- static
- void
--d_endif(struct place *p, struct place *p2, char *line)
-+d_endif(struct place *p, struct place *p2 __unused, char *line __unused)
- {
- if (ifstate->prev == NULL) {
- complain(p, "Unmatched #endif");
-@@ -267,7 +267,7 @@
-
- static
- void
--d_define(struct place *p, struct place *p2, char *line)
-+d_define(struct place *p __unused, struct place *p2, char *line)
- {
- size_t pos, argpos;
- struct place p3, p4;
-@@ -330,7 +330,7 @@
-
- static
- void
--d_undef(struct place *p, struct place *p2, char *line)
-+d_undef(struct place *p __unused, struct place *p2, char *line)
- {
- uncomment(line);
- oneword("#undef", p2, line);
-@@ -393,7 +393,7 @@
-
- static
- void
--d_line(struct place *p, struct place *p2, char *line)
-+d_line(struct place *p, struct place *p2 __unused, char *line __unused)
- {
- /* XXX */
- complain(p, "Sorry, no #line yet");
-@@ -433,7 +433,7 @@
-
- static
- void
--d_pragma(struct place *p, struct place *p2, char *line)
-+d_pragma(struct place *p, struct place *p2 __unused, char *line)
- {
- complain(p, "#pragma %s", line);
- complain_fail();
diff --git a/devel/tradcpp/files/patch-files.c b/devel/tradcpp/files/patch-files.c
deleted file mode 100644
index 68978793b261..000000000000
--- a/devel/tradcpp/files/patch-files.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./files.c.orig 2013-06-11 14:21:06.504446578 +0200
-+++ ./files.c 2013-06-11 14:23:44.928830892 +0200
-@@ -340,6 +340,17 @@
-
- assert(place != NULL);
-
-+ if (name[0] == '/') {
-+ fd = file_tryopen(name);
-+ if (fd >= 0) {
-+ pf = place_addfile(place, name, true);
-+ file_read(pf, fd, name, false);
-+ close(fd);
-+ return;
-+ }
-+ complain(place, "Include file %s not found", name);
-+ complain_fail();
-+ }
- num = incdirarray_num(path);
- for (i=0; i<num; i++) {
- id = incdirarray_get(path, i);
diff --git a/devel/tradcpp/files/patch-output.c b/devel/tradcpp/files/patch-output.c
deleted file mode 100644
index 56740d31b8a1..000000000000
--- a/devel/tradcpp/files/patch-output.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./output.c.orig 2013-06-11 06:14:31.000000000 +0200
-+++ ./output.c 2013-06-11 14:19:53.285452684 +0200
-@@ -96,7 +96,7 @@
-
- static
- void
--filter_output(const struct place *p, const char *buf, size_t len)
-+filter_output(const struct place *p __unused, const char *buf, size_t len)
- {
- size_t pos, start;
- bool inesc = false;