aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-19 11:05:42 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-19 11:05:42 +0000
commitf67a73af560dab13aec1ffc74c2b905ffe1ddb07 (patch)
tree94b46ee49fa0b508c2a95a1d558811d2a945405d /devel
parent71fb67d74074bc0709c31ccaba2329b6c8175fec (diff)
downloadports-f67a73af560dab13aec1ffc74c2b905ffe1ddb07.tar.gz
ports-f67a73af560dab13aec1ffc74c2b905ffe1ddb07.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cppadvio/Makefile45
-rw-r--r--devel/cppadvio/distinfo1
-rw-r--r--devel/cppadvio/files/patch-Makefile84
-rw-r--r--devel/cppadvio/pkg-comment1
-rw-r--r--devel/cppadvio/pkg-descr20
-rw-r--r--devel/cppadvio/pkg-message10
-rw-r--r--devel/cppadvio/pkg-plist16
8 files changed, 178 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index afbae2840928..4150333adf19 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -69,6 +69,7 @@
SUBDIR += cons-test
SUBDIR += cook
SUBDIR += cpp2html
+ SUBDIR += cppadvio
SUBDIR += cproto
SUBDIR += crossgo32
SUBDIR += crossgo32-djgpp2
diff --git a/devel/cppadvio/Makefile b/devel/cppadvio/Makefile
new file mode 100644
index 000000000000..d118e429003d
--- /dev/null
+++ b/devel/cppadvio/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: cppadvio
+# Date created: November 23, 2000
+# Whom: Oleg Kiselyov <oleg@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cppadvio
+PORTVERSION= 2.6
+CATEGORIES= devel net
+MASTER_SITES= http://www.lh.com/~oleg/ftp/packages/ \
+ ${MASTER_SITE_LOCAL}
+
+MAINTAINER= oleg@pobox.com
+
+WRKSRC= ${WRKDIR}/cppadvio
+ALL_TARGET= lib
+USE_GMAKE= yes
+USE_NEWGCC= yes
+
+post-patch:
+ @( cd ${WRKSRC}; ${MV} c++ c++.orig; \
+ ${SED} -e 's/^ *gcc/${CXX} ${CXXFLAGS}/' c++.orig > c++; ${CHMOD} +x c++ )
+
+do-install:
+ $(INSTALL_DATA) ${WRKSRC}/libcppadvio.a ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/Logger.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/TCPstream.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/arithm.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/arithm_modadapt.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/arithm_modadh.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/builtin.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/endian_io.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/histogram.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/minmax.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/myenv.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/std.h ${PREFIX}/include/cppadvio
+ $(INSTALL_DATA) ${WRKSRC}/voc.h ${PREFIX}/include/cppadvio
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/cppadvio
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cppadvio
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cppadvio/distinfo b/devel/cppadvio/distinfo
new file mode 100644
index 000000000000..bca2800d2532
--- /dev/null
+++ b/devel/cppadvio/distinfo
@@ -0,0 +1 @@
+MD5 (cppadvio-2.6.tar.gz) = cca888d30ddfcf4957fa501b6ee0569b
diff --git a/devel/cppadvio/files/patch-Makefile b/devel/cppadvio/files/patch-Makefile
new file mode 100644
index 000000000000..58d5730323ab
--- /dev/null
+++ b/devel/cppadvio/files/patch-Makefile
@@ -0,0 +1,84 @@
+--- Makefile Sun Nov 19 14:57:06 2000
++++ Makefile Thu Nov 23 14:12:35 2000
+@@ -62,8 +62,8 @@
+ #
+ # $Id: Makefile,v 4.2 2000/11/19 22:57:06 oleg Exp oleg $
+
+-CC=./c++
+-CCL=g++ -pipe
++CCXC=./c++
++CCL=$(CXX)
+ .SUFFIXES: .cc
+ MODULES=myenv.cc endian_io.cc \
+ arithm_coding.cc arithm_model.cc arithm_modadapt.cc \
+@@ -83,10 +83,10 @@
+ # Rules, new style
+
+ %.o : %.cc
+- $(CC) $*.cc
++ $(CCXC) $*.cc
+
+ $(LIBRARY)(%.o) : %.cc
+- $(CC) $*.cc
++ $(CCXC) $*.cc
+ ar rcv $(LIBRARY) $*.o
+ rm -f $*.o
+
+@@ -95,7 +95,7 @@
+ ./$@
+
+ % :: %.cc
+- $(CC) $*.cc
++ $(CCXC) $*.cc
+ $(CCL) $*.o $(CLDEF) $(LIBRARY) $(LIBS) -o $@
+ ./$@
+
+@@ -104,11 +104,11 @@
+ # $(CCL) $*.o $(CLDEF) $(LIBRARY) $(LIBS) -o $*
+ # ./$*
+ #.cc: $*.cc $(LIBRARY)
+-# $(CC) $*.cc
++# $(CCXC) $*.cc
+ # $(CCL) $*.o $(CLDEF) $(LIBRARY) $(LIBS) -o $*
+ # ./$*
+ #.cc.o:
+-# $(CC) $*.cc
++# $(CCXC) $*.cc
+ #
+
+ # Primary goal
+@@ -126,7 +126,7 @@
+
+ #$(LIBRARY):: $(MODULES)
+ # Compile the source files that have been changed
+-# $(CC) $?
++# $(CCXC) $?
+ # listobj=`echo $? | sed s/.cc/.o/g` ; \
+ # ar rv $(LIBRARY) $$listobj && \
+ # rm $$listobj
+@@ -151,14 +151,14 @@
+
+ # Optimization causes internal compiler error...
+ #vmyenv.o: vmyenv.cc
+-# $(CC) -O0 vmyenv.cc
++# $(CCXC) -O0 vmyenv.cc
+
+ vTCPstream: vTCPstream.o $(LIBRARY)
+ $(CCL) $^ -o $@ $(NETLIBS) -lm
+ ECHO_HOST=$(ECHO_HOST) ./$@
+
+ vTCPstream_server.o: vTCPstream_server.cc
+- $(CC) -DDO_FORK vTCPstream_server.cc
++ $(CCXC) -DDO_FORK vTCPstream_server.cc
+
+ vTCPstream_server: vTCPstream_server.o $(LIBRARY)
+ $(CCL) $^ -o $@ $(NETLIBS) -lm
+@@ -177,7 +177,7 @@
+
+
+ vendian_io_ext: sys_open_glue.o open_ext.o
+- $(CC) -DEXT_OPEN=1 -DEXT_NETIO=$(ECHO_HOST) vendian_io.cc
++ $(CCXC) -DEXT_OPEN=1 -DEXT_NETIO=$(ECHO_HOST) vendian_io.cc
+ $(CCL) vendian_io.o $^ $(LIBRARY) $(NETLIBS) -o $@ -lm
+ ./$@
+
diff --git a/devel/cppadvio/pkg-comment b/devel/cppadvio/pkg-comment
new file mode 100644
index 000000000000..1ce8d3279009
--- /dev/null
+++ b/devel/cppadvio/pkg-comment
@@ -0,0 +1 @@
+Advanced i/o, networking, and arithmetic compression C++ classlib
diff --git a/devel/cppadvio/pkg-descr b/devel/cppadvio/pkg-descr
new file mode 100644
index 000000000000..6a582c3831cb
--- /dev/null
+++ b/devel/cppadvio/pkg-descr
@@ -0,0 +1,20 @@
+cppadvio: Advanced i/o, Networking, and Arithmetic Compression
+classlib, extended file names, and portable handling and compression
+of binary data
+
+A collection of classes and C++ streams that perform:
+ - a variable-bit coding of sequences of integers (including
+ Arithmetic compression),
+ - a trick of sharing a stream buffer (a "file") among several streams,
+ - handling of extended file names, with uni- and bi-directional 'pipes'
+ and a 'tcp://' prefix
+ - explicit endian specification in dealing with integer streams
+ - TCP streams
+ - a Vocabulary package, (poly/homo)morphic dictionaries with a
+ dynamic "inheritance" path, an embedded OO system
+
+Current Version: 2.6, November 19, 2000.
+WWW: http://pobox.com/~oleg/ftp/packages.html
+
+Oleg Kiselyov
+mailto:oleg@pobox.com, mailto:oleg@acm.org, mailto:oleg@computer.org
diff --git a/devel/cppadvio/pkg-message b/devel/cppadvio/pkg-message
new file mode 100644
index 000000000000..86b8f7d9c768
--- /dev/null
+++ b/devel/cppadvio/pkg-message
@@ -0,0 +1,10 @@
+Don't forget to compile and run verification/validation code: gmake check-all
+or specifically, sub-targets
+ vmyenv vendian_io vendian_io_ext vhistogram varithm
+ vTCPstream vTCPstream_server vvoc
+
+See comments in the work/cppadvio/Makefile for details, as well as
+c++serv.dr. The verification code checks to see that all the
+functions in this package have compiled and run well. The validation
+code can also serve as an illustration of how package's classes and
+functions may be employed.
diff --git a/devel/cppadvio/pkg-plist b/devel/cppadvio/pkg-plist
new file mode 100644
index 000000000000..2d67f96417ec
--- /dev/null
+++ b/devel/cppadvio/pkg-plist
@@ -0,0 +1,16 @@
+lib/libcppadvio.a
+%%PORTDOCS%%share/doc/cppadvio/README
+%%PORTDOCS%%@dirrm share/doc/cppadvio
+include/cppadvio/Logger.h
+include/cppadvio/TCPstream.h
+include/cppadvio/arithm.h
+include/cppadvio/arithm_modadapt.h
+include/cppadvio/arithm_modadh.h
+include/cppadvio/builtin.h
+include/cppadvio/endian_io.h
+include/cppadvio/histogram.h
+include/cppadvio/minmax.h
+include/cppadvio/myenv.h
+include/cppadvio/std.h
+include/cppadvio/voc.h
+@dirrm include/cppadvio