aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-12-29 09:01:54 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-12-29 09:01:54 +0000
commit377901b8047ae297af0f26755f2de5b3294e1a52 (patch)
treeac738d925e9dd4322b885c52f4c199df3cb92fa8 /devel
parentcda895d2d4055b8bb411bcc6a43cc9ff77062e59 (diff)
downloadports-377901b8047ae297af0f26755f2de5b3294e1a52.tar.gz
ports-377901b8047ae297af0f26755f2de5b3294e1a52.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/b2/Makefile2
-rw-r--r--devel/bear/Makefile2
-rw-r--r--devel/py-aniso8601/Makefile2
-rw-r--r--devel/py-apscheduler/Makefile2
-rw-r--r--devel/py-boto/Makefile2
-rw-r--r--devel/py-cliff/Makefile2
-rw-r--r--devel/py-diazo/Makefile2
-rw-r--r--devel/py-glob2/Makefile2
-rw-r--r--devel/py-keystoneauth1/Makefile2
-rw-r--r--devel/py-logfury/Makefile2
-rw-r--r--devel/py-phpserialize/Makefile2
-rw-r--r--devel/py-pyro/Makefile2
-rw-r--r--devel/py-pytest-timeout/Makefile2
-rw-r--r--devel/py-semantic_version/Makefile3
-rw-r--r--devel/py-serpent/Makefile2
-rw-r--r--devel/py-sourcemap/Makefile2
-rw-r--r--devel/py-validictory/Makefile2
-rw-r--r--devel/py-zc.buildout/Makefile2
18 files changed, 18 insertions, 19 deletions
diff --git a/devel/b2/Makefile b/devel/b2/Makefile
index 4d6542185bb7..b7539ad5a804 100644
--- a/devel/b2/Makefile
+++ b/devel/b2/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>=0.8.0:devel/py-arrow@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tqdm>=4.5.0:misc/py-tqdm@${FLAVOR}
-USES= python:2.7+
+USES= python
USE_PYTHON= distutils autoplist concurrent optsuffix
NO_ARCH= yes
diff --git a/devel/bear/Makefile b/devel/bear/Makefile
index 499ac9084711..77929332635e 100644
--- a/devel/bear/Makefile
+++ b/devel/bear/Makefile
@@ -15,7 +15,7 @@ USE_GITHUB= yes
GH_ACCOUNT= rizsotto
GH_PROJECT= Bear
-USES= cmake shebangfix python:2.7+
+USES= cmake shebangfix python
USE_LDCONFIG= yes
SHEBANG_FILES= bear/main.py.in
diff --git a/devel/py-aniso8601/Makefile b/devel/py-aniso8601/Makefile
index fea9a4ddfa82..e80d631335f3 100644
--- a/devel/py-aniso8601/Makefile
+++ b/devel/py-aniso8601/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${FLAVOR}
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-apscheduler/Makefile b/devel/py-apscheduler/Makefile
index 894c7e369278..dbf8d3344469 100644
--- a/devel/py-apscheduler/Makefile
+++ b/devel/py-apscheduler/Makefile
@@ -21,7 +21,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.5.1:devel/py-pytest@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-capturelog>=0.7:devel/py-pytest-capturelog@${FLAVOR}
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
TEST_ENV= ${MAKE_ENV} TZ=UTC
diff --git a/devel/py-boto/Makefile b/devel/py-boto/Makefile
index fec832f0cdbb..76110c5ee8bf 100644
--- a/devel/py-boto/Makefile
+++ b/devel/py-boto/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python interface to Amazon Web Services
LICENSE= MIT
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
CONFLICTS_INSTALL= p5-Net-Amazon-Route53-[0-9]*
diff --git a/devel/py-cliff/Makefile b/devel/py-cliff/Makefile
index e90a07dcb365..54217a7e1aa3 100644
--- a/devel/py-cliff/Makefile
+++ b/devel/py-cliff/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cmd2>=0.6.7:devel/py-cmd2@${FLAVOR} \
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-diazo/Makefile b/devel/py-diazo/Makefile
index 8f43856fccf8..aef17b0ba33f 100644
--- a/devel/py-diazo/Makefile
+++ b/devel/py-diazo/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webob>=0:www/py-webob@${FLAVOR}
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-glob2/Makefile b/devel/py-glob2/Makefile
index 01674839e3fd..00d720f44ba0 100644
--- a/devel/py-glob2/Makefile
+++ b/devel/py-glob2/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${FLAVOR}
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= distutils concurrent autoplist
do-test:
diff --git a/devel/py-keystoneauth1/Makefile b/devel/py-keystoneauth1/Makefile
index de23c85b2583..91e4b5cef8ed 100644
--- a/devel/py-keystoneauth1/Makefile
+++ b/devel/py-keystoneauth1/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}iso8601>=0.1.11:devel/py-iso8601@${FLAVOR} \
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-logfury/Makefile b/devel/py-logfury/Makefile
index cbf7e3927bfc..20eb8b999624 100644
--- a/devel/py-logfury/Makefile
+++ b/devel/py-logfury/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.10:devel/py-six@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}funcsigs>=1.0.2:devel/py-funcsigs@${FLAVOR}
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
diff --git a/devel/py-phpserialize/Makefile b/devel/py-phpserialize/Makefile
index d4c118e37bef..7f904e76aca5 100644
--- a/devel/py-phpserialize/Makefile
+++ b/devel/py-phpserialize/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= jnlin@freebsd.cs.nctu.edu.tw
COMMENT= Port of the serialize and unserialize functions of PHP to Python
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-pyro/Makefile b/devel/py-pyro/Makefile
index 29e7ecf5ef5d..b3b1af2f3505 100644
--- a/devel/py-pyro/Makefile
+++ b/devel/py-pyro/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}serpent>=1.23:devel/py-serpent@${FLAVOR}
NO_ARCH= yes
-USES= dos2unix python:2.7+
+USES= dos2unix python
USE_PYTHON= autoplist concurrent distutils
PORTDOCS= *
diff --git a/devel/py-pytest-timeout/Makefile b/devel/py-pytest-timeout/Makefile
index e06a87f64c23..145b82493e63 100644
--- a/devel/py-pytest-timeout/Makefile
+++ b/devel/py-pytest-timeout/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${FLAVOR}
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
TEST_ENV+= PYTHONPATH=${TEST_WRKSRC}
diff --git a/devel/py-semantic_version/Makefile b/devel/py-semantic_version/Makefile
index 4a4ec3bd4fb8..fd54809443f1 100644
--- a/devel/py-semantic_version/Makefile
+++ b/devel/py-semantic_version/Makefile
@@ -21,8 +21,7 @@ GH_PROJECT= python-semanticversion
NO_ARCH= yes
-# Actually 2.7,3.4+
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
do-test:
diff --git a/devel/py-serpent/Makefile b/devel/py-serpent/Makefile
index efa761a5b8e6..bc936c580d96 100644
--- a/devel/py-serpent/Makefile
+++ b/devel/py-serpent/Makefile
@@ -12,7 +12,7 @@ COMMENT= Simple serialization library based on ast.literal_eval
LICENSE= MIT
NO_ARCH= yes
-USES= dos2unix python:2.7+
+USES= dos2unix python
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/devel/py-sourcemap/Makefile b/devel/py-sourcemap/Makefile
index 4bc5c89e78b0..cad8d5b34d69 100644
--- a/devel/py-sourcemap/Makefile
+++ b/devel/py-sourcemap/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-validictory/Makefile b/devel/py-validictory/Makefile
index e5e91435bed8..66b8431c884e 100644
--- a/devel/py-validictory/Makefile
+++ b/devel/py-validictory/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/devel/py-zc.buildout/Makefile b/devel/py-zc.buildout/Makefile
index 707640e9d431..d9e829d09ddd 100644
--- a/devel/py-zc.buildout/Makefile
+++ b/devel/py-zc.buildout/Makefile
@@ -14,7 +14,7 @@ LICENSE= ZPL21
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
NO_ARCH= yes
-USES= python:2.7+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>