aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-03-15 11:29:21 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-03-15 11:29:21 +0000
commitac9b7fbf76f0919830005f25387fee08e329f031 (patch)
tree11884ec9cafca2b27aa02e6a5be21afee9199cbc /devel
parenta753ad4bf9636aeded79afb0541cdf8188e1ab67 (diff)
downloadports-ac9b7fbf76f0919830005f25387fee08e329f031.tar.gz
ports-ac9b7fbf76f0919830005f25387fee08e329f031.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cvsgraph/Makefile17
-rw-r--r--devel/cvsgraph/distinfo2
-rw-r--r--devel/cvsgraph/files/patch-configure.in28
-rw-r--r--devel/cvsgraph/pkg-descr3
4 files changed, 23 insertions, 27 deletions
diff --git a/devel/cvsgraph/Makefile b/devel/cvsgraph/Makefile
index 84c5cb347a6e..17687b0194a1 100644
--- a/devel/cvsgraph/Makefile
+++ b/devel/cvsgraph/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= cvsgraph
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.1
CATEGORIES= devel graphics
-MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/
+MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/release/
MAINTAINER= trevor@FreeBSD.org
@@ -17,15 +17,22 @@ LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= cvsgraph.1
+MAN5= cvsgraph.conf.5
+
ALL_TARGET= cvsgraph
DOCDIR= share/doc/${PORTNAME}
DOCS= ChangeLog LICENCE README
PLIST= ${WRKDIR}/pkg-plist
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gd=${LOCALBASE} \
+CONFIGURE_ARGS= --with-gd-inc=${LOCALBASE}/include/gd \
+ --with-gd-lib=${LOCALBASE}/lib \
--with-png=${LOCALBASE} \
- --with-z=/usr
+ --with-z-inc=/usr/include \
+ --with-z-lib=/usr/lib
post-configure:
${PERL} -pi -e \
@@ -46,6 +53,8 @@ pre-install:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/cvsgraph.conf ${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/cvsgraph.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/${DOCDIR}
.for i in ${DOCS}
diff --git a/devel/cvsgraph/distinfo b/devel/cvsgraph/distinfo
index 1812015431d2..6455d19e3fb7 100644
--- a/devel/cvsgraph/distinfo
+++ b/devel/cvsgraph/distinfo
@@ -1 +1 @@
-MD5 (cvsgraph-1.0.1.tar.gz) = 6e531971d73a8f9a9956079a315c8ebe
+MD5 (cvsgraph-1.1.1.tar.gz) = 616ca7209f3aebdb93ff3cac0b36574b
diff --git a/devel/cvsgraph/files/patch-configure.in b/devel/cvsgraph/files/patch-configure.in
index 607b749def2b..9a74fff55bb8 100644
--- a/devel/cvsgraph/files/patch-configure.in
+++ b/devel/cvsgraph/files/patch-configure.in
@@ -1,31 +1,17 @@
---- configure.in.orig Fri Feb 23 14:53:13 2001
-+++ configure.in Sat Feb 24 18:58:31 2001
-@@ -11,18 +11,18 @@
-
- dnl Extra libraries 'with'-options
- AC_ARG_WITH(gd,[ --with-gd=DIR location of the gd lib/inc],
-- [LDFLAGS="${LDFLAGS} -L${withval}"
-- CFLAGS="${CFLAGS} -I${withval}"
-+ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
-+ CFLAGS="${CFLAGS} -I${withval}/include/gd"
- ])
-
- AC_ARG_WITH(z,[ --with-z=DIR location of zlib lib/inc],
-- [LDFLAGS="${LDFLAGS} -L${withval}"
-- CFLAGS="${CFLAGS} -I${withval}"
-+ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
-+ CFLAGS="${CFLAGS} -I${withval}/include"
+--- configure.in.orig Sun Mar 4 10:24:10 2001
++++ configure.in Thu Mar 15 03:19:00 2001
+@@ -30,8 +30,8 @@
])
AC_ARG_WITH(png,[ --with-png=DIR location of png lib/inc],
-- [LDFLAGS="${LDFLAGS} -L${withval}"
+- [LDFLAGS="${LDFLAGS} -L${withval} -lpng"
- CFLAGS="${CFLAGS} -I${withval}"
-+ [LDFLAGS="${LDFLAGS} -L${withval}/lib"
++ [LDFLAGS="${LDFLAGS} -L${withval}/lib -lpng"
+ CFLAGS="${CFLAGS} -I${withval}/include"
])
- LDFLAGS="${LDFLAGS} -lgd"
-@@ -73,7 +73,7 @@
+ AC_ARG_ENABLE(speed,[ --disable-speed Turn off lex table optimization reducing speed and size of executable],
+@@ -90,7 +90,7 @@
dnl Make sure the header is here
AC_CHECK_HEADER( gd.h,[ have_gd_h="yes" ],[ have_gd_h="no" ])
diff --git a/devel/cvsgraph/pkg-descr b/devel/cvsgraph/pkg-descr
index 827b27ad5d0f..f703e2abc9ed 100644
--- a/devel/cvsgraph/pkg-descr
+++ b/devel/cvsgraph/pkg-descr
@@ -3,7 +3,8 @@ tags, and branching of a file in a CVS or RCS repository. Example:
cvsgraph -r /home/ncvs -m ports/devel/cvsgraph -o test.png pkg-descr,v
-It can also be used with cvsweb.
+It can also be used with cvsweb. A patch to cvsweb is available
+through the cvsgraph home page.
WWW: http://www.akhphd.au.dk/~bertho/cvsgraph/