aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-03-13 05:22:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-03-13 05:22:11 +0000
commit08e8044ef40a63892f980188a39e50895a2e8118 (patch)
treeefa06746c1e6283379f561339344808baf6d2037 /devel
parentaa15d1f6c303a27b5f6b09de9d63ec8ea5459de4 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/py-dbus/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
index cd00ac59552d..dc315374f031 100644
--- a/devel/py-dbus/Makefile
+++ b/devel/py-dbus/Makefile
@@ -14,9 +14,8 @@ COMMENT= Python bindings for the D-BUS messaging system
LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
-USES= gettext pathfix pkgconfig
+USES= gettext pathfix pkgconfig gmake
USE_PYTHON= 2
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${PYTHON_INCLUDEDIR}
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
@@ -28,7 +27,6 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS_DEFINE=HTMLDOCS
HTMLDOCS_DESC= build html documentation
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHTMLDOCS}
@@ -47,9 +45,7 @@ post-patch:
.endif
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR} && \
- ${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR} && \
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.py ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>