aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-09 11:55:30 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-09 11:55:30 +0000
commit1189e311aa09f31b3dcfb52877e1bd8896a3a569 (patch)
tree2fe74dcb5c6fba35070d9e982641f3de1384a582 /devel
parent6d99caa844edaa0f24d5fa872b23613c29b42721 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-AnyEvent-RPC/Makefile3
-rw-r--r--devel/p5-Class-C3-Adopt-NEXT/Makefile9
-rw-r--r--devel/p5-Class-Observable/Makefile9
-rw-r--r--devel/p5-Config-Fast/Makefile9
-rw-r--r--devel/p5-Devel-LeakGuard-Object/Makefile9
-rw-r--r--devel/p5-Devel-StackTrace-AsHTML/Makefile3
-rw-r--r--devel/p5-Exporter/Makefile3
-rw-r--r--devel/p5-File-DesktopEntry/Makefile3
-rw-r--r--devel/p5-Java/Makefile3
-rw-r--r--devel/p5-Log-Dispatch-Configurator-YAML/Makefile9
-rw-r--r--devel/p5-Module-Runtime/Makefile9
-rw-r--r--devel/p5-MouseX-Getopt/Makefile8
-rw-r--r--devel/p5-Path-Class-File-Lockable/Makefile9
-rw-r--r--devel/p5-Perl6-Form/Makefile9
-rw-r--r--devel/p5-Role-HasMessage/Makefile9
-rw-r--r--devel/p5-Stream-Reader/Makefile9
-rw-r--r--devel/p5-Sub-Exporter-GlobExporter/Makefile3
-rw-r--r--devel/p5-Test-Benchmark/Makefile9
-rw-r--r--devel/p5-Tie-Array-Pack/Makefile9
19 files changed, 50 insertions, 84 deletions
diff --git a/devel/p5-AnyEvent-RPC/Makefile b/devel/p5-AnyEvent-RPC/Makefile
index a6c8919c1042..db096101b821 100644
--- a/devel/p5-AnyEvent-RPC/Makefile
+++ b/devel/p5-AnyEvent-RPC/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-lib-abs>=0.90:${PORTSDIR}/devel/p5-lib-abs
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::RPC.3 AnyEvent::RPC::Enc::YAML.3 \
AnyEvent::RPC::Enc::REST.3
diff --git a/devel/p5-Class-C3-Adopt-NEXT/Makefile b/devel/p5-Class-C3-Adopt-NEXT/Makefile
index 0ab3ebcd9982..bbd6cfdf8012 100644
--- a/devel/p5-Class-C3-Adopt-NEXT/Makefile
+++ b/devel/p5-Class-C3-Adopt-NEXT/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-C3-Adopt-NEXT
-# Date created: 18 Jun 2009
-# Whom: Denis Pokataev <catone@cpan.org>
-#
+# Created by: Denis Pokataev <catone@cpan.org>
# $FreeBSD$
-#
PORTNAME= Class-C3-Adopt-NEXT
PORTVERSION= 0.13
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::C3::Adopt::NEXT.3
diff --git a/devel/p5-Class-Observable/Makefile b/devel/p5-Class-Observable/Makefile
index 6ccc5f241fcf..642be84cdafd 100644
--- a/devel/p5-Class-Observable/Makefile
+++ b/devel/p5-Class-Observable/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-Observable
-# Date created: 11 Aug 2004
-# Whom: Travis Campbell <hcoyote@ghostar.org>
-#
+# Created by: Travis Campbell <hcoyote@ghostar.org>
# $FreeBSD$
-#
PORTNAME= Class-Observable
PORTVERSION= 1.04
@@ -17,7 +13,8 @@ COMMENT= Allow other classes and objects to respond to events in yours
BUILD_DEPENDS= p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Observable.3
diff --git a/devel/p5-Config-Fast/Makefile b/devel/p5-Config-Fast/Makefile
index 2d41f99d0446..2a13b84f50d5 100644
--- a/devel/p5-Config-Fast/Makefile
+++ b/devel/p5-Config-Fast/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Config::Fast
-# Date created: 10 Feb 2004
-# Whom: Xavier Beaudouin <kiwi@oav.net>
-#
+# Created by: Xavier Beaudouin <kiwi@oav.net>
# $FreeBSD$
-#
PORTNAME= Config-Fast
PORTVERSION= 1.07
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kiwi@oav.net
COMMENT= Extremely fast configuration file parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::Fast.3
diff --git a/devel/p5-Devel-LeakGuard-Object/Makefile b/devel/p5-Devel-LeakGuard-Object/Makefile
index b36a40c1ee20..0d754a970713 100644
--- a/devel/p5-Devel-LeakGuard-Object/Makefile
+++ b/devel/p5-Devel-LeakGuard-Object/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Devel-LeakGuard-Object
-# Date created: 2009-07-19
-# Whom: TERAMOTO Masahiro <markun@onohara.to>
-#
+# Created by: TERAMOTO Masahiro <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= Devel-LeakGuard-Object
PORTVERSION= 0.06
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-latest>0:${PORTSDIR}/devel/p5-latest
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Devel::LeakGuard::Object.3 \
Devel::LeakGuard::Object::State.3
diff --git a/devel/p5-Devel-StackTrace-AsHTML/Makefile b/devel/p5-Devel-StackTrace-AsHTML/Makefile
index 08b908cad003..0837df1ff0c6 100644
--- a/devel/p5-Devel-StackTrace-AsHTML/Makefile
+++ b/devel/p5-Devel-StackTrace-AsHTML/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension to display stack trace in HTML
RUN_DEPENDS= p5-Devel-StackTrace>0:${PORTSDIR}/devel/p5-Devel-StackTrace
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::StackTrace::AsHTML.3
diff --git a/devel/p5-Exporter/Makefile b/devel/p5-Exporter/Makefile
index b53ecae9cae3..4bc9667896ad 100644
--- a/devel/p5-Exporter/Makefile
+++ b/devel/p5-Exporter/Makefile
@@ -13,7 +13,8 @@ COMMENT= Implements default import method for modules
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Exporter.3 Exporter::Heavy.3
diff --git a/devel/p5-File-DesktopEntry/Makefile b/devel/p5-File-DesktopEntry/Makefile
index e8adb12404e8..f23146a1315a 100644
--- a/devel/p5-File-DesktopEntry/Makefile
+++ b/devel/p5-File-DesktopEntry/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools \
p5-File-BaseDir>=0.03:${PORTSDIR}/devel/p5-File-BaseDir
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= File::DesktopEntry.3
diff --git a/devel/p5-Java/Makefile b/devel/p5-Java/Makefile
index e85cad3a6a0c..ac4279c15c9f 100644
--- a/devel/p5-Java/Makefile
+++ b/devel/p5-Java/Makefile
@@ -12,7 +12,8 @@ MAINTAINER= numisemis@yahoo.com
COMMENT= Perl extension for accessing a JVM remotely or locally
USE_RC_SUBR= javaserver
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/devel/p5-Log-Dispatch-Configurator-YAML/Makefile b/devel/p5-Log-Dispatch-Configurator-YAML/Makefile
index 16be9fc250a3..21aa9c699e30 100644
--- a/devel/p5-Log-Dispatch-Configurator-YAML/Makefile
+++ b/devel/p5-Log-Dispatch-Configurator-YAML/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Log-Dispatch-Configurator-YAML
-# Date created: 28 May 2008
-# Whom: Oleg Mamontov <oleg@mamontov.net>
-#
+# Created by: Oleg Mamontov <oleg@mamontov.net>
# $FreeBSD$
-#
PORTNAME= Log-Dispatch-Configurator-YAML
PORTVERSION= 0.03
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Log-Dispatch-Config>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Config
BUILD_DEPENDS= p5-Log-Dispatch-Config>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Config \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Dispatch::Configurator::YAML.3
diff --git a/devel/p5-Module-Runtime/Makefile b/devel/p5-Module-Runtime/Makefile
index e33264fd659b..80f5ca138d90 100644
--- a/devel/p5-Module-Runtime/Makefile
+++ b/devel/p5-Module-Runtime/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Module-Runtime
-# Date created: 01 Jun 2008
-# Whom: brix@FreeBSD.org
-#
+# Created by: brix@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= Module-Runtime
PORTVERSION= 0.013
@@ -17,7 +13,8 @@ COMMENT= Perl module for runtime module handling
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Module::Runtime.3
diff --git a/devel/p5-MouseX-Getopt/Makefile b/devel/p5-MouseX-Getopt/Makefile
index 3ace7c29c465..3595e338d65b 100644
--- a/devel/p5-MouseX-Getopt/Makefile
+++ b/devel/p5-MouseX-Getopt/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: MouseX::Getopt
-# Date created: 22 Jan 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= MouseX-Getopt
PORTVERSION= ${DISTVERSION}00
@@ -22,7 +17,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MouseX::Getopt.3 \
MouseX::Getopt::Basic.3 \
diff --git a/devel/p5-Path-Class-File-Lockable/Makefile b/devel/p5-Path-Class-File-Lockable/Makefile
index 5d87fc6b5fdb..aaf685f0e836 100644
--- a/devel/p5-Path-Class-File-Lockable/Makefile
+++ b/devel/p5-Path-Class-File-Lockable/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Path-Class-File-Lockable
-# Date created: 2012-01-22
-# Whom: Tatsuya Ueda <ml+freebsd@tatsuya.info>
-#
+# Created by: Tatsuya Ueda <ml+freebsd@tatsuya.info>
# $FreeBSD$
-#
PORTNAME= Path-Class-File-Lockable
PORTVERSION= 0.03
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-File-NFSLock>0:${PORTSDIR}/devel/p5-File-NFSLock \
p5-Path-Class>0:${PORTSDIR}/devel/p5-Path-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Path::Class::File::Lockable.3
diff --git a/devel/p5-Perl6-Form/Makefile b/devel/p5-Perl6-Form/Makefile
index 80069358e0d6..cb6ac189a96c 100644
--- a/devel/p5-Perl6-Form/Makefile
+++ b/devel/p5-Perl6-Form/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Perl6-Form
-# Date created: 21 Oct 2004
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
# $FreeBSD$
-#
PORTNAME= Perl6-Form
PORTVERSION= 0.04
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-Perl6-Export>=0:${PORTSDIR}/devel/p5-Perl6-Export \
p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Perl6::Form.3
diff --git a/devel/p5-Role-HasMessage/Makefile b/devel/p5-Role-HasMessage/Makefile
index 40e13e4b896c..01f80aa95732 100644
--- a/devel/p5-Role-HasMessage/Makefile
+++ b/devel/p5-Role-HasMessage/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Role-HasMessage
-# Date created: 2011-09-19
-# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
-#
+# Created by: Geraud CONTINSOUZAS <geraud@gcu.info>
# $FreeBSD$
-#
PORTNAME= Role-HasMessage
PORTVERSION= 0.005
@@ -25,7 +21,8 @@ RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Role::HasMessage.3 \
Role::HasMessage::Errf.3
diff --git a/devel/p5-Stream-Reader/Makefile b/devel/p5-Stream-Reader/Makefile
index d0f3e91608b4..db28b1d36055 100644
--- a/devel/p5-Stream-Reader/Makefile
+++ b/devel/p5-Stream-Reader/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Stream-Reader
-# Date created: 2009-08-12
-# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
-#
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Stream-Reader
PORTVERSION= 0.09
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl module for reading data from streams
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Stream::Reader.3
diff --git a/devel/p5-Sub-Exporter-GlobExporter/Makefile b/devel/p5-Sub-Exporter-GlobExporter/Makefile
index 28be18382ddb..ebcb5c5e101d 100644
--- a/devel/p5-Sub-Exporter-GlobExporter/Makefile
+++ b/devel/p5-Sub-Exporter-GlobExporter/Makefile
@@ -17,7 +17,8 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sub::Exporter::GlobExporter.3
diff --git a/devel/p5-Test-Benchmark/Makefile b/devel/p5-Test-Benchmark/Makefile
index 63d823245df8..d33c800b7a96 100644
--- a/devel/p5-Test-Benchmark/Makefile
+++ b/devel/p5-Test-Benchmark/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Benchmark
-# Date created: 2006-07-13
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Test-Benchmark
PORTVERSION= 0.004
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester \
p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Benchmark.3
diff --git a/devel/p5-Tie-Array-Pack/Makefile b/devel/p5-Tie-Array-Pack/Makefile
index b394bbbf2994..1255ae9e3a19 100644
--- a/devel/p5-Tie-Array-Pack/Makefile
+++ b/devel/p5-Tie-Array-Pack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-Array-Pack
-# Date created: 2006-12-22
-# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
-#
+# Created by: TAKAHASHI Kaoru <kaoru@kaisei.org>
# $FreeBSD$
-#
PORTNAME= Tie-Array-Pack
PORTVERSION= 0.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kaoru@kaisei.org
COMMENT= Array implemented as a packed string
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::Array::Pack.3