aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-12-16 05:20:17 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-12-16 05:20:17 +0000
commit6b4f8c76007cea7ffcf7d861acf6ce159679b881 (patch)
tree9ff809d1c6cf46423356fad967ee931aeef9e63e /devel
parentb7e651129edb25526f819997be100a20c8bf72fe (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/mspdebug/Makefile2
-rw-r--r--devel/mspdebug/distinfo4
-rw-r--r--devel/mspdebug/files/patch-Makefile20
3 files changed, 13 insertions, 13 deletions
diff --git a/devel/mspdebug/Makefile b/devel/mspdebug/Makefile
index ba31fd46f479..f8b69a65800d 100644
--- a/devel/mspdebug/Makefile
+++ b/devel/mspdebug/Makefile
@@ -7,7 +7,7 @@
# Based on the OpenBSD port by: Jasper Lievisse Adriaanse <jasper@openbsd.org>
PORTNAME= mspdebug
-PORTVERSION= 0.19
+PORTVERSION= 0.21
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}
diff --git a/devel/mspdebug/distinfo b/devel/mspdebug/distinfo
index 2c3a466bc80d..c487186a2879 100644
--- a/devel/mspdebug/distinfo
+++ b/devel/mspdebug/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mspdebug-0.19.tar.gz) = 0410ee3c30ae50d028bacee0fe27ec0d0b6cda3163cae51d02cda9aaa8814b6a
-SIZE (mspdebug-0.19.tar.gz) = 174126
+SHA256 (mspdebug-0.21.tar.gz) = 37c0c83851e1ff7048012c733e21cd2fe5bef21f67814a462c6a7049dc709988
+SIZE (mspdebug-0.21.tar.gz) = 228413
diff --git a/devel/mspdebug/files/patch-Makefile b/devel/mspdebug/files/patch-Makefile
index 766e4d4c7cb1..a67f609c01a3 100644
--- a/devel/mspdebug/files/patch-Makefile
+++ b/devel/mspdebug/files/patch-Makefile
@@ -1,16 +1,16 @@
---- Makefile.orig 2011-11-08 08:11:49.000000000 +1100
-+++ Makefile 2012-02-25 09:33:44.098219483 +1100
-@@ -43,8 +43,14 @@
- PORTS_CFLAGS = `pkg-config --cflags libusb`
- PORTS_LDFLAGS = `pkg-config --libs libusb` -ltermcap -pthread
+--- Makefile.orig 2012-11-26 10:27:48.000000000 +1100
++++ Makefile 2012-12-16 15:13:34.359453238 +1100
+@@ -45,8 +45,14 @@
+ PORTS_CFLAGS := $(shell pkg-config --cflags libusb)
+ PORTS_LDFLAGS := $(shell pkg-config --libs libusb) -ltermcap -pthread
else
-+ ifeq ($(UNAME),FreeBSD) # FreeBSD Ports stuff
++ ifeq ($(UNAME_S),FreeBSD) # FreeBSD Ports stuff
+# This is only needed prior to FreeBSD 8.x to find libusb
-+ PORTS_CFLAGS = -I${LOCALBASE}/include
-+ PORTS_LDFLAGS = -L${LOCALBASE}/lib
++ PORTS_CFLAGS := -I${LOCALBASE}/include
++ PORTS_LDFLAGS := -L${LOCALBASE}/lib
+ else
- PORTS_CFLAGS =
- PORTS_LDFLAGS =
+ PORTS_CFLAGS :=
+ PORTS_LDFLAGS :=
+ endif
endif
endif