aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-08-03 19:31:58 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-08-03 19:31:58 +0000
commit740cd7128760963b4243b633984aea3f88b3c052 (patch)
tree068e266c6d6030132117a731cfd6829fe30739a0 /devel
parent25236c5b5a9367fdf04b867b95affe40014223d0 (diff)
downloadports-740cd7128760963b4243b633984aea3f88b3c052.tar.gz
ports-740cd7128760963b4243b633984aea3f88b3c052.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Log-Dispatch/Makefile1
-rw-r--r--devel/p5-Log-Dispatch/scripts/configure.pl4
2 files changed, 4 insertions, 1 deletions
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index 59815291a45e..4f4ab5e3dd8d 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -33,6 +33,7 @@ MAN3= Log::Dispatch.3 \
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
SCRIPTS_ENV+= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ MKDIR="${MKDIR}" \
REALCURDIR="${.CURDIR}"
pre-fetch:
diff --git a/devel/p5-Log-Dispatch/scripts/configure.pl b/devel/p5-Log-Dispatch/scripts/configure.pl
index cdadc0aef39a..1ae566fac5a0 100644
--- a/devel/p5-Log-Dispatch/scripts/configure.pl
+++ b/devel/p5-Log-Dispatch/scripts/configure.pl
@@ -3,6 +3,7 @@ use strict;
unless (defined $ENV{WRKDIRPREFIX} and
defined $ENV{REALCURDIR} and
+ defined $ENV{MKDIR} and
defined $ENV{LOCALBASE})
{
die "this script should not be run like that!\n";
@@ -12,6 +13,7 @@ my $batch = $ENV{BATCH} || 0;
my $makedir = "$ENV{WRKDIRPREFIX}$ENV{REALCURDIR}";
my $makefile = "$makedir/Makefile.inc";
+my $mkdircmd = $ENV{MKDIR};
exit if -f $makefile;
my @modules = (
@@ -54,7 +56,7 @@ sub generate_makefile_inc
{
my @modules = @_;
- mkdir $makedir, 0777;
+ system("$mkdircmd $makedir");
open INC, "> $makefile" or die "open: $makefile: $!\n";
for my $m (@modules) {