aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-07-14 03:11:40 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-07-14 03:11:40 +0000
commitbf9cdcfc908c83b741173117b6e7c69374cbfdda (patch)
tree7f2eb1b7660df36625dd60e20849809e2165999d /devel
parentf18fb6790d2822649d261668433830caf072fa23 (diff)
downloadports-bf9cdcfc908c83b741173117b6e7c69374cbfdda.tar.gz
ports-bf9cdcfc908c83b741173117b6e7c69374cbfdda.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-trace/Makefile39
-rw-r--r--devel/pecl-trace/distinfo2
-rw-r--r--devel/pecl-trace/pkg-descr9
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 36fd50d4fe8d..07eef178e6ea 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3611,6 +3611,7 @@
SUBDIR += pecl-swoole
SUBDIR += pecl-sync
SUBDIR += pecl-test_helpers
+ SUBDIR += pecl-trace
SUBDIR += pecl-uopz
SUBDIR += pecl-uploadprogress
SUBDIR += pecl-uri_template
diff --git a/devel/pecl-trace/Makefile b/devel/pecl-trace/Makefile
new file mode 100644
index 000000000000..fa3a5e7565e6
--- /dev/null
+++ b/devel/pecl-trace/Makefile
@@ -0,0 +1,39 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= trace
+PORTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DIST_SUBDIR= PECL
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= Low-overhead tracing tool for PHP
+
+LICENSE= APACHE20
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/extension
+CMDTOOLSRC= ${WRKSRC}/../cmdtool
+
+GNU_CONFIGURE= yes
+USES= gmake shebangfix tar:tgz
+USE_PHP= yes
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+
+SHEBANG_FILES= ${CMDTOOLSRC}/phptrace
+PLIST_FILES= bin/phptrace \
+ bin/trace-php
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|Darwin|FreeBSD|g' ${CMDTOOLSRC}/phptrace
+
+post-build:
+ (cd ${CMDTOOLSRC} && ${GMAKE} ${MAKE_ENV})
+
+post-install:
+ ${INSTALL_PROGRAM} ${CMDTOOLSRC}/trace-php ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${CMDTOOLSRC}/phptrace ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-trace/distinfo b/devel/pecl-trace/distinfo
new file mode 100644
index 000000000000..318a31645c7f
--- /dev/null
+++ b/devel/pecl-trace/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/trace-0.3.0.tgz) = aa5f6a91a77ef11f4102b542847b32fce03ea7777081ebb86a812228526b38f7
+SIZE (PECL/trace-0.3.0.tgz) = 76354
diff --git a/devel/pecl-trace/pkg-descr b/devel/pecl-trace/pkg-descr
new file mode 100644
index 000000000000..870e9b0b7055
--- /dev/null
+++ b/devel/pecl-trace/pkg-descr
@@ -0,0 +1,9 @@
+Trace is a low-overhead tracing tool for PHP.
+
+It can trace all PHP execution, function calls, request information during
+run-time. And provides features like Filter, Statistics, Current Status and
+so on.
+It is very useful to locate blocking, heavy-load problems and debug in all
+environments, especially in production environments.
+
+WWW: https://pecl.php.net/package/trace