aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
commitdaffe00d4a57c0ef6a21947a8121b8d233d8d3a5 (patch)
tree713942325bda393305edb21d46cd7f38d213aebc /devel
parent51498efaebaad1106dcf0d3f70c8feaa14c411ee (diff)
downloadports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.tar.gz
ports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/bennugd-core/Makefile7
-rw-r--r--devel/bennugd-core/files/patch-bgdrtm-src-dirs.c20
-rw-r--r--devel/bennugd-core/files/patch-include-crypt.h16
-rw-r--r--devel/bennugd-modules/Makefile2
-rw-r--r--devel/bennugd-modules/files/patch-mod__map-file__png.c (renamed from devel/bennugd-modules/files/patch-mod_map-file_png.c)62
-rw-r--r--devel/bennugd-modules/files/patch-mod__mem-mod__mem.c (renamed from devel/bennugd-modules/files/patch-mod_mem-mod_mem.c)32
-rw-r--r--devel/hgview/Makefile10
-rw-r--r--devel/love/Makefile13
-rw-r--r--devel/love/files/patch-src-modules-graphics-opengl-GLee.h16
-rw-r--r--devel/love07/Makefile13
-rw-r--r--devel/love07/files/patch-src-modules-graphics-opengl-GLee.h16
-rw-r--r--devel/love5/Makefile7
-rw-r--r--devel/love5/files/patch-src-system-love__system.cpp (renamed from devel/love5/files/patch-src-system-love_system.cpp)16
-rw-r--r--devel/ois/Makefile8
-rw-r--r--devel/pire/pkg-descr2
15 files changed, 118 insertions, 122 deletions
diff --git a/devel/bennugd-core/Makefile b/devel/bennugd-core/Makefile
index 5bede4d7196c..4488fbf16a98 100644
--- a/devel/bennugd-core/Makefile
+++ b/devel/bennugd-core/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bennugd
-# Date created: 06 Nov 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= core
PORTVERSION= r20091106
@@ -20,6 +16,7 @@ MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/libexec"
SUB_FILES= bgdc bgdi
USE_LDCONFIG= yes
+USE_DOS2UNIX= *.c *.h
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Segfaults on !i386
diff --git a/devel/bennugd-core/files/patch-bgdrtm-src-dirs.c b/devel/bennugd-core/files/patch-bgdrtm-src-dirs.c
index 14db56ebe5cb..e854978f8db5 100644
--- a/devel/bennugd-core/files/patch-bgdrtm-src-dirs.c
+++ b/devel/bennugd-core/files/patch-bgdrtm-src-dirs.c
@@ -1,13 +1,13 @@
--- bgdrtm/src/dirs.c.orig 2009-07-09 05:10:52.000000000 +0400
+++ bgdrtm/src/dirs.c 2009-11-06 05:50:02.000000000 +0300
@@ -230,9 +230,7 @@
- /* Convert *.* to * */
- if ( fptr > path_final + 2 && fptr[ -1 ] == '*' && fptr[ -2 ] == '.' && fptr[ -3 ] == '*' ) fptr[ -2 ] = 0;
-
--#if defined(TARGET_MAC)
-- glob( path_final, GLOB_ERR | GLOB_NOSORT, NULL, &hDir->globd );
--#elif defined(TARGET_BEOS)
-+#if defined(TARGET_MAC) || defined(TARGET_BEOS) || defined(TARGET_BSD)
- glob( path_final, GLOB_ERR | GLOB_NOSORT, NULL, &hDir->globd );
- #else
- glob( path_final, GLOB_ERR | GLOB_PERIOD | GLOB_NOSORT, NULL, &hDir->globd );
+ /* Convert *.* to * */
+ if ( fptr > path_final + 2 && fptr[ -1 ] == '*' && fptr[ -2 ] == '.' && fptr[ -3 ] == '*' ) fptr[ -2 ] = 0;
+
+-#if defined(TARGET_MAC)
+- glob( path_final, GLOB_ERR | GLOB_NOSORT, NULL, &hDir->globd );
+-#elif defined(TARGET_BEOS)
++#if defined(TARGET_MAC) || defined(TARGET_BEOS) || defined(TARGET_BSD)
+ glob( path_final, GLOB_ERR | GLOB_NOSORT, NULL, &hDir->globd );
+ #else
+ glob( path_final, GLOB_ERR | GLOB_PERIOD | GLOB_NOSORT, NULL, &hDir->globd );
diff --git a/devel/bennugd-core/files/patch-include-crypt.h b/devel/bennugd-core/files/patch-include-crypt.h
index 3939740a1dbb..6fe26ba12225 100644
--- a/devel/bennugd-core/files/patch-include-crypt.h
+++ b/devel/bennugd-core/files/patch-include-crypt.h
@@ -1,11 +1,11 @@
--- include/crypt.h.orig 2009-07-02 04:20:53.000000000 +0400
+++ include/crypt.h 2009-11-06 05:52:32.000000000 +0300
@@ -24,7 +24,7 @@
-
- /* ------------------------------------------------------------------------- */
-
--#include <des.h>
-+#include <openssl/des.h>
-
- /* ------------------------------------------------------------------------- */
-
+
+ /* ------------------------------------------------------------------------- */
+
+-#include <des.h>
++#include <openssl/des.h>
+
+ /* ------------------------------------------------------------------------- */
+
diff --git a/devel/bennugd-modules/Makefile b/devel/bennugd-modules/Makefile
index 310a7d34b081..c9f6f3851999 100644
--- a/devel/bennugd-modules/Makefile
+++ b/devel/bennugd-modules/Makefile
@@ -27,6 +27,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/bennugd"
MAKE_JOBS_SAFE= yes
+USE_DOS2UNIX= *.c
+
WRKSRC= ${WRKDIR}/bennugd/${PORTNAME}
post-extract:
diff --git a/devel/bennugd-modules/files/patch-mod_map-file_png.c b/devel/bennugd-modules/files/patch-mod__map-file__png.c
index 5479d7cbdd10..26e44948b742 100644
--- a/devel/bennugd-modules/files/patch-mod_map-file_png.c
+++ b/devel/bennugd-modules/files/patch-mod__map-file__png.c
@@ -1,37 +1,37 @@
--- mod_map/file_png.c.orig 2009-07-22 04:02:45.000000000 +0200
+++ mod_map/file_png.c 2012-05-27 11:54:18.000000000 +0200
@@ -24,6 +24,7 @@
- /* --------------------------------------------------------------------------- */
-
- #include <png.h>
-+#include <pngpriv.h>
-
- #include "mod_map.h"
-
+ /* --------------------------------------------------------------------------- */
+
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "mod_map.h"
+
@@ -89,7 +90,7 @@
-
- /* Rutina de error */
-
-- if ( setjmp( png_ptr->jmpbuf ) )
-+ if ( setjmp( png_jmpbuf(png_ptr) ) )
- {
- png_destroy_read_struct( &png_ptr, &info_ptr, &end_info ) ;
- file_close( png ) ;
+
+ /* Rutina de error */
+
+- if ( setjmp( png_ptr->jmpbuf ) )
++ if ( setjmp( png_jmpbuf(png_ptr) ) )
+ {
+ png_destroy_read_struct( &png_ptr, &info_ptr, &end_info ) ;
+ file_close( png ) ;
@@ -286,7 +287,7 @@
-
- /* Fin */
-
-- if ( !setjmp( png_ptr->jmpbuf ) ) png_read_end( png_ptr, 0 ) ;
-+ if ( !setjmp( png_jmpbuf(png_ptr) ) ) png_read_end( png_ptr, 0 ) ;
-
- bitmap->modified = 1 ;
-
+
+ /* Fin */
+
+- if ( !setjmp( png_ptr->jmpbuf ) ) png_read_end( png_ptr, 0 ) ;
++ if ( !setjmp( png_jmpbuf(png_ptr) ) ) png_read_end( png_ptr, 0 ) ;
+
+ bitmap->modified = 1 ;
+
@@ -356,7 +357,7 @@
-
- /* Error handling... */
-
-- if ( setjmp( png_ptr->jmpbuf ) )
-+ if ( setjmp( png_jmpbuf(png_ptr) ) )
- {
- png_destroy_write_struct( &png_ptr, NULL ) ;
- free( rowpointers ) ;
+
+ /* Error handling... */
+
+- if ( setjmp( png_ptr->jmpbuf ) )
++ if ( setjmp( png_jmpbuf(png_ptr) ) )
+ {
+ png_destroy_write_struct( &png_ptr, NULL ) ;
+ free( rowpointers ) ;
diff --git a/devel/bennugd-modules/files/patch-mod_mem-mod_mem.c b/devel/bennugd-modules/files/patch-mod__mem-mod__mem.c
index bd50f146a618..b94bdc5842f8 100644
--- a/devel/bennugd-modules/files/patch-mod_mem-mod_mem.c
+++ b/devel/bennugd-modules/files/patch-mod__mem-mod__mem.c
@@ -1,20 +1,20 @@
--- mod_mem/mod_mem.c.orig 2009-06-15 22:34:24.000000000 +0400
+++ mod_mem/mod_mem.c 2009-11-06 06:28:55.000000000 +0300
@@ -128,7 +128,7 @@
- get_system_info( &info );
- return B_PAGE_SIZE * ( info.max_pages - info.used_pages );
-
--#elif !defined(TARGET_MAC)
-+#elif !defined(TARGET_MAC) && !defined(TARGET_BSD)
- /* Linux and other Unix (?) */
- struct sysinfo meminf;
- int fv;
+ get_system_info( &info );
+ return B_PAGE_SIZE * ( info.max_pages - info.used_pages );
+
+-#elif !defined(TARGET_MAC)
++#elif !defined(TARGET_MAC) && !defined(TARGET_BSD)
+ /* Linux and other Unix (?) */
+ struct sysinfo meminf;
+ int fv;
@@ -166,7 +166,7 @@
- get_system_info( &info );
- return B_PAGE_SIZE * ( info.max_pages );
-
--#elif !defined(TARGET_MAC)
-+#elif !defined(TARGET_MAC) && !defined(TARGET_BSD)
- /* Linux and other Unix (?) */
- struct sysinfo meminf;
- int fv;
+ get_system_info( &info );
+ return B_PAGE_SIZE * ( info.max_pages );
+
+-#elif !defined(TARGET_MAC)
++#elif !defined(TARGET_MAC) && !defined(TARGET_BSD)
+ /* Linux and other Unix (?) */
+ struct sysinfo meminf;
+ int fv;
diff --git a/devel/hgview/Makefile b/devel/hgview/Makefile
index 92ba05103cda..33163eeee5ba 100644
--- a/devel/hgview/Makefile
+++ b/devel/hgview/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hgview
-# Date created: 20 Nov 2008
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= hgview
PORTVERSION= 1.6.2
@@ -31,6 +27,8 @@ PORTDOCS= *
MAN1= hgview.1
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|share/python-support/mercurial-common|${PYTHON_SITELIBDIR:C,^${PYTHONBASE}/,,}|' \
${WRKSRC}/hgviewlib/__pkginfo__.py
@@ -40,8 +38,8 @@ post-patch:
${WRKSRC}/README
@${REINPLACE_CMD} -e 's|'make'|'${GMAKE}'|' ${WRKSRC}/setup.py
-.if !defined(NOPORTDOCS)
post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/devel/love/Makefile b/devel/love/Makefile
index a6610eb35ffd..94b31e14fced 100644
--- a/devel/love/Makefile
+++ b/devel/love/Makefile
@@ -12,12 +12,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
-LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
- modplug.1:${PORTSDIR}/audio/libmodplug \
- mpg123.0:${PORTSDIR}/audio/mpg123 \
- vorbisfile.6:${PORTSDIR}/audio/libvorbis \
- physfs.1:${PORTSDIR}/devel/physfs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= IL:${PORTSDIR}/graphics/devil \
+ modplug:${PORTSDIR}/audio/libmodplug \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ vorbisfile:${PORTSDIR}/audio/libvorbis \
+ physfs:${PORTSDIR}/devel/physfs \
+ freetype:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_GMAKE= yes
@@ -31,6 +31,7 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib
WRKSRC= ${WRKDIR}/love-${PORTVERSION}
+USE_DOS2UNIX= yes
PLIST_FILES= bin/love
diff --git a/devel/love/files/patch-src-modules-graphics-opengl-GLee.h b/devel/love/files/patch-src-modules-graphics-opengl-GLee.h
index ee29f8c1c064..fb28b6582ebe 100644
--- a/devel/love/files/patch-src-modules-graphics-opengl-GLee.h
+++ b/devel/love/files/patch-src-modules-graphics-opengl-GLee.h
@@ -1,11 +1,11 @@
--- src/modules/graphics/opengl/GLee.h.orig 2011-05-04 20:00:10.000000000 +0400
+++ src/modules/graphics/opengl/GLee.h 2011-09-20 00:16:46.000000000 +0400
@@ -799,8 +799,6 @@
-
- /* GLX */
-
-- typedef void (*__GLXextFuncPtr)(void);
--
- #ifndef GLX_ARB_get_proc_address
- #define GLX_ARB_get_proc_address 1
- extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);
+
+ /* GLX */
+
+- typedef void (*__GLXextFuncPtr)(void);
+-
+ #ifndef GLX_ARB_get_proc_address
+ #define GLX_ARB_get_proc_address 1
+ extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);
diff --git a/devel/love07/Makefile b/devel/love07/Makefile
index 2d77f1bbeff2..c6c0f115baa0 100644
--- a/devel/love07/Makefile
+++ b/devel/love07/Makefile
@@ -12,12 +12,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
-LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
- modplug.1:${PORTSDIR}/audio/libmodplug \
- mpg123.0:${PORTSDIR}/audio/mpg123 \
- vorbisfile.6:${PORTSDIR}/audio/libvorbis \
- physfs.1:${PORTSDIR}/devel/physfs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= IL:${PORTSDIR}/graphics/devil \
+ modplug:${PORTSDIR}/audio/libmodplug \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ vorbisfile:${PORTSDIR}/audio/libvorbis \
+ physfs:${PORTSDIR}/devel/physfs \
+ freetype:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LATEST_LINK= ${PORTNAME}07
@@ -36,6 +36,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=07
WRKSRC= ${WRKDIR}/love-HEAD
+USE_DOS2UNIX= yes
PLIST_FILES= bin/love07
diff --git a/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h b/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h
index ee29f8c1c064..fb28b6582ebe 100644
--- a/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h
+++ b/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h
@@ -1,11 +1,11 @@
--- src/modules/graphics/opengl/GLee.h.orig 2011-05-04 20:00:10.000000000 +0400
+++ src/modules/graphics/opengl/GLee.h 2011-09-20 00:16:46.000000000 +0400
@@ -799,8 +799,6 @@
-
- /* GLX */
-
-- typedef void (*__GLXextFuncPtr)(void);
--
- #ifndef GLX_ARB_get_proc_address
- #define GLX_ARB_get_proc_address 1
- extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);
+
+ /* GLX */
+
+- typedef void (*__GLXextFuncPtr)(void);
+-
+ #ifndef GLX_ARB_get_proc_address
+ #define GLX_ARB_get_proc_address 1
+ extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);
diff --git a/devel/love5/Makefile b/devel/love5/Makefile
index 156f42e8d23c..83f234660fe3 100644
--- a/devel/love5/Makefile
+++ b/devel/love5/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
-LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
- physfs.1:${PORTSDIR}/devel/physfs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= IL:${PORTSDIR}/graphics/devil \
+ physfs:${PORTSDIR}/devel/physfs \
+ freetype:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LATEST_LINK= love5
@@ -27,6 +27,7 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=5
+USE_DOS2UNIX= yes
PLIST_FILES= bin/love5
diff --git a/devel/love5/files/patch-src-system-love_system.cpp b/devel/love5/files/patch-src-system-love__system.cpp
index d6ff173d2b9a..96db20088020 100644
--- a/devel/love5/files/patch-src-system-love_system.cpp
+++ b/devel/love5/files/patch-src-system-love__system.cpp
@@ -1,11 +1,11 @@
--- src/system/love_system.cpp.orig 2008-09-20 18:40:14.000000000 +0400
+++ src/system/love_system.cpp 2011-09-27 07:49:03.000000000 +0400
@@ -83,7 +83,7 @@
- #ifdef WIN32
- bool embedded = (leaf.compare("love.exe") != 0);
- #else
-- bool embedded = (leaf.compare("love") != 0);
-+ bool embedded = (leaf.compare("love5") != 0);
- #endif
-
- std::string base;
+ #ifdef WIN32
+ bool embedded = (leaf.compare("love.exe") != 0);
+ #else
+- bool embedded = (leaf.compare("love") != 0);
++ bool embedded = (leaf.compare("love5") != 0);
+ #endif
+
+ std::string base;
diff --git a/devel/ois/Makefile b/devel/ois/Makefile
index f73071584b33..14f059841bd3 100644
--- a/devel/ois/Makefile
+++ b/devel/ois/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ois
-# Date created: 16 Jun 2008
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= ois
PORTVERSION= 1.2.0
@@ -17,7 +13,7 @@ COMMENT= Object Oriented Input System
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix
USE_AUTOTOOLS= libtool:env aclocal:env autoheader:env automake:env autoconf:env
USE_XORG= x11 xaw
USE_LDCONFIG= yes
diff --git a/devel/pire/pkg-descr b/devel/pire/pkg-descr
index f2c180551546..32f13d4582f3 100644
--- a/devel/pire/pkg-descr
+++ b/devel/pire/pkg-descr
@@ -20,4 +20,4 @@ neither has it any capturing facilities.
Pire was developed in Yandex (http://company.yandex.ru/) as a part
of its web crawler.
-WWW: https://github.com/dprokoptsev/pire
+WWW: https://github.com/dprokoptsev/pire