aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-11 13:25:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-11 13:25:11 +0000
commit11f3b681ba46c10f4b68351641208296b04f8462 (patch)
tree683ee7ac30ae9580216074d450619cc5541d4983 /devel
parentf86db7b16949219e8d4990e886aa7e7dbc273d2a (diff)
downloadports-11f3b681ba46c10f4b68351641208296b04f8462.tar.gz
ports-11f3b681ba46c10f4b68351641208296b04f8462.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/otrs/Makefile3
-rw-r--r--devel/otrs/distinfo6
-rw-r--r--devel/otrs/files/patch-bin-SetPermissions.sh15
-rw-r--r--devel/otrs/files/pkg-install.in6
-rw-r--r--devel/otrs/pkg-plist2
5 files changed, 10 insertions, 22 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 8e0850e7e765..76d686fc0062 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= otrs
-PORTVERSION= 2.1.3
-PORTREVISION= 1
+PORTVERSION= 2.1.6
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
diff --git a/devel/otrs/distinfo b/devel/otrs/distinfo
index e479412d68d1..53771f0d4b30 100644
--- a/devel/otrs/distinfo
+++ b/devel/otrs/distinfo
@@ -1,3 +1,3 @@
-MD5 (otrs-2.1.3.tar.gz) = 669b48aff1d9609520875cdc955e2101
-SHA256 (otrs-2.1.3.tar.gz) = 296fd91f78adce211c3524c873b07bfa42b7aaef825448a2e98c7fb81bc5beda
-SIZE (otrs-2.1.3.tar.gz) = 13003457
+MD5 (otrs-2.1.6.tar.gz) = eaa4e097c7bbcb47e834841456c2f778
+SHA256 (otrs-2.1.6.tar.gz) = bc87c91813cf8f5b1b61abfdcde3714ed1ee2229b30a44419345b7113d06db1f
+SIZE (otrs-2.1.6.tar.gz) = 13088325
diff --git a/devel/otrs/files/patch-bin-SetPermissions.sh b/devel/otrs/files/patch-bin-SetPermissions.sh
deleted file mode 100644
index 5c895665b3bd..000000000000
--- a/devel/otrs/files/patch-bin-SetPermissions.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- bin/SetPermissions.sh.orig Fri Jul 21 21:03:43 2006
-+++ bin/SetPermissions.sh Fri Jul 21 21:07:02 2006
-@@ -55,9 +55,10 @@
- echo "chown -R $WEBUSER:$OTRSGROUP $OTRSDEST"
- chown $WEBUSER:$OTRSGROUP $OTRSDEST
- chown -R $WEBUSER:$OTRSGROUP $OTRSDEST
--echo "chmod -R og+rw $OTRSDEST"
--chmod ug+wr $OTRSDEST
-+echo "chmod -R og+rw $OTRSDEST/*"
- chmod -R ug+wr $OTRSDEST
-+# procmail does not like the home directory to be group writeable
-+chmod g-w $OTRSDEST
-
- # set the $HOME to the OTRS user
- echo "chown $OTRSUSER:$OTRSGROUP $OTRSDEST"
diff --git a/devel/otrs/files/pkg-install.in b/devel/otrs/files/pkg-install.in
index 37c6b84c94f6..f34a72a5016c 100644
--- a/devel/otrs/files/pkg-install.in
+++ b/devel/otrs/files/pkg-install.in
@@ -7,12 +7,14 @@ WWWOWN="www"
WWWGRP="www"
OTRS_USER="otrs"
OTRS_GROUP="otrs"
+OTRS_UID=121
+OTRS_GID=121
case $2 in
PRE-INSTALL)
if ! pw groupshow -n ${OTRS_GROUP} >/dev/null 2>&1; then
- if pw groupadd -n ${OTRS_GROUP}; then
+ if pw groupadd -n ${OTRS_GROUP} -g ${OTRS_GID}; then
echo "Added group \"${OTRS_GROUP}\"."
else
echo "Adding group \"${OTRS_GROUP}\" failed..."
@@ -22,7 +24,7 @@ PRE-INSTALL)
if ! id -u ${OTRS_USER} >/dev/null 2>&1; then
if pw useradd -n ${OTRS_USER} -g ${OTRS_GROUP} \
- -G ${WWWGRP} -h - -s /bin/csh \
+ -u ${OTRS_UID} -G ${WWWGRP} -h - -s /bin/csh \
-d ${PKG_PREFIX}/otrs -c "OTRS Administrator" ; then
echo "Added user \"${OTRS_USER}\"."
else
diff --git a/devel/otrs/pkg-plist b/devel/otrs/pkg-plist
index 535adfd7cf97..fb3a06e30272 100644
--- a/devel/otrs/pkg-plist
+++ b/devel/otrs/pkg-plist
@@ -16,6 +16,7 @@ otrs/bin/PostMasterDaemon.pl
otrs/bin/PostMasterPOP3.pl
otrs/bin/RebuildTicketIndex.pl
otrs/bin/SetPermissions.sh
+otrs/bin/StatsExportToOPM.pl
otrs/bin/UnlockTickets.pl
otrs/bin/XMLMaster.pl
otrs/bin/mkStats.pl
@@ -587,6 +588,7 @@ otrs/Kernel/System/Ticket/Number/DateChecksum.pm
otrs/Kernel/System/Ticket/Number/Random.pm
otrs/Kernel/System/Ticket/Permission/GroupCheck.pm
otrs/Kernel/System/Ticket/Permission/OwnerCheck.pm
+otrs/Kernel/System/Ticket/Permission/ResponsibleCheck.pm
otrs/Kernel/System/User/Preferences/DB.pm
otrs/Kernel/System/Web/InterfaceAgent.pm
otrs/Kernel/System/Web/InterfaceCustomer.pm