aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-03 19:28:52 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-03 19:28:52 +0000
commit203a0a7d3a64075e41ca3abd6049822b214eab62 (patch)
tree77c840cc8ea773f3324e7a4ef2b9b104a8667963 /devel
parentae31495e8a108d3babda596ef9bceeaebffeb91e (diff)
downloadports-203a0a7d3a64075e41ca3abd6049822b214eab62.tar.gz
ports-203a0a7d3a64075e41ca3abd6049822b214eab62.zip
MFH: r507639
devel/py-llfuse: Fix build (warning=error), remove -Werror -Werror is added to flags by default, breaking build for example with GCC. Follow upstream and remove it. Also disable DEVELOPER_MODE since it's enabled too widely. PR: 238887 Approved by: portmgr (blanket(s): build fix, ports compliance), linimon (mentor) Differential Revision: https://reviews.freebsd.org/D21067
Notes
Notes: svn path=/branches/2019Q3/; revision=507990
Diffstat (limited to 'devel')
-rw-r--r--devel/py-llfuse/Makefile2
-rw-r--r--devel/py-llfuse/files/files/patch-setup.py36
-rw-r--r--devel/py-llfuse/files/patch-setup.py36
3 files changed, 72 insertions, 2 deletions
diff --git a/devel/py-llfuse/Makefile b/devel/py-llfuse/Makefile
index 1def5ebd4521..42ed67eb2aaf 100644
--- a/devel/py-llfuse/Makefile
+++ b/devel/py-llfuse/Makefile
@@ -12,8 +12,6 @@ COMMENT= Python bindings for low-level FUSE API
LICENSE= LGPL20+
-BROKEN_powerpc64= Does not build: error: conversion to mode_t from int may alter its value
-
USES= compiler:c++11-lang fuse pkgconfig python tar:bz2
USE_PYTHON= autoplist distutils
diff --git a/devel/py-llfuse/files/files/patch-setup.py b/devel/py-llfuse/files/files/patch-setup.py
new file mode 100644
index 000000000000..e2b4838bc4ae
--- /dev/null
+++ b/devel/py-llfuse/files/files/patch-setup.py
@@ -0,0 +1,36 @@
+--- setup.py.orig 2017-01-22 22:24:10 UTC
++++ setup.py
+@@ -80,24 +80,24 @@ def main():
+ # We may have unused functions if we compile for older FUSE versions
+ compile_args.append('-Wno-unused-function')
+
+- # Value-changing conversions should always be explicit.
+- compile_args.append('-Werror=conversion')
+-
+- # Note that (i > -1) is false if i is unsigned (-1 will be converted to
+- # a large positive value). We certainly don't want to do this by
+- # accident.
+- compile_args.append('-Werror=sign-compare')
+-
+ # Enable all fatal warnings only when compiling from Mercurial tip.
+ # (otherwise we break forward compatibility because compilation with newer
+ # compiler may fail if additional warnings are added)
+- if DEVELOPER_MODE:
++ if 0:
+ compile_args.append('-Werror')
+ compile_args.append('-Wfatal-errors')
+
+ # Unreachable code is expected because we need to support multiple
+ # platforms and architectures.
+ compile_args.append('-Wno-error=unreachable-code')
++
++ # Value-changing conversions should always be explicit.
++ compile_args.append('-Werror=conversion')
++
++ # Note that (i > -1) is false if i is unsigned (-1 will be converted to
++ # a large positive value). We certainly don't want to do this by
++ # accident.
++ compile_args.append('-Werror=sign-compare')
+
+ # http://bugs.python.org/issue7576
+ if sys.version_info[0] == 3 and sys.version_info[1] < 2:
diff --git a/devel/py-llfuse/files/patch-setup.py b/devel/py-llfuse/files/patch-setup.py
new file mode 100644
index 000000000000..e2b4838bc4ae
--- /dev/null
+++ b/devel/py-llfuse/files/patch-setup.py
@@ -0,0 +1,36 @@
+--- setup.py.orig 2017-01-22 22:24:10 UTC
++++ setup.py
+@@ -80,24 +80,24 @@ def main():
+ # We may have unused functions if we compile for older FUSE versions
+ compile_args.append('-Wno-unused-function')
+
+- # Value-changing conversions should always be explicit.
+- compile_args.append('-Werror=conversion')
+-
+- # Note that (i > -1) is false if i is unsigned (-1 will be converted to
+- # a large positive value). We certainly don't want to do this by
+- # accident.
+- compile_args.append('-Werror=sign-compare')
+-
+ # Enable all fatal warnings only when compiling from Mercurial tip.
+ # (otherwise we break forward compatibility because compilation with newer
+ # compiler may fail if additional warnings are added)
+- if DEVELOPER_MODE:
++ if 0:
+ compile_args.append('-Werror')
+ compile_args.append('-Wfatal-errors')
+
+ # Unreachable code is expected because we need to support multiple
+ # platforms and architectures.
+ compile_args.append('-Wno-error=unreachable-code')
++
++ # Value-changing conversions should always be explicit.
++ compile_args.append('-Werror=conversion')
++
++ # Note that (i > -1) is false if i is unsigned (-1 will be converted to
++ # a large positive value). We certainly don't want to do this by
++ # accident.
++ compile_args.append('-Werror=sign-compare')
+
+ # http://bugs.python.org/issue7576
+ if sys.version_info[0] == 3 and sys.version_info[1] < 2: