aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-01-18 04:01:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-01-18 04:01:24 +0000
commit2cd6161419576e97c766dd2e23764716151e72db (patch)
treeda5620ed73897aa31c6e02af4c9f7073b57b82f6 /devel
parent6d0bed2564320e61e5f446240d04c7b5024051b9 (diff)
downloadports-2cd6161419576e97c766dd2e23764716151e72db.tar.gz
ports-2cd6161419576e97c766dd2e23764716151e72db.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cmake/Makefile2
-rw-r--r--devel/cmake/files/patch-Modules_FindBoost.cmake12
2 files changed, 13 insertions, 1 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index 15f9c16c0be3..8977dc5dba2f 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -4,7 +4,7 @@
PORTNAME= cmake
# Remember to update devel/cmake-doc and devel/cmake-gui as well.
DISTVERSION= 3.10.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
diff --git a/devel/cmake/files/patch-Modules_FindBoost.cmake b/devel/cmake/files/patch-Modules_FindBoost.cmake
new file mode 100644
index 000000000000..074dad0895f1
--- /dev/null
+++ b/devel/cmake/files/patch-Modules_FindBoost.cmake
@@ -0,0 +1,12 @@
+Allow imported targets, even with newer Boost.
+
+--- Modules/FindBoost.cmake.orig 2017-12-13 13:25:23 UTC
++++ Modules/FindBoost.cmake
+@@ -799,7 +799,6 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
+ endif()
+ if(NOT Boost_VERSION VERSION_LESS 106600)
+ message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
+- set(_Boost_IMPORTED_TARGETS FALSE)
+ endif()
+ endif()
+