aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /devel
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/bonobo-conf/Makefile2
-rw-r--r--devel/bonobo/Makefile2
-rw-r--r--devel/bug-buddy/Makefile2
-rw-r--r--devel/bugbuddy/Makefile2
-rw-r--r--devel/bugbuddy2/Makefile2
-rw-r--r--devel/cervisia/Makefile7
-rw-r--r--devel/commoncpp/Makefile2
-rw-r--r--devel/dmalloc/Makefile2
-rw-r--r--devel/dryad/Makefile2
-rw-r--r--devel/gconf/Makefile2
-rw-r--r--devel/gconf2/Makefile2
-rw-r--r--devel/gide/Makefile2
-rw-r--r--devel/glade/Makefile2
-rw-r--r--devel/glade2/Makefile2
-rw-r--r--devel/gnome-crash/Makefile2
-rw-r--r--devel/gnome-vfs/Makefile2
-rw-r--r--devel/gnome-vfs1/Makefile2
-rw-r--r--devel/gnomecrash/Makefile2
-rw-r--r--devel/gnomedebug/Makefile2
-rw-r--r--devel/gnomevfs/Makefile2
-rw-r--r--devel/gnomevfs2/Makefile2
-rw-r--r--devel/gtranslator/Makefile2
-rw-r--r--devel/libgii/Makefile2
-rw-r--r--devel/libgtop/Makefile2
-rw-r--r--devel/libgtop2/Makefile2
-rw-r--r--devel/oaf/Makefile2
-rw-r--r--devel/pharmacy/Makefile2
-rw-r--r--devel/sdl-devel/Makefile2
-rw-r--r--devel/sdl/Makefile2
-rw-r--r--devel/sdl10/Makefile2
-rw-r--r--devel/sdl12/Makefile2
-rw-r--r--devel/titano/Makefile2
-rw-r--r--devel/veepee/Makefile4
33 files changed, 33 insertions, 40 deletions
diff --git a/devel/bonobo-conf/Makefile b/devel/bonobo-conf/Makefile
index 7562e119ef0c..42c3a2e22e40 100644
--- a/devel/bonobo-conf/Makefile
+++ b/devel/bonobo-conf/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/bonobo/Makefile b/devel/bonobo/Makefile
index 33701d026699..10e4f37e1873 100644
--- a/devel/bonobo/Makefile
+++ b/devel/bonobo/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/bug-buddy/Makefile b/devel/bug-buddy/Makefile
index 81d07e839120..ce11bef4d952 100644
--- a/devel/bug-buddy/Makefile
+++ b/devel/bug-buddy/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/bugbuddy/Makefile b/devel/bugbuddy/Makefile
index 81d07e839120..ce11bef4d952 100644
--- a/devel/bugbuddy/Makefile
+++ b/devel/bugbuddy/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/bugbuddy2/Makefile b/devel/bugbuddy2/Makefile
index 81d07e839120..ce11bef4d952 100644
--- a/devel/bugbuddy2/Makefile
+++ b/devel/bugbuddy2/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/cervisia/Makefile b/devel/cervisia/Makefile
index 60b31275ad30..261579380799 100644
--- a/devel/cervisia/Makefile
+++ b/devel/cervisia/Makefile
@@ -46,13 +46,6 @@ KDE_VERSION?= 2
.if exists(${X11BASE}/lib/libqt2-mt.so)
.if exists(${X11BASE}/lib/libXThrStub.so)
QT_ADD= -mt
-.if ${OSVERSION} >= 500016
-PTHREAD_CFLAGS=
-PTHREAD_LIBS= -lc_r
-.else
-PTHREAD_CFLAGS= -D_THREAD_SAFE
-PTHREAD_LIBS= -pthread
-.endif
.else
QT_ADD= ""
PTHREAD_CFLAGS=
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 60fb50126174..edfed2aadb1d 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -21,7 +21,7 @@ INSTALLS_SHLIB= yes
pre-patch:
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|-release \$$\(LT_RELEASE\)||g'
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g ; \
s|=c_r|=pthread|g' ${WRKSRC}/configure
diff --git a/devel/dmalloc/Makefile b/devel/dmalloc/Makefile
index c6df7b21d776..a8ecfa7b6c9c 100644
--- a/devel/dmalloc/Makefile
+++ b/devel/dmalloc/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS+=--enable-threads --enable-shlib
ALL_TARGET= dmalloc_t all light
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dmalloc ${PREFIX}/bin
diff --git a/devel/dryad/Makefile b/devel/dryad/Makefile
index 28d27263c2b3..1bdadf1758b6 100644
--- a/devel/dryad/Makefile
+++ b/devel/dryad/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index 4de0c11ba352..670f4c2671c0 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 4de0c11ba352..670f4c2671c0 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gide/Makefile b/devel/gide/Makefile
index db77f92b532e..13446a9ca1ee 100644
--- a/devel/gide/Makefile
+++ b/devel/gide/Makefile
@@ -28,7 +28,7 @@ MAN1= gide.1 gdbio.1
PLIST_SUB= VERSION=${PORTVERSION}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/devel/glade/Makefile b/devel/glade/Makefile
index 46e718fd981b..ea47aa04f408 100644
--- a/devel/glade/Makefile
+++ b/devel/glade/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/libs"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index 46e718fd981b..ea47aa04f408 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/libs"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/devel/gnome-crash/Makefile b/devel/gnome-crash/Makefile
index 1f660cd5c84b..70f999a3dabf 100644
--- a/devel/gnome-crash/Makefile
+++ b/devel/gnome-crash/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 52a64d518e8d..e10c3bff11d8 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN5= gnome-vfs-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 52a64d518e8d..e10c3bff11d8 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN5= gnome-vfs-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gnomecrash/Makefile b/devel/gnomecrash/Makefile
index 1f660cd5c84b..70f999a3dabf 100644
--- a/devel/gnomecrash/Makefile
+++ b/devel/gnomecrash/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gnomedebug/Makefile b/devel/gnomedebug/Makefile
index 2d5dbb7accf5..822ae0027184 100644
--- a/devel/gnomedebug/Makefile
+++ b/devel/gnomedebug/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index 52a64d518e8d..e10c3bff11d8 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN5= gnome-vfs-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 52a64d518e8d..e10c3bff11d8 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN5= gnome-vfs-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/gtranslator/Makefile b/devel/gtranslator/Makefile
index 75ab7b1996dc..d5afda67e1e2 100644
--- a/devel/gtranslator/Makefile
+++ b/devel/gtranslator/Makefile
@@ -31,7 +31,7 @@ MAN1= gtranslator.1
MANCOMPRESSED= yes
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/libgii/Makefile b/devel/libgii/Makefile
index 15c512b5d2ef..c70ecb475674 100644
--- a/devel/libgii/Makefile
+++ b/devel/libgii/Makefile
@@ -18,7 +18,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
# NOTE: We can not define USE_LIBTOOL for this port to build.
#USE_LIBTOOL= yes
-CFLAGS+= -pthread
+CFLAGS+= ${PTHREAD_LIBS}
MAN1= mhub.1
MAN3= giiEventPoll.3gii giiInit.3gii giiOpen.3gii \
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index 7bb3906e8a14..75269fc7e812 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/libgtop2/Makefile b/devel/libgtop2/Makefile
index 7bb3906e8a14..75269fc7e812 100644
--- a/devel/libgtop2/Makefile
+++ b/devel/libgtop2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 27a0c1a99094..82e5c6894f2b 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/pharmacy/Makefile b/devel/pharmacy/Makefile
index 181cf7241b04..a6ed2390e2fe 100644
--- a/devel/pharmacy/Makefile
+++ b/devel/pharmacy/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV+= CPPCFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/devel/sdl-devel/Makefile b/devel/sdl-devel/Makefile
index 2978e3de90de..f25238362a95 100644
--- a/devel/sdl-devel/Makefile
+++ b/devel/sdl-devel/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ARGS= --enable-video-aalib \
--disable-arts \
--disable-nas
-CFLAGS+= -D_THREAD_SAFE
+CFLAGS+= ${PTHREAD_CFLAGS}
.if exists(/usr/lib/libvgl.so.3)
CONFIGURE_ARGS+=--enable-video-vgl
diff --git a/devel/sdl/Makefile b/devel/sdl/Makefile
index ec5af0dceefb..a86a566db247 100644
--- a/devel/sdl/Makefile
+++ b/devel/sdl/Makefile
@@ -26,7 +26,7 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm"
CONFIGURE_ARGS= --enable-video-svga
-CFLAGS+= -D_THREAD_SAFE
+CFLAGS+= ${PTHREAD_CFLAGS}
post-configure:
@${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
diff --git a/devel/sdl10/Makefile b/devel/sdl10/Makefile
index ec5af0dceefb..a86a566db247 100644
--- a/devel/sdl10/Makefile
+++ b/devel/sdl10/Makefile
@@ -26,7 +26,7 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm"
CONFIGURE_ARGS= --enable-video-svga
-CFLAGS+= -D_THREAD_SAFE
+CFLAGS+= ${PTHREAD_CFLAGS}
post-configure:
@${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 2978e3de90de..f25238362a95 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ARGS= --enable-video-aalib \
--disable-arts \
--disable-nas
-CFLAGS+= -D_THREAD_SAFE
+CFLAGS+= ${PTHREAD_CFLAGS}
.if exists(/usr/lib/libvgl.so.3)
CONFIGURE_ARGS+=--enable-video-vgl
diff --git a/devel/titano/Makefile b/devel/titano/Makefile
index d95159b4b2c6..a87dbf49cd06 100644
--- a/devel/titano/Makefile
+++ b/devel/titano/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/veepee/Makefile b/devel/veepee/Makefile
index 1819d8f9ce92..3f6bf91fc2b3 100644
--- a/devel/veepee/Makefile
+++ b/devel/veepee/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
USE_XLIB= yes
USE_PYTHON= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= LDFLAGS="-pthread ${PYTHON_LIBS}"
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS} ${PYTHON_LIBS}"
CONFIGURE_ARGS= --with-gd-includes=${LOCALBASE}/include/gd \
--disable-kde
.if exists(/usr/lib/libcrypto.a)
@@ -28,7 +28,7 @@ PYTHON_LIBS+= -lssl -lcrypto
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
post-configure: