aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-08-11 14:45:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-08-11 14:45:37 +0000
commit9b9e8484559ef64514abda4c5463d734543c6f62 (patch)
tree0391e648a29b3b5d4af6af4606bd462e0d49bef7 /devel
parent399c738f0dfba6257c81f691c5b306e8a6addcc8 (diff)
downloadports-9b9e8484559ef64514abda4c5463d734543c6f62.tar.gz
ports-9b9e8484559ef64514abda4c5463d734543c6f62.zip
MFH: r508626
devel/ghidra: Fix build error caused by cache cleanup The issue seems to be caused by Gradle caches being cleaned up between build sessions [1]. It did not come up before because the cached files were not old enough to be deleted. Cleanup happens after a build session, so running the two build targets (yajswDevUnpack and buildGhidra) in the same session fixes the issue. [1] https://docs.gradle.org/current/userguide/directory_layout.html#dir:gradle_user_home:cache_cleanup) PR: 239472 Submitted by: Tamas Szakaly <sghctoma@gmail.com> (maintainer) Approved by: ports-secteam build fix blanket
Notes
Notes: svn path=/branches/2019Q3/; revision=508627
Diffstat (limited to 'devel')
-rw-r--r--devel/ghidra/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/devel/ghidra/Makefile b/devel/ghidra/Makefile
index 16248215250d..6fb675273b78 100644
--- a/devel/ghidra/Makefile
+++ b/devel/ghidra/Makefile
@@ -100,8 +100,7 @@ post-patch-JDK12-on:
@${ECHO_CMD} "org.gradle.java.home=${LOCALBASE}/openjdk12" > ${WRKSRC}/gradle.properties
do-build:
- cd ${WRKSRC} && ${GRADLE_RUN} yajswDevUnpack
- cd ${WRKSRC} && ${GRADLE_RUN} buildGhidra
+ cd ${WRKSRC} && ${GRADLE_RUN} yajswDevUnpack buildGhidra
post-build:
@${RM} ${GRADLE_HOME_BASE}/gradle-${PORTNAME}