aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-09-30 20:20:19 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-09-30 20:20:19 +0000
commita02c48b9da99510a14abc1b21196d3cd18996ae5 (patch)
tree8678fb8d19118b1dd40a46910ebb55eeae403303 /devel
parent0d6fac21f43c8b2a78e0567388336cd440c8e233 (diff)
downloadports-a02c48b9da99510a14abc1b21196d3cd18996ae5.tar.gz
ports-a02c48b9da99510a14abc1b21196d3cd18996ae5.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/libvirt/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 0a7b762fdd40..fc9f071c791f 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -42,8 +42,10 @@ CONFIGURE_ARGS= --without-sasl \
--with-ssh2
# workaround to override pkg-config calls
+# random_data fix can be removed when 8.x is eol
CONFIGURE_ENV= SSH2_LIBS="-L${LOCALBASE}/lib -lssh2 -lssl" \
- SSH2_CFLAGS="-I${LOCLABASE}/include"
+ SSH2_CFLAGS="-I${LOCLABASE}/include" \
+ ac_cv_type_struct_random_data=""
# limit production release x.x.x
PORTSCOUT= limit:\d+\.\d+\.\d+$$
@@ -66,6 +68,10 @@ MAN1= virsh.1 virt-pki-validate.1 virt-xml-validate.1 virt-host-validate.1
MAN8= libvirtd.8 virtlockd.8
post-patch:
+.if ${OSVERSION} < 900000
+ @${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||' \
+ ${WRKSRC}/configure
+.endif
@${MV} ${WRKSRC}/daemon/libvirtd.conf ${WRKSRC}/daemon/libvirtd.conf.sample
@${REINPLACE_CMD} -e 's|libvirtd\.conf|libvirtd.conf.sample|' \
${WRKSRC}/daemon/Makefile.in